Dolphinrc file reverted by dolphin at startup - but I need to set my preferences

As I was trying to solve this issue and apply the 'solution'
( Move Top Panel window appmenu to application window - #3 by Dadrake )

I noticed that the .config/dolphinrc that I edited is reverted back to its previous settings (in my back).

I'm sorry I didn't find any lead in my search (forum or online).

So, what's going on? Why can't I set my preferences in the rc file as I wish?

Kernel: 6.4.11-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
available: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e0c57a88-dedd-4c35-aadb-58146b98b7f2 rw rootflags=subvol=@ quiet quiet
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
Console: pty pts/0 DM: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: H97N-WIFI serial: <superuser required>
UEFI: American Megatrends v: F8 date: 08/03/2015
Info: model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell gen: core 4 level: v3
note: check built: 2013-15 process: Intel 22nm family: 6 model-id: 0x3C (60) stepping: 3
microcode: 0x28
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB
L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1931 high: 3400 min/max: 800/3400 scaling: driver: intel_cpufreq
governor: schedutil cores: 1: 1078 2: 800 3: 3400 4: 2447 bogomips: 25540
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics vendor: Gigabyte
driver: i915 v: kernel arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: none
empty: HDMI-A-1, HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0300
Device-2: NVIDIA GM204 [GeForce GTX 970] driver: nvidia v: 535.104.05
alternate: nouveau,nvidia_drm non-free: 535.xx+ status: current (as of 2023-08) arch: Maxwell
code: GMxxx process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
Display: server: v: with: Xwayland v: 23.2.0 compositor: kwin_x11 driver: X:
loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: crocus
gpu: i915,nvidia tty: 110x28
API: OpenGL Message: GL data unavailable in console. Try -G --display
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel
bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403
Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte 9 driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:8ca0 class-ID: 0403
Device-3: NVIDIA GM204 High Definition Audio driver: snd_hda_intel v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fbb
class-ID: 0403
API: ALSA v: k6.4.11-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.77 status: active (process) with: 1: pipewire-pulse status: active
2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: kernel port: f080
bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 04:00.0 chip-ID: 8086:08b1 class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-11:3 chip-ID: 8087:07dc class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0 lmp-v: 6 status:
discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 465.76 GiB used: 9.54 GiB (2.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: 2B6Q scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 9.53 GiB (2.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 9.53 GiB (2.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 9.53 GiB (2.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 9.53 GiB (2.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 36.0 C mobo: N/A gpu: nvidia temp: 43 C
Fan Speeds (rpm): N/A
Processes: 221 Uptime: 19m wakeups: 0 Memory: total: 8 GiB available: 7.62 GiB
used: 2.52 GiB (33.0%) Init: systemd v: 254 default: graphical tool: systemctl Compilers:
gcc: 13.2.1 Packages: pm: pacman pkgs: 1280 libs: 337 tools: octopi,pamac,paru Shell: Bash
v: 5.1.16 running-in: pty pts/0 inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-24
Last full system update: 2023-08-25
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Please, which Garuda desktop environment you use?

If you use a live ISO changes are not saved.

It's now a proper installation on SSD. :blush:

I'm using the defaut Dragonized setup (the main flavor, the first listed on download page)


This reverted edit happens even without disconnect or reboot. Edit the rc, start dolphin, and it's back to previous settings in the file :cold_sweat: (and I before I could see the edit was effective, reading the rc files with a grep)

My inxi (part)

Kernel: 6.4.12-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
root=UUID=fc62cc44-07ab-497b-ac89-15704c290993 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 amd_pstate=active ibt=off
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux

Could you post your changes, please?
The home folder will be used as first place and never touch by other software.
Sorry I cant explain better :slight_smile:

You mean what I edited in rc file?

Just in case I write the whole thing:

  1. Fresh install on brand new SSD, Garuda Linux KDE Dragonized edition, main flavor, just the locale settings for time, language and keyboard.
  2. Create my main account, no much customization
  3. Create the Guest account, the one I experiment with.
  4. On the guest account, or from the main account: just edit the ~guest/.config/dolphinrc
    Either with

sed -i ‘s/MenuBar=Disabled/MenuBar=Enabled/’ *rc

or with vi to do the same change.
5. Start dolphin from guest: the dolphinrc is reverted. :cold_sweat:

I did some audit, and I have the proof that the dolphin is the culprit, writing to the rc at startup. :rage: :sob: (so I edited the post title for that)

Does it make any difference with the main account?
I understand you're using the guest account for testing and not "dirty" the main one, but your installation is new, so you could still create a further account later (or now for testing).
Edit: I see now you already did it "from the main account", sorry (I assume you updated always the relevant ~/.config/dolphinrc file)...

Yes, I tried both:

  • edit ~guest/.config/dolphinrc from the main account without guest being logged on.
  • edit the same file from guest account, after normal graphical login

I mean you should try it for the main user, not for the guest account (that one could have a different behaviour).
Login as main user and try changing ~/.config/dolphinrc, not ~guest/.config/dolphinrc.
For example, if you change dolphinrc from the main account, it could be that when you login as guest that file is overwritten starting from the skel defaults, because guest accounts should be frozen.

Yeah, I think this is expected behavior. I tried the same and everytime I open dolphin the changes in dolphinrc are reverted. It seems dolphin recreates dolphinrc every startup instead of reading from it for some reason. I even tried to making the file immutable but dolphin threw an error the file is not writeable before proceeding and not caring about the options in the dolphinrc at all.



I edited both


to change MenuBar=Disabled to MenuBar=Enabled and then...
... at least if doesn't bring the MenuBar=Disabled, the line is just remove.

And I can get the menu bar with Ctrl-M
(work for dolphin, not Chrome)

(I also unloaded the wiget, not sure if it was required qdbus org.kde.kded5 /kded org.kde.kded5.unloadModule "appmenu"

I'll tag this solution if I narrow down the bare minimum.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.