Desktop Reset after atx hard reboot signal

This morning, booted my computer, launched discord, lutris, and FFXIV (get in the login queue while i do some chores). It was taking a while to launch the game and discord, so I walked away to get started making coffee, feeding pets, and cleaning the kitchen. Normal Sunday morning stuff.

I came back to discord frozen on the desktop, unable to move the mouse... I spammed the keyboard a little, clicked a few times, moved the mouse and decided it was hopeless. I long pressed the power button.

I reboot to an empty latte dock, no top bar. Looks like my configuration was completely lost.

I found a similar post here (that i'm unable to locate again, of course) and tried some things from there, most notably, reset to a snapshot from December. Did not work

Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=5ed66716-13d2-4876-8c98-0563b45e4251 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE v: x.x
serial: <superuser required> UEFI: American Megatrends LLC. v: F34
date: 06/10/2021
ID-1: hidpp_battery_0 charge: 73% condition: N/A volts: 3.9 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: Discharging
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3948 high: 4286 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3733 2: 4219
3: 4169 4: 4238 5: 4178 6: 4110 7: 4162 8: 4249 9: 4163 10: 4258 11: 4127
12: 3462 13: 3469 14: 3535 15: 4012 16: 4006 17: 4196 18: 4133 19: 3584
20: 4106 21: 3764 22: 3474 23: 4270 24: 3797 25: 4024 26: 4222 27: 4286
28: 3549 29: 3563 30: 3637 31: 4171 32: 3482 bogomips: 223585
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 09:00.0
chip-ID: 10de:1e84 class-ID: 0300
Display: x11 server: X.Org compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 108 s-size: 1204x342mm (47.4x13.5")
s-diag: 1252mm (49.3")
Monitor-1: DP-2 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
Monitor-2: DP-4 res: 2560x1440 hz: 60 dpi: 109
size: 598x336mm (23.5x13.2") diag: 686mm (27")
OpenGL: renderer: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 495.46 direct render: Yes
Device-1: YUAN High-Tech Development driver: N/A bus-ID: 05:00.0
chip-ID: 12ab:0380 class-ID: 0480
Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f8
class-ID: 0403
Device-3: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-4: TC Electronic GoXLR type: USB driver: snd-usb-audio
bus-ID: 1-2:2 chip-ID: 1220:8fe0 class-ID: 0102
Device-5: Texas Instruments ATH-G1WL type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.3.2:7
chip-ID: 0451:16ba class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
port: f000 bus-ID: 04:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 3.66 TiB used: 790.41 GiB (21.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX6000PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: V9002s85
temp: 34.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EARX-00ZUDB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-1: / raw-size: 923.02 GiB size: 923.02 GiB (100.00%)
used: 338.95 GiB (36.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 498 MiB size: 497 MiB (99.79%)
used: 235.5 MiB (47.4%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 923.02 GiB size: 923.02 GiB (100.00%)
used: 338.95 GiB (36.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 923.02 GiB size: 923.02 GiB (100.00%)
used: 338.95 GiB (36.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 923.02 GiB size: 923.02 GiB (100.00%)
used: 338.95 GiB (36.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda4 maj-min: 8:4
ID-2: swap-2 type: zram size: 31.35 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 27.0 C mobo: 26.0 C gpu: nvidia temp: 40 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 23%
Processes: 578 Uptime: 3m wakeups: 2 Memory: 31.35 GiB
used: 4.08 GiB (13.0%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2015 lib: 524 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

Have you tried resetting latte to default config with the Garuda assistant?

Dr460nized.layout.latte in my ~/.config folder is empty. I think this is the one I was modifying. I guess it corrupted on reboot?

I'm not sure what this should look like honestly, so I don't know what I don't know here. It's not clear to me what else might've been corrupted.

No. Corrupted by


Open Krunner (normally shortcuts could be alt+space or alt+F2) and launch Garuda Assistant. From there reset default config flagging latte.
Then right click on desktop to logoff.

1 Like

I was hoping there was a way to get my original config back, I did a lot of customization to it.

Ah well, here's to fresh starts. Thank you for all your help.

I learned something when googling, hopefully it works for me: Raising Elephants Is So Utterly Boring... I don't have the key on my keyboard, but some had success with Alt + PrintScr + R, E, ... etc. Would this procedure work in Garuda? Ctrl + Alt + Backspace also received honorable mention for killing X11 graphical environment and restarting it.

What should I do next time i get a full desktop lockup?

1 Like

I wonder why latte-dock is so unstable when it comes to its config..
This is such a common issue, even I've had it countless times while testing in a VM.

1 Like

I could write a script for crontab to back it up each night. Maybe that should be explored for the next update?

I was indeed thinking about writing up a quick systemd user oneshot unit to backup the file, and if it's empty, restore it. But ideally this should be debugged and fixed upstream :eyes:


A good practice could be to export your latte config as a backup file and import as needed.

Perhaps we need to start including BackInTime by default, as most users just can't comprehend that a snapshot is not a comprehensive backup. Almost daily we read complaints on the forum that timeshift/snapper does not restore the user configs stored in the home directory. That is the users job (get on it people, we can't do everything for you).

1 Like

No backup.

No compassion.


There is no latte bug report so there is no bug to fix.

Configuration files issue I havent encountered in my latte system for the last two years.

You might get surprised that this could be a garuda specific issue that might be encountered from distro restoring files on its own.

Make sure also in Layouts editor to enable, Single layout at all cases, it provides the best stability for your configuration file.

The raising elephants SysRq sequence is useful, but nowadays it is typically not enabled by default. It's pretty easy to set up though:


It is the same as the PrtSc key. Traditionally the keycap would say both SysRq and PrtSc, but a lot of manufacturers leave off SysRq because it is meaningless to most people.

On some laptops you have to engage the Fn key as well to get the SysRq/PrtSc key.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.