Desktop frozen BUT the mouse still moves. how to restart desktop?

hi, after a 9 days of stable uptime my garuda dragonized laptops desktop seems to have frozen BUT the mouse still moves. i can ssh in from another pc. what could let me unfreeze it ? or restart kde? i looked online but alt+space alt+f2 did nothing and i tried kquitapp5 plasmashell and kstart5 plasmashell but they did nothing. it seems fine on a low load using half its ram and running two docker containers all day. i had x11vnc running fine on a win10 pc w tigervnc viewer

i tried
kquitapp5 plasmashell
but it said:
"Application plasmashell could not be found using service org.kde.plasmashell and path /MainApplication."

i looked at:
systemctl status ananicy-cpp irqbalance preload prelockd auto-cpufreq memavaild
Unit ananicy-cpp.service could not be found.
Unit irqbalance.service could not be found.
Unit preload.service could not be found.
Unit prelockd.service could not be found.
Unit auto-cpufreq.service could not be found.
Unit memavaild.service could not be found.

garuda-inxi

System:
  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=465a57ac-bb20-4c36-8b4f-9271cbda9245
    rw [email protected] quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8516699a-d5f3-454d-9715-25cc6d6cca39 loglevel=3 ibt=off
  Console: pty pts/5 DM: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: Vivobook_ASUSLaptop N7601ZM_N7601ZM v: 1.0
    serial: <filter>
  Mobo: ASUSTeK model: N7601ZM v: 1.0 serial: <filter> UEFI: American Megatrends LLC.
    v: N7601ZM.205 date: 04/29/2022
Battery:
  ID-1: BAT0 charge: 91.8 Wh (100.0%) condition: 91.8/90.0 Wh (101.9%) volts: 17.3 min: 15.9
    model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: full cycles: 2
CPU:
  Info: model: 12th Gen Intel Core i7-12650H socket: U3E1 bits: 64 type: MST AMCP arch: Alder Lake
    gen: core 12 level: v3 note: check built: 2021+ process: Intel 7 (10nm ESF) family: 6
    model-id: 0x9A (154) stepping: 3 microcode: 0x424
  Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled cache: L1: 864 KiB
    desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB
    desc: 1x24 MiB
  Speed (MHz): avg: 2476 high: 2700 min/max: 400/4600:4700:3500 base/boost: 4059/4700 scaling:
    driver: intel_pstate governor: powersave volts: 1.3 V ext-clock: 100 MHz cores: 1: 2700 2: 2700
    3: 2700 4: 2700 5: 2700 6: 2700 7: 1100 8: 2700 9: 2700 10: 2700 11: 2700 12: 2700 13: 2700
    14: 2700 15: 2700 16: 721 bogomips: 86016
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW
    sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: DP-1,eDP-1 empty: DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a3 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+ status: current (as of 2022-12)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:2520 class-ID: 0300
  Device-3: USB C Video Adaptor type: USB driver: N/A bus-ID: 3-1.1:4 chip-ID: 25a4:9311
    class-ID: 1100 serial: <filter>
  Device-4: Sonix USB2.0 FHD UVC WebCam type: USB driver: uvcvideo bus-ID: 3-9:7
    chip-ID: 3277:0016 class-ID: 0e02
  Display: x11 server: X.org v: 1.21.1.6 with: Xwayland v: 22.1.7 compositor: kwin_x11 driver:
    X: loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
    gpu: i915 tty: 237x63
  Monitor-1: DP-1 model: Asus VX248 serial: <filter> built: 2013 res: 1920x1080 dpi: 92
    gamma: 1.2 size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes: max: 1920x1080
    min: 720x400
  Monitor-2: eDP-1 model: AU Optronics 0xc199 built: 2021 res: 2560x1600 dpi: 189 gamma: 1.2
    size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10 modes: 2560x1600
  API: OpenGL Message: GL data unavailable in console for root.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel,snd_sof_pci_intel_tgl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:228e class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel port: 3000
    bus-ID: 0000:2e:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK vendor: AzureWave driver: mt7921e v: kernel port: N/A bus-ID: 0000:2f:00.0
    chip-ID: 14c3:7922 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: cdc_ncm bus-ID: 2-1.2:3
    chip-ID: 0b95:1790 class-ID: 0a00 serial: <filter>
  IF: enp0s13f0u1u2c2 state: down mac: <filter>
  IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-2: veth29d7287 state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-3: veth41473e4 state: up speed: 10000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8 bus-ID: 3-10:8
    chip-ID: 13d3:3568 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: N/A
    bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
  Local Storage: total: 2.81 TiB used: 69.59 GiB (2.4%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 MTFDKBA1T0TFH size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: P7MA002 temp: 41.9 C scheme: GPT
  SMART: yes health: PASSED on: 26 hrs cycles: 70 read-units: 1,263,654 [646 GB]
    written-units: 1,294,564 [662 GB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB
    block-size: physical: 4096 B logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: Flash Disk size: 58.2 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 8.01 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 919.42 GiB size: 919.42 GiB (100.00%) used: 47.46 GiB (5.2%) fs: btrfs
    block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB (0.2%) fs: vfat
    block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 919.42 GiB size: 919.42 GiB (100.00%) used: 47.46 GiB (5.2%) fs: btrfs
    block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 919.42 GiB size: 919.42 GiB (100.00%) used: 47.46 GiB (5.2%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 919.42 GiB size: 919.42 GiB (100.00%) used: 47.46 GiB (5.2%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.15 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 31.05 GiB used: 113.2 MiB (0.4%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 41 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 458 Uptime: 9d 5h 58m wakeups: 19351 Memory: 31.05 GiB used: 13.07 GiB (42.1%)
  Init: systemd v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1389 libs: 330 tools: octopi,paru Shell: Bash (sudo) v: 5.1.16
  running-in: pty pts/5 (SSH) inxi: 3.3.24
Garuda (2.6.12-1):
  System install date:     2022-12-06
  Last full system update: 2023-01-04 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            [email protected]

i dont understand how to / why i cant restart kde plasma or if that is the right thing to try?

i did journalctl -xe
in the journal there were many many lin
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old
Jan 05 18:53:37 avp22 kscreenlocker_greet[536510]: QXcbClipboard: SelectionRequest too old

at the end i saw it ran its hourly snapper and also this
Jan 05 19:00:12 avp22 dbus-daemon[655]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.1487' (uid=1000 pid=536510 comm="/usr/lib/kscreenlocker_greet --gra>
Jan 05 19:00:12 avp22 dbus-daemon[655]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Jan 05 19:00:12 avp22 kscreenlocker_greet[536510]: pam_systemd_home(kde:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.

i tried a shutdown and start, it just hangs at Loading initialramdisk

i tried boot from a snapshot a few hours ago and it showed the garuda screen a moment and then just a black screen saying:
Failed to start docker application engine
what might be the next step?

thanks in advance

If you are able to ssh in, just run systemctl reboot.

It looks like a reboot is called for anyway.

why would it now hang on bootup saying
[FAILED] Failed to start docker application engine

that stops the garuda OS from booting to the login screen?
wow.
any idea how to fix ?

No, you do not need Docker to boot. But why did it fail?

i dont know. makes no sense.
i tried recovery mode and systemctl disable docker
restarted and it just hangs on loading initial ramdisk...

thought that might solve it and let me in to see what problems there are.
big bummer because i had portainer and x11vnc working so nice for 2 days and everything was stable and productive finally...now i cant even log in.

tried booting the linux-lts kernel. also hangs on loading initial ramdisk...
tried a snapshot from day. one time i hit the ESC key to see what text there was to see and it said :
setfont: KDFONTOP: Function not implemented

i finally got logged in with a snapshot from days ago before i setup x11vnc .

my first usecase to do flutter dev on it failed bc it never fully worked. other usecase was portainer and dockers. didnt go well. is this distro suitable for this kind of work?

now im not sure what to do next...???

im not sure but it seems like journal says docker had errors related to graphdriver and btrfs (wrong filesystem?)

wierd bc the 2 docker containers were running fine for days and portainer had no problems.

" btrfs is supported if you meet the following prerequisites:

  • Docker Engine - Community: For Docker Engine - Community, btrfs is only recommended on Ubuntu or Debian.
    "

if true this is dissappointing. i just dont understand why it ran ok for days until plasma locked up and reboot couldnt get to the login screen.

I'm not sure the source of the issues you are having; it sound like there may be more than one problem.

The only glaring issue I can see is from your inxi it looks like you took an update (including updating the kernel, I would guess judging by the dates and the kernel version noted) but left the system running instead of rebooting. Sometimes services need to be stopped/restarted after updates, and after a kernel update it is good to fully reboot--otherwise, certain things can be broken.

It is better to not update every day if the system is going to have continuous uptime like this. Updating once a week is fine, or even every couple of weeks but you should do it when you will have time to take a full reboot afterward.

Recently some folks have had issues getting stuck on Plymouth after updating (maybe a bug in Plymouth). Try removing splash from the kernel parameters to see if it helps. Fresh Garuda installation won’t boot except in recovery mode - #7 by Alenox

This is not needed for running Docker on a Btrfs system--rather, this would be used if you wanted to set up a Btrfs filesystem inside your Docker container. I'm not sure what the errors you had were about (paste them into the thread so we can take a look), but you don't need to set this up to use Docker.

The main workflow change I would recommend would be to have a more cautious update strategy if you want to have a prolonged uptime. Get ready before pulling down an update (make backups if you have a system in place, etc), then reboot afterward and troubleshoot any issues that the update pulled down.

This is not intended to be a maintenance-free distro, if that is what you mean. If you want something that can run and run and run for weeks or months with hardly any maintenance or intervention, you may be better served by a distro like Debian (easy mode) or NixOS (some assembly required).

2 Likes

Personally, I run several docker containers across several of my garuda installs. I also run vm's on one. I haven't tried portainer on garuda, but i discovered i really dislike portainer so there is that.

Please note, i don't end up with 99% of the issues people are reporting. so that is a "just works * " from another user.

1 Like

hi, for recovery i have daily and hourly snapper snapshots. tried to use a gui for borg backup but it had issues i havent overcome yet. id like to do a weekly clonezilla too as disaster backup strategy.
yeah, perhaps a reboot days ago after an update and tinkering w different vnc solutions would have been wise.

Per DOCKER i found this:
journalctl -xeu docker.service

β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A start job for unit docker.service has finished with a failure.
β–‘β–‘
β–‘β–‘ The job identifier is 4512 and the job result is failed.
Jan 05 21:04:52 avp22 systemd[1]: docker.service: Scheduled restart job, restart counter is at 2.
β–‘β–‘ Subject: Automatic restarting of a unit has been scheduled
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ Automatic restarting of the unit docker.service has been scheduled, as the result for
β–‘β–‘ the configured Restart= setting for the unit.
Jan 05 21:04:52 avp22 systemd[1]: Stopped Docker Application Container Engine.
β–‘β–‘ Subject: A stop job for unit docker.service has finished
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A stop job for unit docker.service has finished.
β–‘β–‘
β–‘β–‘ The job identifier is 4632 and the job result is done.
Jan 05 21:04:52 avp22 systemd[1]: Starting Docker Application Container Engine...
β–‘β–‘ Subject: A start job for unit docker.service has begun execution
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A start job for unit docker.service has begun execution.
β–‘β–‘
β–‘β–‘ The job identifier is 4632.
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.762920994-05:00" level=info msg="Starting up"
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.763365774-05:00" level=info msg="libcontainerd: started new containerd process" pid=3708
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.763381776-05:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.763385484-05:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.763394500-05:00" level=info msg="ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock  <nil> 0 <nil>}] <nil> <nil>}" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.763398466-05:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52-05:00" level=warning msg="containerd config version `1` has been deprecated and will be removed in containerd v2.0, please switch to version `2`, see https://github.com/containerd/containerd>
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.771995589-05:00" level=info msg="starting containerd" revision=9ba4b250366a5ddde94bb7c9d1def331423aa323.m version=v1.6.14
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.778104792-05:00" level=info msg="loading plugin \"io.containerd.content.v1.content\"..." type=io.containerd.content.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.778134695-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.aufs\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779031786-05:00" level=info msg="skip loading plugin \"io.containerd.snapshotter.v1.aufs\"..." error="aufs is not supported (modprobe aufs failed: exit status 1 \"modprobe: FATAL: Module auf>
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779042805-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.btrfs\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779141328-05:00" level=info msg="skip loading plugin \"io.containerd.snapshotter.v1.btrfs\"..." error="path /var/lib/docker/containerd/daemon/io.containerd.snapshotter.v1.btrfs (overlay) mus>
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779148723-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.devmapper\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779157540-05:00" level=warning msg="failed to load plugin io.containerd.snapshotter.v1.devmapper" error="devmapper not configured"
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779164522-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.native\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779178923-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.overlayfs\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779255886-05:00" level=info msg="loading plugin \"io.containerd.snapshotter.v1.zfs\"..." type=io.containerd.snapshotter.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779325594-05:00" level=info msg="skip loading plugin \"io.containerd.snapshotter.v1.zfs\"..." error="path /var/lib/docker/containerd/daemon/io.containerd.snapshotter.v1.zfs must be a zfs fil>
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779333109-05:00" level=info msg="loading plugin \"io.containerd.metadata.v1.bolt\"..." type=io.containerd.metadata.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779344167-05:00" level=warning msg="could not use snapshotter devmapper in metadata plugin" error="devmapper not configured"
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779350301-05:00" level=info msg="metadata content store policy set" policy=shared
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779396316-05:00" level=info msg="loading plugin \"io.containerd.differ.v1.walking\"..." type=io.containerd.differ.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779405686-05:00" level=info msg="loading plugin \"io.containerd.event.v1.exchange\"..." type=io.containerd.event.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779413901-05:00" level=info msg="loading plugin \"io.containerd.gc.v1.scheduler\"..." type=io.containerd.gc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779430292-05:00" level=info msg="loading plugin \"io.containerd.service.v1.introspection-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779439814-05:00" level=info msg="loading plugin \"io.containerd.service.v1.containers-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779449462-05:00" level=info msg="loading plugin \"io.containerd.service.v1.content-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779458589-05:00" level=info msg="loading plugin \"io.containerd.service.v1.diff-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779474849-05:00" level=info msg="loading plugin \"io.containerd.service.v1.images-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779484354-05:00" level=info msg="loading plugin \"io.containerd.service.v1.leases-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779494844-05:00" level=info msg="loading plugin \"io.containerd.service.v1.namespaces-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779503702-05:00" level=info msg="loading plugin \"io.containerd.service.v1.snapshots-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779512324-05:00" level=info msg="loading plugin \"io.containerd.runtime.v1.linux\"..." type=io.containerd.runtime.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779546975-05:00" level=info msg="loading plugin \"io.containerd.runtime.v2.task\"..." type=io.containerd.runtime.v2
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779570894-05:00" level=info msg="loading plugin \"io.containerd.monitor.v1.cgroups\"..." type=io.containerd.monitor.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779690788-05:00" level=info msg="loading plugin \"io.containerd.service.v1.tasks-service\"..." type=io.containerd.service.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779704548-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.introspection\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779714012-05:00" level=info msg="loading plugin \"io.containerd.internal.v1.restart\"..." type=io.containerd.internal.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779790844-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.containers\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779953619-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.content\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.779987579-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.diff\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780032212-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.events\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780053479-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.healthcheck\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780070969-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.images\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780083814-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.leases\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780095816-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.namespaces\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780111171-05:00" level=info msg="loading plugin \"io.containerd.internal.v1.opt\"..." type=io.containerd.internal.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780140994-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.snapshots\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780154462-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.tasks\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780166947-05:00" level=info msg="loading plugin \"io.containerd.grpc.v1.version\"..." type=io.containerd.grpc.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780178660-05:00" level=info msg="loading plugin \"io.containerd.tracing.processor.v1.otlp\"..." type=io.containerd.tracing.processor.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780197641-05:00" level=info msg="skip loading plugin \"io.containerd.tracing.processor.v1.otlp\"..." error="no OpenTelemetry endpoint: skip plugin" type=io.containerd.tracing.processor.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780210263-05:00" level=info msg="loading plugin \"io.containerd.internal.v1.tracing\"..." type=io.containerd.internal.v1
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780226690-05:00" level=error msg="failed to initialize a tracing processor \"otlp\"" error="no OpenTelemetry endpoint: skip plugin"
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780468091-05:00" level=info msg=serving... address=/var/run/docker/containerd/containerd-debug.sock
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780504418-05:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock.ttrpc
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780533194-05:00" level=info msg=serving... address=/var/run/docker/containerd/containerd.sock
Jan 05 21:04:52 avp22 dockerd[3708]: time="2023-01-05T21:04:52.780544212-05:00" level=info msg="containerd successfully booted in 0.008865s"
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.784824834-05:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.784835281-05:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.784845680-05:00" level=info msg="ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock  <nil> 0 <nil>}] <nil> <nil>}" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.784850079-05:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785458394-05:00" level=info msg="parsed scheme: \"unix\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785466061-05:00" level=info msg="scheme \"unix\" not registered, fallback to default scheme" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785473713-05:00" level=info msg="ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock  <nil> 0 <nil>}] <nil> <nil>}" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785479739-05:00" level=info msg="ClientConn switching balancer to \"pick_first\"" module=grpc
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785770751-05:00" level=error msg="[graphdriver] prior storage driver btrfs failed: prerequisites for driver not satisfied (wrong filesystem?)"
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785948818-05:00" level=info msg="stopping healthcheck following graceful shutdown" module=libcontainerd
Jan 05 21:04:52 avp22 dockerd[3690]: time="2023-01-05T21:04:52.785982067-05:00" level=info msg="stopping event stream following graceful shutdown" error="context canceled" module=libcontainerd namespace=plugins.moby
Jan 05 21:04:53 avp22 dockerd[3690]: time="2023-01-05T21:04:53.786867331-05:00" level=warning msg="grpc: addrConn.createTransport failed to connect to {unix:///var/run/docker/containerd/containerd.sock  <nil> 0 <nil>}. Err :connection error: desc = \"tr>
Jan 05 21:04:53 avp22 dockerd[3690]: failed to start daemon: error initializing graphdriver: prerequisites for driver not satisfied (wrong filesystem?)
Jan 05 21:04:53 avp22 systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
β–‘β–‘ Subject: Unit process exited
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ An ExecStart= process belonging to unit docker.service has exited.
β–‘β–‘
β–‘β–‘ The process' exit code is 'exited' and its exit status is 1.
Jan 05 21:04:53 avp22 systemd[1]: docker.service: Failed with result 'exit-code'.
β–‘β–‘ Subject: Unit failed
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ The unit docker.service has entered the 'failed' state with result 'exit-code'.
Jan 05 21:04:53 avp22 systemd[1]: Failed to start Docker Application Container Engine.
β–‘β–‘ Subject: A start job for unit docker.service has failed
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A start job for unit docker.service has finished with a failure.
β–‘β–‘
β–‘β–‘ The job identifier is 4632 and the job result is failed.
Jan 05 21:04:53 avp22 systemd[1]: docker.service: Scheduled restart job, restart counter is at 3.
β–‘β–‘ Subject: Automatic restarting of a unit has been scheduled
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ Automatic restarting of the unit docker.service has been scheduled, as the result for
β–‘β–‘ the configured Restart= setting for the unit.
Jan 05 21:04:53 avp22 systemd[1]: Stopped Docker Application Container Engine.
β–‘β–‘ Subject: A stop job for unit docker.service has finished
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A stop job for unit docker.service has finished.
β–‘β–‘
β–‘β–‘ The job identifier is 4752 and the job result is done.
Jan 05 21:04:53 avp22 systemd[1]: docker.service: Start request repeated too quickly.
Jan 05 21:04:53 avp22 systemd[1]: docker.service: Failed with result 'exit-code'.

level=error msg="[graphdriver] prior storage driver btrfs failed: prerequisites for driver not satisfied (wrong filesystem?)

that stood out to me as weird.

other than the portainer docker, i have two python focused dockers and each has a mount to a local folder in documents w my py code (just like on my win10 pc). they were running great for days until the system desktop froze and dropped my x11vnc too (except the mouse which moved around like normal)

i thought to blame docker bc when garuda splash screen popped up and then went to black it usually comes back to the garuda splash w login form. since it wasnt, i hit ESC to see what its doing the next boot and it said [FAILED] docker . i did recovery mode and cmd systemctl disable docker but the next reboot it hung too ...and the ESC key revealed weird FONT error

how would i test the plymouth issue by removing 'splash' option from kernel params from the cmd line when i boot it into recovery mode?
i only ever did that in garudas gui once.

i got in grub, advanced , garuda and hit e key to edit. i saw quiet listed twice and then splash. removed splash and ctrl-x , it booted to a black screen saying:
setfont: KDFONTOP: Function not implemented

any ideas ?

Try adding "setfont" to the BINARIES section of /etc/mkinitcpio.conf.

BINARIES=(setfont)

Then rebuild the initramfs again.

sudo mkinitcpio -P

The black screen is normal after removing splash from the kernel parameters (it disables the Plymouth splash screen), but you shouldn't be stuck on a black screen. Is SDDM starting, or does it just hang?

2 Likes

ok thanks

did those two things.
now it flashes the garuda logo for a few milliseconds and then hangs on a blackscreen saying
loading linux linux-zen...
loading initial ramdisk...

it just sits there.

any other ideas ?

i did get it to boot and login w the december 29 snapshot. should i just go w that and choose to keep it and go from there? or better to keep troubleshooting why it wont let me login from the current state?

It hangs on the LTS kernel as well?

How did you install your Nvidia driver? Is it a DKMS package?

yes it hangs on the lts too . the nvidia driver was installed like this
installed garuda w/o nvidia
and
Garuda Boot Options and add:
ibt=off
to the end of the kernel parameters

garuda-update

sudo pacman -S mhwd

sudo mhwd -a pci nonfree 0300

checked it with
sudo nvidia-smi
it looked good

ran xrandr cmd

it was working on my two addtl monitors

mostly smooth sailing since then.

i got into a dec30 snapshot with zen kernel.
this was before i got x11vnc and my docker images going.
i restored to that.
docker ps works but docker images shows no images that i loaded. ill try those again w reboots n snapshots between each

make sure you aren't using the btrfs driver in docker if you don't actually need it. and try docker's "hello-world" just to get a log of what docker starting up should look like

Does this method survive through kernel versions? I am not really great with Nvida cards, I've never had that particular curse.

Try to install the DKMS version and see if you have better luck.

sudo pacman -S nvidia-dkms
sudo dkms autoinstall
sudo update-grub

Copy/paste the terminal input and output into the thread so if it doesn't work there is some visibility into what is happening.

1 Like

just before your reply i already did a system update via
garuda assistant > maintenance > system update and rebooted twice. did a snap. everything seems good.
i thought i noticed it doing dkms for both the zen and the lts kernel ...

under system specs i see kernel is now 6.1.3-zen and at the end it says Relevant software: nvidia-dkms
under last pacman log it shows ALPM-SCRIPTLET ==> dkms install --nodepmod nvidia/525.78.01 -k
three times, one for each kernel 5.15 lts and 6.0 and 6.1.3

there was a lot of noisy lines from flutter, like 800.

my old kernel was 6.0.12 so it seems like nvidia survived the kernel update from my late december snapshot

last system update pacman log
(i omitted the bulk which was every 775 vs 755 flutter file permission warnings bc it was too much to post, per char limit in this form)

[2023-01-06T13:17:06-0500] [PACMAN] Running 'pacman -Su'

[2023-01-06T13:17:06-0500] [PACMAN] starting full system upgrade

[2023-01-06T13:31:32-0500] [ALPM] running '05-snap-pac-pre.hook'...

[2023-01-06T13:31:32-0500] [ALPM-SCRIPTLET] ==> root: 822

[2023-01-06T13:31:32-0500] [ALPM] running '10-linux-modules-pre.hook'...

[2023-01-06T13:31:34-0500] [ALPM] running '60-mkinitcpio-remove.hook'...

[2023-01-06T13:31:34-0500] [ALPM] running '71-dkms-remove.hook'...

[2023-01-06T13:31:34-0500] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod nvidia/525.60.11 -k 5.15.84-1-lts

[2023-01-06T13:31:34-0500] [ALPM-SCRIPTLET] ==> dkms remove --no-depmod nvidia/525.60.11 -k 6.0.12-zen1-1-zen

[2023-01-06T13:31:35-0500] [ALPM-SCRIPTLET] ==> depmod 5.15.84-1-lts

[2023-01-06T13:31:36-0500] [ALPM-SCRIPTLET] ==> depmod 6.0.12-zen1-1-zen

[2023-01-06T13:31:37-0500] [ALPM] running 'firedragon-pre.hook'...

[2023-01-06T13:31:37-0500] [ALPM] transaction started

[2023-01-06T13:31:37-0500] [ALPM] upgraded iana-etc (20221107-1 -> 20221215-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded a52dec (0.7.4-11 -> 0.7.4-12)

[2023-01-06T13:31:37-0500] [ALPM] upgraded ncurses (6.3-3 -> 6.4-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded aalib (1.4rc5-14 -> 1.4rc5-15)

[2023-01-06T13:31:37-0500] [ALPM] upgraded alsa-card-profiles (1:0.3.63-1 -> 1:0.3.63-4)

[2023-01-06T13:31:37-0500] [ALPM] upgraded libpsl (0.21.1-3 -> 0.21.2-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded curl (7.87.0-1 -> 7.87.0-2)

[2023-01-06T13:31:37-0500] [ALPM] upgraded device-mapper (2.03.17-1 -> 2.03.18-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded libpcap (1.10.1-2 -> 1.10.2-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded nftables (1:1.0.5-1 -> 1:1.0.6-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded file (5.43-1 -> 5.44-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded shadow (4.12.3-2 -> 4.13-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded android-udev (20220903-2 -> 20230104-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded libtiff (4.4.0-4 -> 4.5.0-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded glib2 (2.74.3-1 -> 2.74.4-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded gdk-pixbuf2 (2.42.10-1 -> 2.42.10-2)

[2023-01-06T13:31:37-0500] [ALPM] upgraded appstream (0.15.5-1 -> 0.15.6-1)

[2023-01-06T13:31:37-0500] [ALPM] upgraded libomxil-bellagio (0.9.3-3 -> 0.9.3-4)

[2023-01-06T13:31:37-0500] [ALPM] upgraded default-cursors (1-1 -> 2-1)

[2023-01-06T13:31:38-0500] [ALPM] upgraded nvidia-utils (525.60.11-1 -> 525.78.01-1)

[2023-01-06T13:31:38-0500] [ALPM-SCRIPTLET] If you run into trouble with CUDA not being available, run nvidia-modprobe first.

[2023-01-06T13:31:38-0500] [ALPM-SCRIPTLET] If you use GDM on Wayland, you might have to run systemctl enable --now nvidia-resume.service

[2023-01-06T13:31:38-0500] [ALPM] upgraded mesa (22.3.1-1 -> 22.3.2-3)

...

23.01.0-3)

[2023-01-06T13:31:38-0500] [ALPM] upgraded sdl2 (2.26.1-1 -> 2.26.2-1)

[2023-01-06T13:31:38-0500] [ALPM] upgraded libcamera (0.0.2-1 -> 0.0.3-3)

[2023-01-06T13:31:38-0500] [ALPM] upgraded pipewire (1:0.3.63-1 -> 1:0.3.63-4)

[2023-01-06T13:31:38-0500] [ALPM] installed liblc3 (1.0.1-1)

[2023-01-06T13:31:38-0500] [ALPM] upgraded pipewire-audio (1:0.3.63-1 -> 1:0.3.63-4)


...


[2023-01-06T13:31:38-0500] [ALPM] upgraded gtk-update-icon-cache (1:4.8.2-1 -> 1:4.8.3-3)

[2023-01-06T13:31:39-0500] [ALPM] upgraded gtk3 (1:3.24.35-2 -> 1:3.24.36-1)

[2023-01-06T13:31:39-0500] [ALPM] upgraded xdg-desktop-portal-kde (5.26.4-1 -> 5.26.5-1)

[2023-01-06T13:31:39-0500] [ALPM] upgraded libmm-glib (1.20.2-1 -> 1.20.4-1)

[2023-01-06T13:31:39-0500] [ALPM] upgraded firedragon (108.0-1 -> 108.0.1-1)

[2023-01-06T13:31:39-0500] [ALPM-SCRIPTLET] To use profile-sync-daemon add firedragon to ~/.config/psd/psd.conf

[2023-01-06T13:31:39-0500] [ALPM-SCRIPTLET] If you prefer strict hardened settings execute 'cp /usr/lib/firedragon/firedragon.overrides.cfg ~/.firedragon/'

[2023-01-06T13:31:39-0500] [ALPM] upgraded fluidsynth (2.3.0-2 -> 2.3.1-1)

[2023-01-06T13:31:39-0500] [ALPM] warning: directory permissions differ on /opt/flutter/

[2023-01-06T13:31:41-0500] [ALPM] warning: directory permissions differ on /opt/flutter/packages/integration_test/test/
filesystem: 775  package: 755
[2023-01-06T13:31:41-0500] [ALPM] warning: directory permissions differ on /opt/flutter/packages/integration_test/test/data/
filesystem: 775  package: 755
[2023-01-06T13:31:41-0500] [ALPM] upgraded flutter (3.3.9-1 -> 3.3.10-1)
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[30me(Be[me[34mFlutter was installed on e[32m/opt/fluttere(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34me(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34mIn case you encounter problems using Flutter as regular user, add your user into the group flutterusers:e(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[32mgpasswd -a ${USER} flutteruserse(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34me(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34mRe-login your terminal in to the group flutterusers:e(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[32mnewgrp flutteruserse(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34me(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[34mRun the following command to see if there are any dependencies you need to install to complete the setup (for verbose output, add the -v flag):e(Be[m
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] e[32mflutter doctore(Be[m
[2023-01-06T13:31:41-0500] [ALPM] upgraded fwupd (1.8.8-1 -> 1.8.9-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded starship (1.12.0-1 -> 1.12.0-3)
[2023-01-06T13:31:41-0500] [ALPM] upgraded pacman-contrib (1.8.0-1 -> 1.8.2-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded garuda-common-settings (2.6.12-1 -> 2.6.14-1)
[2023-01-06T13:31:41-0500] [ALPM-SCRIPTLET] Performing misc postinstall operations...
[2023-01-06T13:31:41-0500] [ALPM] upgraded garuda-gamer (1.1.5-1 -> 1.1.7-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-encode-locale (1.05-9 -> 1.05-10)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-http-date (6.05-5 -> 6.05-6)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-lwp-mediatypes (6.04-2 -> 6.04-3)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-http-negotiate (6.01-10 -> 6.01-11)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-www-robotrules (6.02-10 -> 6.02-11)
[2023-01-06T13:31:41-0500] [ALPM] upgraded perl-html-tagset (3.20-12 -> 3.20-13)
[2023-01-06T13:31:41-0500] [ALPM] upgraded vulkan-tools (1.3.226-1 -> 1.3.235-2)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libxshmfence (1.3.1-1 -> 1.3.2-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libxau (1.0.10-3 -> 1.0.11-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libx11 (1.8.2-2 -> 1.8.3-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libxdamage (1.1.5-3 -> 1.1.6-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-nvidia-utils (525.60.11-1 -> 525.78.01-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-ncurses (6.3-1 -> 6.4-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-mesa (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:41-0500] [ALPM] upgraded libva-utils (2.16.0-1 -> 2.17.0-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libxrandr (1.5.2-3 -> 1.5.3-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libice (1.0.10-1 -> 1.1.1-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded lib32-libsm (1.2.3-2 -> 1.2.4-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded garuda-settings-manager (1.0.1-3 -> 1.0.2-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded garuda-settings-manager-kcm (1.0.1-3 -> 1.0.2-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded webkit2gtk (2.38.2-2 -> 2.38.3-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded garuda-setup-assistant (3.1.5-1 -> 3.1.7-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded geoip-database (20221118-1 -> 20221227-1)
[2023-01-06T13:31:41-0500] [ALPM] upgraded ghostscript (10.0.0-2 -> 10.0.0-4)
[2023-01-06T13:31:41-0500] [ALPM] upgraded glslang (11.11.0-1 -> 11.13.0-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded go-tools (4:0.4.0-1 -> 4:0.5.0-1)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-libav (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-plugin-pipewire (1:0.3.63-1 -> 1:0.3.63-4)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-plugins-bad-libs (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded spandsp (0.0.6-3 -> 0.0.6-4)
[2023-01-06T13:31:42-0500] [ALPM] upgraded zvbi (0.2.38-1 -> 0.2.39-1)
[2023-01-06T13:31:42-0500] [ALPM] upgraded qrencode (4.1.1-1 -> 4.1.1-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded imagemagick (7.1.0.55-2 -> 7.1.0.57-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-plugins-bad (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded imlib2 (1.10.0-1 -> 1.10.0-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-plugins-good (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gst-plugins-ugly (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gstreamer-vaapi (1.20.5-1 -> 1.20.5-2)
[2023-01-06T13:31:42-0500] [ALPM] upgraded gtk4 (1:4.8.2-1 -> 1:4.8.3-3)
[2023-01-06T13:31:42-0500] [ALPM] upgraded intel-gmmlib (22.1.4-2 -> 22.3.2-1)
[2023-01-06T13:31:42-0500] [ALPM] upgraded intel-media-driver (22.4.4-2 -> 22.6.4-1)
[2023-01-06T13:31:44-0500] [ALPM] upgraded intellij-idea-community-edition (4:2022.3-1 -> 4:2022.3.1-1)
[2023-01-06T13:31:44-0500] [ALPM] upgraded signon-kwallet-extension (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded qt5-webengine (5.15.11-3 -> 5.15.12-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kaccounts-integration (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kactivitymanagerd (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kate (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kde-cli-tools (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kde-gtk-config (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kdeconnect (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kdegraphics-mobipocket (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded libraw (0.21.0-2 -> 0.21.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded libkdcraw (22.12.0-2 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kdegraphics-thumbnailers (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded libksysguard (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded ksystemstats (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded libqalculate (4.5.0-1 -> 4.5.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded milou (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded layer-shell-qt (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kscreenlocker (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kwin (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded plasma-integration (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded libkscreen (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kpipewire (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded oxygen-sounds (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded plasma-workspace (5.26.4.1-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kdeplasma-addons (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kdialog (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded khotkeys (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded systemsettings (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:45-0500] [ALPM] upgraded kinfocenter (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded kmenuedit (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded konsole (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded kpmcore (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded kscreen (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded kwallet-pam (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded kwayland-integration (5.26.4-1 -> 5.26.5-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-glib2 (2.74.3-1 -> 2.74.4-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-libva (2.16.0-1 -> 2.17.0-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-libva-mesa-driver (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-mesa-vdpau (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-opencl-nvidia (525.60.11-1 -> 525.78.01-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-pipewire (1:0.3.63-1 -> 1:0.3.63-3)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-pipewire-jack (1:0.3.63-1 -> 1:0.3.63-3)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-vulkan-intel (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded vulkan-mesa-layers (22.3.1-1 -> 22.3.2-3)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-vulkan-mesa-layers (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded vulkan-radeon (22.3.1-1 -> 22.3.2-3)
[2023-01-06T13:31:46-0500] [ALPM] upgraded lib32-vulkan-radeon (22.3.1-1 -> 22.3.2-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded libadwaita (1:1.2.0-1 -> 1:1.2.1-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded libnm (1.40.8-1 -> 1.40.8-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded spirv-tools (2022.1-1 -> 2022.4-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded shaderc (2022.1-4 -> 2022.4-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded libplacebo (4.208.0-1 -> 5.229.1-2)
[2023-01-06T13:31:46-0500] [ALPM] upgraded libva-mesa-driver (22.3.1-1 -> 22.3.2-3)
[2023-01-06T13:31:46-0500] [ALPM] upgraded libxnvctrl (525.60.11-2 -> 525.78.01-1)
[2023-01-06T13:31:46-0500] [ALPM] upgraded linux-lts (5.15.84-1 -> 5.15.86-1)
[2023-01-06T13:31:47-0500] [ALPM] upgraded linux-lts-headers (5.15.84-1 -> 5.15.86-1)
[2023-01-06T13:31:48-0500] [ALPM] upgraded linux-zen (6.0.12.zen1-1 -> 6.1.3.zen1-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded linux-zen-headers (6.0.12.zen1-1 -> 6.1.3.zen1-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded lirc (1:0.10.2-1 -> 1:0.10.2-2)
[2023-01-06T13:31:50-0500] [ALPM] upgraded make (4.3-5 -> 4.4-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded man-pages (6.01-1 -> 6.02-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded mercurial (6.3.1-1 -> 6.3.2-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded mesa-vdpau (22.3.1-1 -> 22.3.2-3)
[2023-01-06T13:31:50-0500] [ALPM] upgraded mobile-broadband-provider-info (20221107-1 -> 20221107-2)
[2023-01-06T13:31:50-0500] [ALPM] upgraded modemmanager (1.20.2-1 -> 1.20.4-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded mpv (1:0.35.0-2 -> 1:0.35.0-4)
[2023-01-06T13:31:50-0500] [ALPM] upgraded wpa_supplicant (2:2.10-7 -> 2:2.10-8)
[2023-01-06T13:31:50-0500] [ALPM] upgraded slang (2.3.3-1 -> 2.3.3-2)
[2023-01-06T13:31:50-0500] [ALPM] upgraded networkmanager (1.40.8-1 -> 1.40.8-2)
[2023-01-06T13:31:50-0500] [ALPM] upgraded networkmanager-l2tp (1.20.6-2 -> 1.20.8-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded nm-cloud-setup (1.40.8-1 -> 1.40.8-2)
[2023-01-06T13:31:50-0500] [ALPM] upgraded nordvpn-bin (3.15.2-1 -> 3.15.3-1)
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET] :: In order to enable nordvpn you have to start the following service:
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET]      sudo systemctl enable --now nordvpnd
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET] :: You have to add yourself to the nordvpn group:
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET]      sudo gpasswd -a USERNAME nordvpn
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET] :: You then have to restart for the group to be created:
[2023-01-06T13:31:50-0500] [ALPM-SCRIPTLET]      reboot
[2023-01-06T13:31:50-0500] [ALPM] upgraded nvidia-dkms (525.60.11-1 -> 525.78.01-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded nvidia-settings (525.60.11-2 -> 525.78.01-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded okular (22.12.0-1 -> 22.12.1-1)
[2023-01-06T13:31:50-0500] [ALPM] upgraded opencl-nvidia (525.60.11-1 -> 525.78.01-1)

...

[2023-01-06T13:31:52-0500] [ALPM-SCRIPTLET] + KVER=6.0.12-zen1-1-zen
[2023-01-06T13:31:52-0500] [ALPM-SCRIPTLET] + test -e /usr/lib/modules/backup/6.0.12-zen1-1-zen
[2023-01-06T13:31:52-0500] [ALPM-SCRIPTLET] + rsync -AHXal --ignore-existing /usr/lib/modules/backup/6.0.12-zen1-1-zen /usr/lib/modules/
[2023-01-06T13:31:53-0500] [ALPM-SCRIPTLET] + rm -rf /usr/lib/modules/backup
[2023-01-06T13:31:53-0500] [ALPM] running '20-systemd-sysusers.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-systemd-daemon-reload.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-systemd-sysctl.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-systemd-tmpfiles.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-systemd-udev-reload.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-systemd-update.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '30-update-mime-database.hook'...
[2023-01-06T13:31:53-0500] [ALPM] running '60-depmod.hook'...
[2023-01-06T13:31:56-0500] [ALPM] running '70-dkms-install.hook'...
[2023-01-06T13:31:56-0500] [ALPM-SCRIPTLET] ==> dkms install --no-depmod nvidia/525.78.01 -k 5.15.86-1-lts
[2023-01-06T13:32:34-0500] [ALPM-SCRIPTLET] ==> dkms install --no-depmod nvidia/525.78.01 -k 6.1.3-zen1-1-zen
[2023-01-06T13:33:23-0500] [ALPM-SCRIPTLET] ==> dkms install --no-depmod nvidia/525.78.01 -k 6.0.12-zen1-1-zen
[2023-01-06T13:34:13-0500] [ALPM-SCRIPTLET] ==> depmod 6.0.12-zen1-1-zen
[2023-01-06T13:34:14-0500] [ALPM-SCRIPTLET] ==> depmod 6.1.3-zen1-1-zen
[2023-01-06T13:34:15-0500] [ALPM-SCRIPTLET] ==> depmod 5.15.86-1-lts
[2023-01-06T13:34:16-0500] [ALPM] running '90-mkinitcpio-install.hook'...
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET] ==> Starting build: 5.15.86-1-lts
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-01-06T13:34:16-0500] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [plymouth]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-01-06T13:34:17-0500] [ALPM-SCRIPTLET]   -> Running build hook: [grub-btrfs-overlayfs]
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET] ==> Starting build: 5.15.86-1-lts
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-01-06T13:34:19-0500] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2023-01-06T13:34:20-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [plymouth]
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2023-01-06T13:34:21-0500] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-01-06T13:34:22-0500] [ALPM-SCRIPTLET]   -> Running build hook: [grub-btrfs-overlayfs]
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET] ==> Starting build: 6.1.3-zen1-1-zen
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-01-06T13:34:24-0500] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [plymouth]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-01-06T13:34:25-0500] [ALPM-SCRIPTLET]   -> Running build hook: [grub-btrfs-overlayfs]
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET] ==> Starting build: 6.1.3-zen1-1-zen
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2023-01-06T13:34:27-0500] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qed
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla1280
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: qla2xxx
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2023-01-06T13:34:28-0500] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: xhci_pci
[2023-01-06T13:34:29-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2023-01-06T13:34:29-0500] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2023-01-06T13:34:29-0500] [ALPM-SCRIPTLET]   -> Running build hook: [consolefont]
[2023-01-06T13:34:29-0500] [ALPM-SCRIPTLET]   -> Running build hook: [plymouth]
[2023-01-06T13:34:30-0500] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2023-01-06T13:34:30-0500] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2023-01-06T13:34:30-0500] [ALPM-SCRIPTLET]   -> Running build hook: [grub-btrfs-overlayfs]
[2023-01-06T13:34:32-0500] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2023-01-06T13:34:32-0500] [ALPM-SCRIPTLET] ==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] ==> Image generation successful
[2023-01-06T13:34:33-0500] [ALPM] running '90-update-appstream-cache.hook'...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] ? Metadata cache was updated successfully.
[2023-01-06T13:34:33-0500] [ALPM] running '99-foreign.hook'...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] docker-desktop 4.15.0-93002
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] rootactions-servicemenu 2.7.3-1
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] snapd 2.58-1
[2023-01-06T13:34:33-0500] [ALPM] running '99-orphans.hook'...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] geocode-glib 3.26.4-2
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] go 2:1.19.4-1
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] go-tools 4:0.5.0-1
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] libvisual 0.4.0-8
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] python-docutils 1:0.19-2
[2023-01-06T13:34:33-0500] [ALPM] running '99-pacnew-check.hook'...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] e[1m.pac* files found:e[0m
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] /etc/default/grub.pacnew
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] /etc/mkinitcpio.conf.pacnew
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] /etc/pacman.d/mirrorlist.pacnew
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] e[1mPlease check and mergee[0m
[2023-01-06T13:34:33-0500] [ALPM] running '99-update-grub.hook'...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-linux-zen
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-linux-lts
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-lts-fallback.img
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Warning: os-prober will be executed to detect other bootable partitions.
[2023-01-06T13:34:33-0500] [ALPM-SCRIPTLET] Its output will be used to detect bootable binaries on them and create new boot entries.
[2023-01-06T13:34:49-0500] [ALPM-SCRIPTLET] Found Garuda Linux on /dev/nvme0n1p2
[2023-01-06T13:34:51-0500] [ALPM-SCRIPTLET] Found Debian GNU/Linux 11 (bullseye) on /dev/nvme0n1p2
[2023-01-06T13:34:52-0500] [ALPM-SCRIPTLET] Found Ubuntu 20.04.2 LTS on /dev/nvme0n1p2
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Adding boot menu entry for UEFI Firmware Settings ...
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Detecting snapshots ...
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2023-01-06 13:31:32 | @/.snapshots/822/snapshot | pre    | pacman -Su                                                                                                   |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2023-01-04 12:08:38 | @/.snapshots/775/snapshot | post   | tk xf86-video-dummy                                                                                     |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-07 18:30:42 | @/.snapshots/16/snapshot  | single | 3rd-monitor-added                                                       |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-07 12:50:04 | @/.snapshots/15/snapshot  | single | ufw-dns-browser-priv-exts                                               |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-06 19:10:21 | @/.snapshots/14/snapshot  | single | hdmi-sound-working-after-xrandr                                         |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-06 14:23:37 | @/.snapshots/13/snapshot  | single | good-boot-with-nvidia                                                   |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-06 14:02:18 | @/.snapshots/6/snapshot   | single | good-boot-ibt-off-bootparam                                             |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found snapshot: 2022-12-06 13:00:24 | @/.snapshots/5/snapshot   | single | good-boot-no-nvidia                                                     |
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found 37 snapshot(s)
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Unmount /tmp/grub-btrfs.CF6Ch5MmrC .. Success
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] /usr/bin/grub-probe: warning: unknown device type nvme0n1.
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] done
[2023-01-06T13:34:53-0500] [ALPM] running 'dbus-reload.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'detect-old-perl-modules.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'firedragon-post.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'glib-compile-schemas.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'gtk-update-icon-cache.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'gtk4-querymodules.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'texinfo-install.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'update-desktop-database.hook'...
[2023-01-06T13:34:53-0500] [ALPM] running 'zz-snap-pac-post.hook'...
[2023-01-06T13:34:53-0500] [ALPM-SCRIPTLET] ==> root: 823
[2023-01-06T13:34:53-0500] [ALPM] running 'zzz_post.hook'...

thanks, u r a java dev too? did u ever get flutter to work and a Android virtual device to work? none of the guides seemed to work for me for arch even after i reluctantly added chrome to satisfy flutter doctor. we could really use a guide for arch flutter setup thru an avd running. else i might try a ubuntu vm n snap or stick to windoze/crApple for that

not a "java dev". my nick comes from my habit from years ago, chocolate covered espresso beans are dangerously good.

2 Likes