Deletion of Timeshift snapshots caused havoc

My issue is quite similar to 2643: I cannot boot after deleting my Timeshift snapshots for maintenance purposes.

At the time when I did delete the snapshots nothing worked, and I performed a reboot. During the boot, I got warnings similar to this from grub. In the meantime, I could still boot into "Garuda" (with grub).

After booting I would be stuck in a bootloop, I tried to enter tty, but just ended up in rootfs. With the following message:

mount: /new_root: mount (2) system call failed: No such file or directory

I also tried to enter tty3 by adding 3 to the linux line in grub editor, but I still get stuck in the boot loop. I tried with the linux-lts kernel in addition to the tkg kernel.

As a sidenote, why did this even happen? I just deleted some snapshots through the Timeshift GUI.

IDK, never I had these issues.

Post

Provide the name of the ISO (full name!) used to install Garuda on your system.

Or use a new one, it seems you take some developer/test ISO.

In the normal case, it is all well and good to fix bugs, but you have so much wrong that I am inclined to say that a reinstallation is better.

Especially since I personally could not tell from the previous posts which Garuda DE you are using.

So, if necessary, back up important data and start again.

1 Like

No, I used dragonized gaming edition. Nothing experimental.

Could it be something to do with locales? I did change one locale setting also. Everything was fine when I did this. I would be surprised if this was the issue (not that it matters, I am very new to this).

No

Post the full ISO name, you can't know which ISO is a dev./test ISO.
Nico build nearly every day two and more ISO's :slight_smile:
But they are not on download - homepage. I am sure you use another path to download.

I got my ISO from Garuda Linux | Download

How can I get the full ISO name from the USB drive? I don't have the original ISO any longer.

My system was just fine before deleting the snapshots, I'd like to think that it is the only bug. But, yes, you may be right; there could be many bugs in my system.

Use this one, please.

https://sourceforge.net/projects/garuda-linux/files/dr460nized/210107/garuda-dr460nized-linux-tkg-bmq-210107.iso/download

Name inside
garuda-dr460nized-linux-tkg-bmq-210107.iso

For reinstall? Or?

Yes, but update could be very big, so wait until @dr460nf1r3 post a link to a better one he has tested.

Maybe also a ISO with zen-kernel may better for you ...

If you have fun use Xfce :wink: , sorry but you are the only one with this many problems so I don not know where the errors come from.

2 Likes

If you try to boot into a snapshot that you have deleted then booting will (understandably) fail.

You'll have to refresh the GRUB boot menu manually if you delete snapshots manually.

You must be joking, or trolling.
You had a total disaster and you mention nothing.

3 Likes

Apologies, I was convinced that it was fixed. The system was running fine a few hours after the fix.

The problem occurred right after the mentioned deletion.

What if I deleted all my snapshots. Is that a problem?

Don't tell me that I boot into my (latest?) snapshot when selecting the "Garuda" option in Grub. Because there are no snapshots, I deleted them all.

What do your fstab entries say?

All my partitions do show up in a partition manager within a live USB. I can get you the log if you need it.

Strangely, garuda-chroot -a, when ran from live USB, doesn't detect any Linux distribution in my system.

Thank you for the time, and effort. Waiting for that link to reinstall.

Moreover, I wouldn't say noone has had these problems before. Something similar happened in 2643; however, unlike him, my Linux install is deleted or cannot be found. I really don't understand what happened here, would be nice to get closure; don't like unresolved mysteries.

This one works :slight_smile:

2 Likes

I am preparing the USB now, thank you.

Moreover, I think that I will keep playing around, and see if I can fix this without reinstall. #opportunitytolearn

Any ideas on how to update-grub without booting into Linux?

instead of expecting others to spoon feed you use the wiki its all their, come on others do not get paid to give you help, you own the mess you have got yourself into
I'm not picking on you just trying to help you to think for yourself and take responsibility for your actions.

4 Likes

Thanks for the criticism.

1 Like

Its not criticism if it was it would be classed as constructive criticism,
Before you made any changes you should of researched what you wanted to do. you should of also done a full-backup, you did neither that is not criticism that is pure logic.

2 Likes