DaVinci Resolve - Either keypresses won't work or audio won't work

Hey, I’ve run into an odd issue where if I go either of the two routes, I want to fix one or the other, but can’t find the way this should be done, so I’m wondering if anyone has ever heard of this issue before.

So AUR’s DaVinci package has been patchy, needed to remove some files to get it to run, but when inside the editor - Issue 1 - None of the keyboard shortcuts work to change tools, delete or copy.

If I were to open in DaVinci in console with sudo, I don’t have the same projects saved, but at least keypresses work! Issue 2 - I don’t have any audio.

Route 1 oddly registers me ctrl + mouse zooming the timeline and when checking the ‘Keyboard Customization’ menu with the keyboard layout and various shortcuts I could assign… pressing keys makes the respective icon light up. So the Application knows I’m pressing something, but won’t act on it.

The differences I’ve spotted is that with a regular launch DaVinci actually uses the top panel with all the KDE Window Buttons, Global context menu (File, edit, view etc) and I could resize the window. With a sudo launch the window buttons disappear, so I couldn’t close the application that way, but the context menu appears lower on its own line, as if it ignored KDE panels. Then it feels almost like now the window is fully focused.

If I were to try and search how I could possibly fix Route 2 and always sudo launch the application, then what frequently run into is PulseAudio vs PipeWire. I can’t get Pulseaudio-alsa, because it’s in conflict with pipewire-alsa and don’t know if I should try removing one for the other if the install came with PipeWire. Even if someone recommends that I still swap out pipe for pulse, is it normal to be opening the console and running the app with sudo?

I guess here’s the ‘garuda-inxi’ -

System:
Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e40a9440-1b35-4ce3-9a5a-e98f781acac6 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: Micro-Star product: MS-7D78 v: 1.0
serial: <superuser required>
Mobo: Micro-Star model: PRO B650-P WIFI (MS-7D78) v: 1.0
serial: <superuser required> uuid: <superuser required> UEFI: American
Megatrends LLC. v: 1.40 date: 03/24/2023
Battery:
Device-1: wacom_battery_0 model: Wacom Intuos Pro M serial: N/A charge: 100%
status: discharging
CPU:
Info: model: AMD Ryzen 7 7700 bits: 64 type: MT MCP arch: Zen 4 gen: 5
level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 4727 high: 5352 min/max: 400/5582 scaling:
driver: amd-pstate-epp governor: performance cores: 1: 5345 2: 5344 3: 5349
4: 400 5: 5337 6: 5342 7: 5352 8: 5348 9: 5347 10: 5350 11: 5346 12: 400
13: 5340 14: 5348 15: 5349 16: 5341 bogomips: 121597
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: Tul / PowerColor
driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x process: TSMC n5 (5nm)
built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: DP-1,DP-2 empty: DP-3,HDMI-A-1,Writeback-1 bus-ID: 03:00.0
chip-ID: 1002:747e class-ID: 0300
Device-2: AMD Raphael vendor: Micro-Star MSI driver: amdgpu v: kernel
arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: Writeback-2
bus-ID: 12:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 47.0 C
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu,amdgpu d-rect: 4480x2520 display-ID: 0
Monitor-1: DP-1 pos: bottom-l res: 1920x1080 size: N/A modes: N/A
Monitor-2: DP-2 pos: top-right res: 2560x1440 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: radeonsi device: 2 drv: swrast gbm: drv: radeonsi
surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.1-arch1.1
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7800 XT (radeonsi
navi32 LLVM 17.0.6 DRM 3.57 6.9.3-zen1-1-zen) device-ID: 1002:747e
memory: 15.62 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu name: AMD
Radeon RX 7800 XT (RADV NAVI32) driver: mesa radv v: 24.1.1-arch1.1
device-ID: 1002:747e surfaces: xcb,xlib,wayland device: 1
type: integrated-gpu name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO)
driver: mesa radv v: 24.1.1-arch1.1 device-ID: 1002:164e
surfaces: xcb,xlib,wayland device: 2 type: cpu name: llvmpipe (LLVM
17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
Device-2: AMD Rembrandt Radeon High Definition Audio
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 12:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 12:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-4: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5.4:9
chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 0f:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp15s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
Device-2: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:6 chip-ID: 0e8d:0616
class-ID: e001 serial: <filter>
Report: ID: hci1 rfk-id: 1 state: up address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 5.2 TiB used: 2.43 TiB (46.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 1B2QJXD7 temp: 44.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 2B6Q
ID-3: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: B1C2 scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Kingston model: SHSS37A240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 00.Y scheme: MBR
ID-5: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD20PURX-64P6ZY0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 0A80
Partition:
ID-1: / raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 80.86 GiB (36.2%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 27 MiB (28.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 80.86 GiB (36.2%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
ID-4: /var/log raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 80.86 GiB (36.2%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
ID-5: /var/tmp raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 80.86 GiB (36.2%) fs: btrfs dev: /dev/sdc1 maj-min: 8:33
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 30.51 GiB used: 1.93 GiB (6.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 61.1 C mobo: 48.0 C
Fan Speeds (rpm): N/A
GPU: device: amdgpu temp: 48.0 C device: amdgpu temp: 53.0 C mem: 68.0 C
fan: 0 watts: 51.00
Info:
Memory: total: 32 GiB note: est. available: 30.51 GiB used: 9.36 GiB (30.7%)
Processes: 387 Power: uptime: 1d 11h 23m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 12.19 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1489 libs: 425 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-11
Last full system update: 2024-06-14
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.