CS GO troubles?

According to ProtonDB, Counter Strike: GO should be working fine in Linux

I installed it on my system (NVIDIA GeoForce GTX 2060) and got only 30fps. By adding -vulkan flag, it gives 200fps but with severe stuttering, and it freezes after about 10 minutes requiring hard reboot. Not playable.

If others report success, why is it failing under Garuda?

Why not use the Linux native version?

I installed it through Steam; so if it's a native game, makes me wonder even more why I get those issues!

Are you sure you're using the Nvidia card with the game (E.g. running it with prime-run or without, depending which one is the default)?
Also try disabling the compositor when playing

2 Likes

That's bringing several things I'm not familiar with. How to run a game in the Steam library with prime-run? How to control which graphic card is used by an application?

Interestingly enough, disabling the compositor (alt+shift+F12) in the main menu changes it from 32fps to 36fps. Still nowhere the 200fps with -vulkan.

As a separate issue; playing Final Fantasy VII Remake in Lutrix works perfectly fine, except when I start it, 4 times out of 5, it fails to initialize the video, and occasionally, it starts very laggy (wrong graphic card?)

I'm not a Nvidia user, I just remember similar topics in the forum. Anyway:

I think this is a good summary

I think this could be done with optimus-manager-qt (the applet)

3 Likes

If others report success, why is it failing for me?

4 Likes

Yes exactly, it’s not Garuda specific. I run CSGO native in Garuda - and not even with Vulkan as that’s only just been added as experimental support - and I get well over 200 FPS with no stutter.

1 Like

Alright it was simply using the wrong graphic card.

prime-run %command%

That works. Top settings, 200fps fluid.

3 Likes

Game seemed to be working fine at 200fps; but I still get occasional full-system freezes requiring hard reboot.

I thought it might be due to undervolting, but the last freeze was after a reboot and undervolt hadn't been re-applied.

Overheating? Bad RAM?

Could be caused by several different things...

2 Likes

Computer works 100% fine otherwise. CS: GO is a very light game.

I have not played CSGO, but in other games, I've been able to decrease stuttering by limiting the framerate. You can use Mangohud and put a 60fps limit on. 200fps maybe too much, causing the game to pause as you load new areas.

Have you tried disabling the compositor with alt+shift+F12 before playing?
Or changing the compositor settings.
Or maybe
https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Avoid_screen_tearing
See also here

Check also in the btrfs assistant if a btrfs balance is suggested.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.