Could not open file /var/lib/pacman/local/g

I have had a similar problem in the last four days. Each time I trued tu update, I get the error message:

error: could not open file /var/lib/pacman/local/go-2:1.17.7-1/desc: No such file or directory
resolving dependencies...
looking for conflicting packages...
warning: could not fully load metadata for package go-2:1.17.7-1
error: failed to prepare transaction (invalid or corrupted package)
Press enter to exit

I browsed through the Garuda forum, but could not find a solution.
I have tried updating the mirrors and the keyrings prior to updating,
but to no avail. I have also tried "sudo rm /var/lib/pacman/sync/* "
as proposed in this forum, but again, still no way to update. Has anybody
and idea on the subject ?


Hi there, welcome!

Nope, this looks like a different problem, so you should open a new topic.
Before doing that, give a look here, if there is anything you have not yet tried:


I did try what you suggest: sudo pacman -Sy archlinux-keyring chaotic-keyring sudo pacman -Syu
but it did not change anything.

In /var/cache/pacman, I have two packages related to the error message: the tar.zst
and the tar.zst.sig. Shall I remove the two (I'm new to arch linux, I was running .deb based
and .rpm based distros before) ?

Proceed with the tutorial linked by @jonathon.

sudo touch /var/lib/pacman/local/go-2:1.17.7-1/desc
sudo pacman -S go

Thanks a lot ! I have re-installed go and now it works !

You are a great team !


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.