Not able to update system

Hello if this topic has been addressed before please link the forum.
I have tried to update my system and get a corrupted database message.
Any ideas on where i need to look to fix this?

also i cannot upload images as "new users" cannot ...

i have the output to add here


--> Refreshing mirrorlists using rate-mirrors, please be patient..
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
core                                         136.5 KiB   271 KiB/s 00:01 [------------------------------------------] 100%
extra                                       1548.8 KiB  1934 KiB/s 00:01 [------------------------------------------] 100%
community                                      6.0 MiB  4.19 MiB/s 00:01 [------------------------------------------] 100%
multilib                                     154.1 KiB   306 KiB/s 00:01 [------------------------------------------] 100%
chaotic-aur                                 1582.5 KiB   579 KiB/s 00:03 [------------------------------------------] 100%
blackarch                                      3.6 MiB  2.38 MiB/s 00:02 [------------------------------------------] 100%
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

Failed to update mirrorlist
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
core                                         136.5 KiB   307 KiB/s 00:00 [------------------------------------------] 100%
extra                                       1548.8 KiB  1833 KiB/s 00:01 [------------------------------------------] 100%
community                                      6.0 MiB  4.40 MiB/s 00:01 [------------------------------------------] 100%
multilib                                     154.1 KiB   330 KiB/s 00:00 [------------------------------------------] 100%
chaotic-aur is up to date
blackarch is up to date
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

--> Applying keyring updates before starting full system update..
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: database 'core' is not valid (invalid or corrupted database (PGP signature))
error: database 'extra' is not valid (invalid or corrupted database (PGP signature))
error: database 'community' is not valid (invalid or corrupted database (PGP signature))
error: database 'multilib' is not valid (invalid or corrupted database (PGP signature))
Press enter to exit

from a simple forum search on error: GPGME error: No data

8 Likes

Remember to enclose code/terminal output in 3 tilde signs.

3 Likes

Also, you're using the BlackArch repo which normally means you're an advanced user, so searching the forum would be something you'd do before posting a thread asking someone else to search for you.

7 Likes

-Kayo
Thanks for the hasty response.
Simple search for you, not for me.
My search method was inadequate to find the answer, thus i reached out.

-jonathon

in this case it does not mean i am a advanced user, just learning the ins and outs of (networking, linux, computer science related topics i happen to come into.)

I dont understand or appreciate the need for belittlement

Constructive criticism is welcome however...

I believe what Jonathan said to you was constructive if you think about it he was telling you that’s constructive manner that you need to be in advance user to utilize black arch the fullest.

Sometimes constructive criticism isn’t nice

If you read the instructions, you'll know that Garuda BlackArch is provided as-is.

It is not a variant of Garuda that regular users of Linux will choose, as it is for penetration testing. It is for advanced users, and installing it you accept that you are ready for it.

6 Likes

You were assumed to have the abilities of an advanced user by your use of BlackArch. If that's not you, then you should say thank you for the compliment and move on.
:smiley:

4 Likes

4 posts were split to a new topic: Could not open file /var/lib/pacman/local/g

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.