Computer hangs after message Kdfontop not implemented

During boot, I get the following message: setfont: KDFONTOP: Function not implemented
It is stuck there, nothing is happening, how do I solve it?
Its my first experience with an Arch-based distro, I have used debian-based before, but in a very basic form

I tried re-installing, but the same is happening, nothing is working

Welcome to the Forum!

A quick search on the forum returns this:


(SOLVED) KDFONTOP function not implemented - Issues & Assistance / Newbies - Garuda Linux Forum
[boot] setfont: KDFONTOP: Function not implemented - Issues & Assistance - Garuda Linux Forum

1 Like

The message setfont: KDFONTOP: Function not implemented itself is harmless, and can be solved easily.

It is stuck there, nothing is happening

Do you mean the system doesn't boot after that message?
If that is the case, see if one of the many threads about system not booting can help, or provide some more information: what iso file you have installed, details of your machine (graphics card in particular, and which drivers you choose on install if it's nvidia), if possible the garuda-inxi from the live iso.

1 Like

Yeah, it just hangs in there doing nothing

Please, post every time the output from


as text, possible also from live ISO

Use also forum search function like the template offer to do.