Can't start Latte dock anymore

I have tried the different layouts in the lattedock. I just could not get back again to the garuda layout. I closed the latte dock, but now i can't restart the latte dock anymore. Is there a way to get back the latte dock and the menu bar in the original setting?

Edit: Update on new features introduced in Garuda Assistant.

Using the above cp command is no longer necessary as it will overwrite all default configs in the users home directory. Some time after this thread was created Garuda Assistant was updated to allow a much more fine grained solution. Garuda Assistant now allows the user to choose exactly which system components they wish to revert to the defaults. That way if you only require your Latte config to be reverted it doesn't revert other components you may have spent a lot of time and effort customizing.

It is now recommended to simply use Garuda Assistant to revert individual user configs.

2 Likes

I uninstalled latte dock and reinstalled it. When i start latte dock it starts with the empty layout. The /etc/skel/ folder is empty now.

Also tried to put back a snapshot from yesterday. This did not get back the latte dock and menu bar.


Dot files are hidden until you press CTRL+H

ls -la /etc/skel 
insgesamt 120K
drwxr-xr-x 1 root root  184 09.10.2020 20:29 ./
drwxr-xr-x 1 root root 5,1K 18.10.2020 11:46 ../
drwxr-xr-x 1 root root  636 17.10.2020 14:34 .config/
drwxr-xr-x 1 root root   14 13.07.2020 13:20 .icons/
drwxr-xr-x 1 root root   10 13.07.2020 13:20 .local/
-rw-r--r-- 1 root root   21 09.08.2020 18:27 .bash_logout
-rw-r--r-- 1 root root   57 09.08.2020 18:27 .bash_profile
-rw-r--r-- 1 root root  141 09.08.2020 18:27 .bashrc
-rw-r--r-- 1 root root  597 06.10.2020 14:30 .gtkrc-2.0
-rw-r--r-- 1 root root  85K 25.09.2020 01:16 .p10k.zsh
-rw-r--r-- 1 root root  138 06.10.2020 14:30 .profile
-rwxr-xr-x 1 root root 1,6K 06.10.2020 14:30 .xinitrc*
-rw-r--r-- 1 root root 6,1K 25.09.2020 01:16 .zshrc
2 Likes

Yes did finally did the trick. Thanks a lot. Probably gonna need this command a lot.

1 Like

The solution is in post #2 so I change it. :slight_smile:

1 Like

When you have selected a different layout, it is not possible to select the garuda layout again. Only with the manage layout you can go back to the garuda layout. It is possible to change to al the other layouts accept the garuda layout. Is this a bug?

That's right, thanks....