Latte dock and top bar hidden when I boot

When I boot my PC my latte dock is hidden, and also my top menu bar, it seems like almost all process where not initialized for some reason. This is the third time that this bug happens to me in 2 weeks

I tried the solution on this post Can't start Latte dock anymore
cp -rf /etc/skel/. ~/

But now I cant change the configuration of Konsole or any other program, the konsole keeps using fish even when I changed the configuration to use zsh. I want to go back to my personal config before this bug happened, but I cant.

inxi -Faz

System:
Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2388a6d1-7c1f-4a3a-a706-424269cd9d94 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: A320M-HD serial: <superuser required>
UEFI: American Megatrends v: P5.40 date: 07/09/2019
CPU:
Info: model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen/Zen+ note: check family: 0x17 (23) model-id: 0x18 (24)
stepping: 1 microcode: 0x8108102
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2936 high: 2949 min/max: 1400/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2912 2: 2942
3: 2949 4: 2943 bogomips: 28802
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: ASRock
driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:7340 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: DisplayPort-2 res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 03:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel bus-ID: 09:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: e000 bus-ID: 08:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 18.21 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-75WN4A1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 7113 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Lexar model: 256GB SSD
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 505 scheme: GPT
Partition:
ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 18.21 GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 18.21 GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 18.21 GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%)
used: 18.21 GiB (7.6%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.61 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 38.0 C mem: 0.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 262 Uptime: 8m wakeups: 0 Memory: 15.61 GiB
used: 2.77 GiB (17.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1191 lib: 301 Shell: Zsh v: 5.8
running-in: konsole inxi: 3.3.11

Hi there, welcome.
With this

you override all your local configurations (in ~/) with the default one (in /etc/skel/).
Next time, use only latte folder in the copy, or, even better, use the Garuda Assistant, with the button to reset default configs, flagging only latte (or whatever else).

1 Like

Hi. Welcome to you too.
I have to kindly ask you to not "hijack" the topic.
This one is focused on how to reset the latte config v/s all the other configurations.
The "why it happened" is a different and much more complex aspect.
If you have a suspect on a specific sequence of actions that lead to latte crash (it could be e.g. for some "strange/specific" widgets) please open a new dedicated topic for this, detailing those steps as best as possible.

Hello, thank you for the help.

My garuda assistant doesnt have an option to reset the Konsole. What file do I need to edit in order to be abe to use ZSH on Konsole again? Or even better, how do I persist the changes of my configuration?

Basically, I wish to be able to do my own customization again like I was able before

To set your default shell to zsh see e.g. here.
To configure Konsole, open it -> Settings -> Configure Konsole -> Profile -> Edit your profile -> Enter in Command /usr/bin/zsh -> ok

No one will override your customization if you avoid the cp command used above.

2 Likes

I did those configurations, but when I open the konsole it still looks like fish. Unfortunately I cant send the image here, so I uploaded an image on IPFS: https://gateway.pinata.cloud/ipfs/QmePmNjSJhK6mEo2ZHMgMJnXjMNmzxNtcLfVm6CKPaYPEZ?preview=1

Quite frankly I don't get it.
Fish is a shell, konsole is a terminal.
You see in the right side (the neofetch output) that your shell is zsh and terminal is console.
It's done...
And we are moving far away from the initial issue: latte config reset...

I'm new to Linux, that is why I had this post on the newbie topic. Thanks for the help.

1 Like

No problem.
Let me give you a suggestion as a person who came back to linux not that long ago, after many years "away": everything we discussed here is fully addressed in the forum: latte reset, from fish to zsh, konsole config, neofetch config.
Start using the search functionality and especially the filters.
When you'll see how much it can help solve your problems or even just learning something new, it will become indispensable.
And when you don't find something or want to go deeper, go to the Arch wiki.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.