Can't reinstall packages using Garuda Assistant

I am reinstalling all the packages using the button in the Garuda Assistant.
But when I get an error regarding the signature being invalid?

zvbi-0.2.41-1  zxing-cpp-2.0.0-2  zziplib-0.13.72-2

Total Download Size:     822,48 MiB
Total Installed Size:  24394,73 MiB
Net Upgrade Size:          2,65 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
ttf-google-fonts-git-1:r5411.0bd...   822,5 MiB  21,8 MiB/s 00:38 [------------------------------------] 100%
(1990/1990) checking keys in keyring                               [------------------------------------] 100%
(1990/1990) checking package integrity                             [------------------------------------] 100%
error: pamac-aur: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/pamac-aur-10.5.1-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package(PGP signature)).

I’ve already looked at this thread:


  Kernel: 6.3.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f421b3e9-feb7-49ce-885d-088d8fed2dde rw rootflags=subvol=@
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 module_blacklist=hid_sensor_hub nvme.noacpi=1 ibt=off
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Framework product: Laptop (12th Gen Intel Core) v: A4
    serial: <superuser required>
  Mobo: Framework model: FRANMACP04 v: A4 serial: <superuser required>
    UEFI: INSYDE v: 03.05 date: 08/23/2022
  ID-1: BAT1 charge: 21.8 Wh (43.1%) condition: 50.6/55.0 Wh (92.0%)
    volts: 15.6 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: charging cycles: 47
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 12th Gen Intel Core i5-1240P bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x42A
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
    L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 1905 high: 2670 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2217 2: 2100 3: 1926
    4: 2100 5: 400 6: 942 7: 2100 8: 2100 9: 2670 10: 2100 11: 2100 12: 2100
    13: 1329 14: 2100 15: 2100 16: 2100 bogomips: 67584
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Alder Lake-P Integrated Graphics driver: i915 v: kernel
    arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 2256x1504 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.1.1 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0403
  API: ALSA v: k6.3.5-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: a6:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp166s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3 chip-ID: 8087:0032
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Local Storage: total: 1.82 TiB used: 109.82 GiB (5.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 53.9 C
    scheme: GPT
  ID-1: / raw-size: 177.08 GiB size: 177.08 GiB (100.00%)
    used: 109.82 GiB (62.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 2 GiB size: 2 GiB (99.80%) used: 576 KiB (0.0%)
    fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 177.08 GiB size: 177.08 GiB (100.00%)
    used: 109.82 GiB (62.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 177.08 GiB size: 177.08 GiB (100.00%)
    used: 109.82 GiB (62.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 177.08 GiB size: 177.08 GiB (100.00%)
    used: 109.82 GiB (62.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.06 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 67.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 413 Uptime: 22m wakeups: 7109 Memory: available: 31.06 GiB
  used: 10.44 GiB (33.6%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 2012
  pm: pacman pkgs: 2003 libs: 432 tools: gnome-software,octopi,pamac,paru
  pm: rpm pkgs: 0 pm: flatpak pkgs: 9 Shell: fish v: 3.6.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-05-04
  Last full system update: 2023-06-02
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Saw this Setup Assistant errors out "Invalid sigantures from Nico Jensch"

but that's fixed supposedly?

Seems like running garuda-update remote keyring has fixed it.

But now I'm getting this error. which is weird cause I don't have ttf-carlito installed

...xorg-xdpyinfo-1.3.4-1  xorg-xeyes-1.2.0-1  xorg-xhost-1.0.9-1  xorg-xinit-1.4.2-1
xorg-xinput-1.6.4-1  xorg-xkbcomp-1.4.6-1  xorg-xmessage-1.0.6-1  xorg-xmodmap-1.0.11-1
xorg-xprop-1.2.6-1  xorg-xrandr-1.5.2-1  xorg-xrdb-1.2.1-1  xorg-xset-1.2.5-1
xorg-xsetroot-1.1.3-1  xorg-xwayland-23.1.1-1  xorg-xwininfo-1.1.6-1  xorgproto-2022.2-1
xournalpp-1.1.3-1  xsel-1.2.1-1  xvidcore-1.3.7-2  xxhash-0.8.1-4  xz-5.4.3-1  yad-12.3-1
yajl-2.1.0-5  yaml-cpp-0.7.0-2  yasm-1.3.0-6  yelp-tools-42.1-1  yelp-xsl-42.1-1
yt-dlp-2023.03.04-2  zbar-0.23.90-3  zeromq-4.3.4-3  zimg-3.0.4-1  zip-3.0-10
zita-convolver-4.0.3-3  zlib-1:1.2.13-2  zoom-5.14.7-1  zram-generator-1.1.2-1  zstd-1.5.5-1
zvbi-0.2.41-1  zxing-cpp-2.0.0-2  zziplib-0.13.72-2

Total Installed Size:  24394,73 MiB
Net Upgrade Size:          2,63 MiB

:: Proceed with installation? [Y/n] y
(1990/1990) checking keys in keyring                               [------------------------------------] 100%
(1990/1990) checking package integrity                             [------------------------------------] 100%
(1990/1990) loading package files                                  [------------------------------------] 100%
(1990/1990) checking for file conflicts                            [------------------------------------] 100%
error: failed to commit transaction (conflicting files)
/usr/share/fonts/carlito/Carlito-Bold.ttf exists in both 'ttf-google-fonts-git' and 'ttf-carlito'
/usr/share/fonts/carlito/Carlito-BoldItalic.ttf exists in both 'ttf-google-fonts-git' and 'ttf-carlito'
/usr/share/fonts/carlito/Carlito-Italic.ttf exists in both 'ttf-google-fonts-git' and 'ttf-carlito'
/usr/share/fonts/carlito/Carlito-Regular.ttf exists in both 'ttf-google-fonts-git' and 'ttf-carlito'
Errors occurred, no packages were upgraded.
Press enter to exit

I recall reading about it some time ago: Conflicts between font packages - Garuda Setup Assistant.
I thought that was sorted out but apparently not.

Ah yeah, that thread is exactly my problem.

What confuses me is that I don't have ttf-carlito installed.
Does the garuda assistant somehow try to install ttf-carlito as a dependency from some other package?

I think so.

Yeah, afaik it is. It finally worked for me, at least. Your mileage may vary?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.