Can't mount ntfs partition

I have an external usb drive that have 2 ntfs partitions.
I can't mount the first partition, /dev/sdb1.
Windows can't open the external drive and don't show it in "This PC".
I tried ntfsfix, it shows that finished successfully but still can't use the partition.
I need the data, tried many hours and now I'm bored.
please help me.

** UPDATE **

I had this problem with second partition of the external drive but with ntfsfix problem solved.
because I don't use windows I decide to change the partitions format, so with gparted tried to make some free space and create a new ext4 partition. at the 100% of resizing I got an Error and this problem happened.

I'm not good in English.

Can we have your

Garuda-inxi

3 Likes
System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=7e12566b-bfa2-4025-8e3a-4d53e669a471 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=864d717d-9c4b-49a1-8929-f95554e8a604 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude E7440 v: 01
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0TG9FP v: A00 serial: <superuser required> BIOS: Dell
v: A15 date: 05/19/2015
CPU:
Info: model: Intel Core i5-4310U bits: 64 type: MT MCP arch: Haswell
family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 986 high: 1531 min/max: 800/3000 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 1531 3: 799
4: 816 bogomips: 20750
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
Device-2: Microdia Integrated Webcam type: USB driver: uvcvideo
bus-ID: 2-4:3 chip-ID: 0c45:64d2 class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x113d built: 2013
res: 1920x1080 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
v: 4.6 Mesa 22.0.1 compat-v: 3.1 direct render: Yes
Audio:
Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: kernel
port: f080 bus-ID: 00:19.0 chip-ID: 8086:155a class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:08b1 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-1.3:3 chip-ID: 8087:07dc class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
Local Storage: total: 704.24 GiB used: 87.08 GiB (12.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apacer model: AS350 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0A0 scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: Expansion
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B type: N/A
serial: <filter> rev: 0710 scheme: MBR
Partition:
ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 14.69 GiB (29.4%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot raw-size: 512 MiB size: 512 MiB (100.00%)
used: 138 MiB (27.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 179.97 GiB size: 179.97 GiB (100.00%)
used: 42.03 GiB (23.4%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%)
used: 14.69 GiB (29.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%)
used: 14.69 GiB (29.4%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 487 MiB (6.2%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda1 maj-min: 8:1
Sensors:
System Temperatures: cpu: 60.0 C mobo: 42.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 3720
Info:
Processes: 262 Uptime: 1h 46m wakeups: 1 Memory: 7.67 GiB
used: 2.41 GiB (31.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1480 lib: 373 Shell: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.6.1-1):
System install date:     2022-04-04
Last full system update: 2022-04-08 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:
1 Like

You would be better copying and pasting here the output of your garuda-inxi with ~~~ before and ~~~ after to format the text for forum members to be able to help

1 Like

https://forum.garudalinux.org/search?expanded=true&[email protected]%20ntfs-3g%20order:latest

3 Likes

I tried sudo mount -t ntfs-3g /dev/sda2 /mnt/windows, tried sudo ntfsfix /dev/sdb1 and it's the result :

Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb1 was processed successfully.

but still I can't use the partition.

Try chkdsk /f from Windows.

the chkdsk /f command, by default checks the 'C' drive of system.
windows can recognize the hard drive but can't show it in This PC(My Computer). so there is no letter(D, E, F,...) to use for checking the disk.

Maybe this was just a typo in the post, but you should have used /dev/sdb1 here.

1 Like

On Windows login as an admin, hit Windows key + R, type diskmgmt.msc, right click on the problematic partition and assign a drive letter. Then chkdsk /f <drive letter>:

chkdsk d: /f
The type of the file system is RAW.
CHKDSK is not available for RAW drives.

I am not certain, but my guess is you are getting this message because of whatever happened here:

The thread is a little confusing to read through at this point because I'm not sure when this update was added.

It looks like you are still getting advice from people trying to help you mount or fix this device as if it still has an NTFS file system, but the update to post #1 makes it sound like what you actually want to do is reformat it and get a different filesystem on there.

Can you explain what you are trying to do next?

Also please provide the output of lsblk -f when you have a chance.

2 Likes

I had Artix Linux before, I decide to move to a new distro so I copied my important/necessary data to my external drive.
the problem first happened to second partition and with ntfsfix solved.
I don't connect my external drive to a windows systems so decide to change the partition format to EXT4.
it's my idea:
install gparted, create a new partition with the free space of sdb1, then move some data to the new partition and resize partitions again and again until I just have an EXT4 partition.
I made two steps in gparted, 1:resize the sdb1, 2:create new EXT4 partition.
I got error at 100% of first step.

I have important data in my hard drive and first need to access them for moving theme and then reformat the drive.

I hope you understand because I'm not good in English

$ lsblk -f
NAME   FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda
├─sda1 swap   1           864d717d-9c4b-49a1-8929-f95554e8a604                [SWAP]
├─sda2 btrfs              928d6ec2-d8eb-4605-8a30-510a01b5bdc7  297.7M    27% /boot
├─sda3 btrfs              7e12566b-bfa2-4025-8e3a-4d53e669a471   36.6G    25% /var/tmp
│                                                                             /var/log
│                                                                             /var/cache
│                                                                             /srv
│                                                                             /root
│                                                                             /
└─sda4 btrfs              7cba9ea4-04cf-4fb8-a7a7-5ffa004428e7  134.8G    24% /home
sdb
├─sdb1 ntfs               01D6773F5CC97580
└─sdb2 ntfs               795575FA5B5A217F                       55.5G    35% /run/media/smjt2000/795575FA5B5A217F
zram0                                                                         [SWAP]

updated @BluishHumility

Your English is good! Your note is clearly explained. :slightly_smiling_face:

Can you post lsblk -f?

UPDATE

Okay, I think your plan should work:

Actually it looks like you have enough space to do it all in one go. We'll have to figure out what went wrong the first time.

First, sdb1 is EMPTY (or no valuable data), correct?

If so, the first thing you should do in gparted is delete sdb1 partition.

Then you will make a new partition that should be as big as you can make it, but at least 60GB or so, for the ext4 partition.

No it's not free. it's a 380 GB disk and I think more than 200 GB if full.

My mistake--I misunderstood, I thought you had tried to reformat that partition as ext4. I think I understand what you wrote now: you are trying to make a third partition on the disk as ext4 to migrate data over.

Can you run:

sudo parted /dev/sdb

Inside parted, type:

print

And paste output here.

Model: Seagate Expansion (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type     File system  Flags
1      1114kB  408GB  408GB   primary  ntfs
2      408GB   500GB  92.0GB  primary  ntfs         boot

So even Windows thinks it has no filesystem. The only option I can think of is to use recovery software. You may try testdisk, photorec or gparted's filesystem recovery option.
Someone else may be more helpful than me.

I think I fully understand the situation now. Sorry I wasn't getting it before.

You attempted to resize this partition in gparted (to make it smaller) and it did not succeed.

Resizing NTFS in gparted is a little risky because NTFS has a tendency to be very fragile on Linux systems. It sounds like the resize attempt didn't quite work.

This looks good though, and makes me think the partition is perhaps not super broken.

Did you review this comment? The reason I ask is because this mountpoint:

leads me to believe you are not using a proper mount command--you are allowing the file manager to auto-mount the drive.

There is nothing wrong with that, but since that does not appear to be working I would try to create a proper mount point and mount the drive with the correct command.

sudo mkdir /mnt/windows

Don't worry if the directory already exists. Next, mount:

sudo mount -t ntfs-3g /dev/sda1 /mnt/windows

Paste the results here and we'll take a look.

that's a typo, it should be /dev/sdb1.

$ sudo mount -t ntfs-3g /dev/sdb1 /mnt/windows
Failed to read NTFS $Bitmap: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.