Cant logout of Sway for some reason?

the logout button accessed over shift+mod+e doesnt work for some reason. Any fixes?

btw loving it so far

System:
  Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
  root=UUID=ccb6a9ed-afdb-4c13-ab59-5e1e14e2046b rw [email protected] quiet splash
  rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
  loglevel=3
  Desktop: sway 1.6.1 vt: 2 dm: LightDM 1.30.0, SDDM Distro: Garuda Linux
  base: Arch Linux
Machine:
  Type: Convertible System: HP product: HP ProBook x360 435 G7 v: N/A
  serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: HP model: 8735 v: KBC Version 09.24.00 serial: <superuser required> UEFI: HP
  v: S80 Ver. 01.04.02 date: 01/18/2021
Battery:
  ID-1: BAT0 charge: 21.3 Wh (61.2%) condition: 34.8/45.0 Wh (77.4%) volts: 11.5
  min: 11.4 model: Hewlett-Packard Primary type: Li-ion serial: <filter>
  status: Discharging cycles: 52
  Device-1: hid-0018:04F3:2AD3.0002-battery model: ELAN2513:00 04F3:2AD3 serial: N/A
  charge: N/A status: N/A
CPU:
  Info: Quad Core model: AMD Ryzen 3 4300U with Radeon Graphics bits: 64 type: MCP
  arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache:
  L1: 256 KiB L2: 2 MiB L3: 4 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 21560
  Speed: 1394 MHz min/max: 1400/2700 MHz boost: enabled Core speeds (MHz): 1: 1397
  2: 1397 3: 1397 4: 1397
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 04:00.0
  chip-ID: 1002:1636 class-ID: 0300
  Device-2: Quanta HP HD Camera type: USB driver: uvcvideo bus-ID: 3-3:2
  chip-ID: 0408:5375 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.Org 1.21.1.3 compositor: sway v: 1.6.1 driver:
  loaded: amdgpu,ati unloaded: modesetting,vesa alternate: fbdev display-ID: :1
  screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
  s-diag: 583mm (23")
  Monitor-1: XWAYLAND0 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7")
  diag: 336mm (13.2")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 04:00.1
  chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 04:00.5
  chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
  v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0
  chip-ID: 8086:2723 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-3:2
  chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 253.39 GiB used: 16.46 GiB (6.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: KBG40ZNV256G KIOXIA
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
  type: SSD serial: <filter> rev: HP00AE00 temp: 32.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Intenso model: Ultra Line
  size: 14.91 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
  rev: PMAP scheme: MBR
Partition:
  ID-1: / raw-size: 50 GiB size: 50 GiB (100.00%) used: 16.12 GiB (32.2%) fs: btrfs
  dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-2: /boot/efi raw-size: 1 GiB size: 1 GiB (99.80%) used: 576 KiB (0.1%) fs: vfat
  dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-3: /home raw-size: 171.47 GiB size: 171.47 GiB (100.00%) used: 353.4 MiB (0.2%)
  fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 50 GiB size: 50 GiB (100.00%) used: 16.12 GiB (32.2%)
  fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-5: /var/tmp raw-size: 50 GiB size: 50 GiB (100.00%) used: 16.12 GiB (32.2%)
  fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: swap-2 type: zram size: 7.23 GiB used: 58 MiB (0.8%) priority: 100
  dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 0.0 C gpu: amdgpu temp: 37.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 299 Uptime: 11m wakeups: 3 Memory: 7.23 GiB used: 2.34 GiB (32.4%)
  Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
  pacman: 1330 lib: 306 Shell: fish v: 3.3.1 default: Bash v: 5.1.12
  running-in: alacritty inxi: 3.3.09

If you include terminal outputs in your post please
use the proper output format in your post.
Using "~" 3 times above and "~" 3 times below the text block
will provide a readable, raw look.
greetings

What have you tried to resolve this, like configuring the appropriate config...

nothing yet. Im new and not yet familiar with sway and wayland in general

I'm not sure of this, I'm not a sway user...
Maybe you could try adding
bindsym mod+Shift+e exit
in your
~/.config/sway/config
Edit:
Although I see that should call the Power according to the Wiki

1 Like

Hi JewleZ,

yes I have the same issue.

If you follow the shift+mod+e -> when you press this command you "start" the nwgbar/bar.json

Open this bar.json in a editor

the third paragraph is

{
"name": "Logout",
"exec": "loginctl terminate-user $USER",
"icon": "/usr/share/nwg-launchers/nwgbar/images/logout.svg"
},

in my case the exec command works if I copy it to the terminal. But not from the bar.json.

The $USER gives your username

I changed $USER with my user name and the logout works.

Not the best solution but at least a work around.

Perhaps has somebody with deeper knowledge any idea.

Best regards Rotor

4 Likes

Hi,

I had the same problem and solved it changing in ~/.config/nwg-launchers/nwgbar/bar.json
{
"name": "Logout",
"exec": "loginctl terminate-session self",
"icon": "/usr/share/nwg-launchers/nwgbar/images/logout.svg"
},

Regards
Chama

2 Likes

Nice. Thank I didn't know that was a problem. Will mend it on the config

1 Like

I have the same problem. Just was coming here to sway that I switched it to the default in the nwgbar choatic aur and it is working.

@OdiousImp how do we make sure that we are getting these types of updates since this config lives in our home directory?

1 Like

Oh I'm not sure about that. @dr460nf1r3? Does me updating the configs update their configs if they reinstall the package?

Or you can always just manually add it in from looking at the commit history.

2 Likes

Only if it's present in the actual filesystem, updates don't touch /home though :eyes: (unless someone wrote a pretty shitty PKGBUILD :grin:)

3 Likes

Yeah the part for me, was i just installed Garuda like a month ago (middle of December) and I ran into this issue. Since things aren't updated in home folders, which they shouldn't because people customize everything there, it was hard to figure out the issue (if I wasn't looking at the forums).

Most of the sway customization is under ~/.config for me so that means that any updates/fixes would not get propagated. I didn't put them there so the initial setup must.

So how do I handle checking for changes that impact those configs or keep up to date?

1 Like

You can go to the gitlab Files · master · Garuda Linux / Themes and Settings / Settings / garuda-sway-settings · GitLab.

There you can check commits and see if there's anything that needs mending. Normally they will not be anything too significant.

3 Likes

Would the skelton folder get updated with the changes?

So I could also write a simple check for the nwgbar and other specifics that I wanted to monitor to keep those in sync?

1 Like

Yes. That would be a very cool thing to do actually.

Maybe I should open a new topic or something but I went and looked at my /etc/skel on my fully updated system and I don't have the patch.

Is it not pushed to CHOATIC AUR yet?

Oh no that's not what I meant. Any update won't come to you. You have to do it manually.

There is good reason for this. Many people customize their install after and having it update would ruin all that.

Also nwg-launchers don't take the config from /etc/skel/. Changing that won't do anything.

1 Like

Thanks I thought you package would update the /etc/skel/.config/ when it changed in AUR. So it won't update the /etc/skel either so any user I create won't get the fixed version?

I understand about the home users folder but I would hope that your change would propagate to the /etc/skel/.config location that you have specified in your repository.

So from what I'm understanding I have to check for changes in your github because they will never show up on a deployed system inside of /etc/skel/.config/ path. (Looking at the github repo in etc/skel · master · Garuda Linux / Themes and Settings / Settings / garuda-sway-settings · GitLab).

Thanks for answering my questions, just trying to understand this better.