Can't log in newly installed Garuda Hyprland

Hello, everyone. I recently tried to install Garuda Hyprland version on my laptop (Lenovo IdeaPad 5 15ITL05). The installation process was easy and smooth. The only problem I have is that I can’t seem to actually access the newly installed Garuda Linux. When I try to log in, I type the password and then after it unlocks, instead of showing the screen, it goes back to sddm where I have to log in, basically not allowing me to ever access the actual distro.

I have a dual boot with gentoo and from there I ran chroot and here it is my garuda-inxi.

(chroot) [root@gentoo /]# garuda-inxi
  12Kernel 6.1.31-gentoo-dist 12arch x86_64 12bits 64 12compiler N/A 12clocksource tsc 12available acpi_pm
    12parameters BOOT_IMAGE=/vmlinuz-6.1.31-gentoo-dist root=UUID=d7985e95-f3a6-4ad8-af67-797bab3ce1cd
    ro root=/dev/nvme0n1p5 rootfstype=ext4 rootfstype=ext4
  12Desktop KDE Plasma 12v ERR-101 12tk Qt 12v 5.15.11 12wm kwin_x11 12dm N/A 12Distro Garuda Linux
    12base Arch Linux
  12Type Laptop 12System LENOVO 12product 82FG 12v IdeaPad 5 15ITL05 12serial <filter> 12Chassis 12type 10
    12v IdeaPad 5 15ITL05 12serial <filter>
  12Mobo LENOVO 12model LNVNB161216 12v SDK0J40709 WIN 12serial <filter> 12UEFI LENOVO 12v FHCN26WW
    12date 04/12/2021
  12ID-1 BAT0 12charge 40.9 Wh (73.0%) 12condition 56.0/70.0 Wh (80.0%) 12power 11.1 W 12volts 15.5 12min 15.2
    12model Celxpert L19C4PF1 12type Li-poly 12serial <filter> 12status discharging 12cycles 957
  12Info 12model 11th Gen Intel Core i7-1165G7 12socket U3E1 12bits 64 12type MT MCP 12arch Tiger Lake
    12gen core 11 12level v4 12note check 12built 2020 12process Intel 10nm 12family 6 12model-id 0x8C (140)
    12stepping 1 12microcode 0xA6
  12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 320 KiB
    12desc d-4x48 KiB; i-4x32 KiB 12L2 5 MiB 12desc 4x1.2 MiB 12L3 12 MiB 12desc 1x12 MiB
  12Speed (MHz) 12avg 2347 12high 2800 12min/max 400/4700 12base/boost 2800/4700 12scaling
    12driver intel_pstate 12governor powersave 12volts 0.8 V 12ext-clock 100 MHz 12cores 121 2800 122 2800 123 2800
    124 2800 125 2800 126 2800 127 992 128 984 12bogomips 44864
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Vulnerabilities <filter>
  12Device-1 Intel TigerLake-LP GT2 [Iris Xe Graphics] 12vendor Lenovo 12driver i915 12v kernel
    12arch Gen-12.1 12process Intel 10nm 12built 2020-21 12ports 12active eDP-1 12empty DP-1, DP-2, HDMI-A-1,
    HDMI-A-2, HDMI-A-3 12bus-ID 0000:00:02.0 12chip-ID 8086:9a49 12class-ID 0300
  12Device-2 NVIDIA TU117M [GeForce MX450] 12vendor Lenovo 12driver nouveau 12v kernel 12non-free 535.xx+
    12status current (as of 2023-09) 12arch Turing 12code TUxxx 12process TSMC 12nm FF 12built 2018-22
    12bus-ID 0000:01:00.0 12chip-ID 10de:1f97 12class-ID 0302
  12Device-3 Syntek [] 12driver uvcvideo 12type USB 12rev 2.0 12speed 480 Mb/s 12lanes 1 12mode 2.0
    12bus-ID 3-5:2 12chip-ID 174f:2459 12class-ID fe01 12serial <filter>
  12Display 12server 12v 12with Xwayland 12v 23.2.2 12compositor kwin_x11 12driver 12gpu i915
    12display-ID :0
  12Monitor-1 eDP-1 12model AU Optronics 0xe48d 12built 2019 12res 1920x1080 12dpi 142 12gamma 1.2
    12size 344x194mm (13.54x7.64") 12diag 395mm (15.5") 12ratio 16:9 12modes 1920x1080
  12API Vulkan 12Message No Vulkan data available.
  12API OpenGL 12Message Unable to show GL data. glxinfo is missing.
  12Device-1 Intel Tiger Lake-LP Smart Sound Audio 12vendor Lenovo 12driver sof-audio-pci-intel-tgl
    12bus-ID 0000:00:1f.3 12chip-ID 8086:a0c8 12class-ID 0401
  12API ALSA 12v k6.1.31-gentoo-dist 12status kernel-api 12tools N/A
  12Server-1 sndiod 12v N/A 12status off 12tools aucat,midicat,sndioctl
  12Server-2 PipeWire 12v 0.3.83 12status n/a (root, process) 12with 121 pipewire-pulse 12status off
    122 wireplumber 12status active 123 pipewire-alsa 12type plugin 124 pw-jack 12type plugin
    12tools pactl,pw-cat,pw-cli,wpctl
  12Device-1 Intel Wi-Fi 6 AX201 12driver iwlwifi 12v kernel 12bus-ID 0000:00:14.3 12chip-ID 8086:a0f0
    12class-ID 0280
  12IF wlp0s20f3 12state up 12mac <filter>
  12Device-1 Intel AX201 Bluetooth 12driver btusb 12v 0.8 12type USB 12rev 2.0 12speed 12 Mb/s 12lanes 1 12mode 1.1
    12bus-ID 3-10:4 12chip-ID 8087:0026 12class-ID e001
  12Report btmgmt 12ID hci0 12rfk-id 2 12state down 12bt-service N/A 12rfk-block 12hardware no 12software yes
    12address <filter> 12bt-v 5.2 12lmp-v 11 12status 12discoverable no 12pairing no
  12Hardware-1 Intel Volume Management Device NVMe RAID Controller 12driver vmd 12v 0.6 12port N/A
    12bus-ID 0000:00:0e.0 12chip-ID 8086:9a0b 12rev 12class-ID 0104
  12Local Storage 12total 476.94 GiB 12used 4.85 GiB (1.0%)
  12SMART Message Required tool smartctl not installed. Check --recommends
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Samsung 12model MZALQ512HALU-000L2 12size 476.94 GiB
    12block-size 12physical 512 B 12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12tech SSD 12serial <filter>
    12fw-rev BL2QFXV7 12temp 34.9 C
  12Message No partition data found.
  12Kernel 12swappiness 60 (default) 12cache-pressure 100 (default) 12zswap no
  12ID-1 swap-1 12type partition 12size 8.8 GiB 12used 0 KiB (0.0%) 12priority -2 12dev /dev/nvme0n1p3
    12maj-min 259:3
  12System Temperatures 12cpu 36.0 C 12mobo N/A 12gpu nouveau 12temp 33.0 C
  12Fan Speeds (rpm) N/A
  12Processes 246 12Uptime 20m 12wakeups 3616 12Memory 12total 16 GiB 12available 15.42 GiB
  12used 3.51 GiB (22.8%) 12igpu 60 MiB 12Init N/A 12v N/A 12default graphical 12tool systemctl 12Compilers
  12gcc 13.2.1 12Packages 12pm pacman 12pkgs 1226 12libs 358 12tools paru 12Client shell wrapper 12v 5.1.16-release
  12inxi 3.3.30
attenzione: database file for 'garuda' does not exist (use '-Sy' to download)
attenzione: database file for 'core' does not exist (use '-Sy' to download)
attenzione: database file for 'extra' does not exist (use '-Sy' to download)
attenzione: database file for 'community' does not exist (use '-Sy' to download)
attenzione: database file for 'multilib' does not exist (use '-Sy' to download)
attenzione: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
head: impossibile aprire '/var/log/pacman.log' per la lettura: File o directory non esistente
  System install date:     
  Last full system update: 2023-12-24
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager connman dracut nvidia-dkms
  Windows dual boot:       No/Undetected
Running in chroot, ignoring command 'list-units'
  Failed units:

There is an issue we have not quite figured out yet where the installer allows language or keyboard layout choices which are not actually supported. See also this forum thread: Garuda hyprland booting issue

Ideally we need to figure out how to add whatever packages or configuration we are missing to be able to support any selected language or keyboard layout choice, or remove options from the installer so the configurations that are not working are not presented as choices to the user.

In the meanwhile, if you are interested in a workaround you can complete the installer with the “default” language and keyboard layout choices and then convert your system to the desired configuration after the installation is complete.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.