Can't get UEFI/BIOS to detect install on NVME

Hello Comrades. I'm having a bit of an issue with my Garuda install. My UEFI won't detect it on my NVME. It works just fine on a regular SSD, in fact, I'm using another install if Garuda's GRUB menu to access the install on my NVME. Not exactly a seemless solution, so hopefully you guys can help. I didn't have this problem with Ubuntu or Windows, but besides this, I LOVE the distro so far.

Just a passer-by - but I suspect you'll get help faster (and better) if you include some system information with the post! Things like an inxi -Fxxxza and what your partitions/drives are would be of assistance. NVME or not should not make a difference of any importance that I know of (have a gen 3 and a gen 4 on the go at the moment in separate machines) - so you'll need more expertise than I can summon up. Good luck.

1 Like

I have also had issues with Linux not recognizing NVMe drives before. My problem was that the BIOS was configured to access the drive as Intel RAID, where as Linux requires it to be SATA AHCI. I would check the BIOS settings for something like that and make sure that the NVMe drive is configured as SATA AHCI and nothing else.

If all else fails, try and configure the drive in Legacy mode - also a BIOS option. I wouldn't install in this mode, just want to see if the drive becomes visible.

In the other hand, you mention that Ubuntu and Windows do not have the problem.... Any chance Secure Boot is enabled in the BIOS?


Hi guys, I've been tracking this issue on all Arch distro and would like to help you fix in Garuda, please pm if you want help

Endeavor OS is also now fixed

You're next.