KDE Ultimate installer is not seeing NVme SSD

Calamares sees my SATA SSD's, but not my NVme SSD. My BIOS sees it. Any ideas?

1 Like

I have seen this type of post often enough on other Arch spins that I did not buy an nvme drive exactly for that reason with a recent build. I believe there are ways to work around this, I just figured why bother inviting problems and stuck with SSD's.

I don't recall this topic coming up on this forum, but perhaps it has. I would search the Arch, Manjaro, and EndeavourOS forums as I'm certain there's information on how to correct this on the other Arch, or Arch spins fora.

I'm sure the answer is out there, you'll just have to do a bit of searching for it.

Good luck.


Oh lucky i build just a new PC with 2 NVme SSD only . And both shows up in calamares . one is corsair and one is samsung .
maybee try without the Sata ssd 's pluged in


Make sure the nvme is plugged into the socket all the way. I have had this happen. If not inserted fully it will show up in bios but not be able to be seen by the installer.


Big thank you to you all for your attention to my problem!
I have fiddled with this SSD a bit more and it only leads to more head scratching!
My Win 10 OS on another SATA SSD sees the Crucial P5 1TB NVMe SSD using the Win drive mangler and my Manjaro OS on yet another SATA SSD sees the NVMe drive using GParted and KPM as well.
So I am assuming the SSD is probably seated in it's socket properly.
In Garuda Live, I don't see the drive using Calamares, GParted nor KDE Partition Manager.
The problem seems to only exist in Garuda KDE Ultimate Live.
I verified my USB drive with the SHA 256 checksum twice and they match.
I am totally perplexed!

It sounds pretty strange to me too. I've used the XFCE edition for my installs of Garuda, and both the Samsung 970 Evo Plus (gen3 nvme) and the Corsair MP600 (gen4 nvme) have been completely normal in operation - on GParted and Calamares. Obviously I have no idea about KDE partition manager! :grin: There must be a package or service running that is unusual, and probably specific to KDE (IMHO - no knowledge that this is so).

I get this from lspci:

03:00.0 Non-Volatile memory controller: Phison Electronics Corporation E16 PCIe4 NVMe Controller (rev 01)

What does yours say?

I would try booting the barebones KDE ISO with the LTS kernel.

Did you perform a thorough search as I suggested?

It took me all of a minute to find this result and numerous others on the exManjaro forum.

Simply search for "NVMe not detected".

1 Like

Here is what my lspci says;

01:00.0 Non-Volatile memory controller: Micron Technology Inc Device 5405

I did try Barebones KDE ISO and KDE Lite too, sadly... no joy.
I still am working on those "NVMe not detected" search results.

Something of note though;
A few times, I have had my NVMe SSD appear in Calamares, KPM and GParted in Garuda Live and just KPM and GParted in my installed Manjaro only to disappear like a mouse fart in a whirlwind as soon as I try to do anything with it.

That looks relatively incomplete - no kmention of the NVME itself.... but I am not expert enough to know if that matters...

You have tried trolling through the BIOS, and ensured you're in ahci?

Out of ideas, I'm afraid...

The first link I posted about Windoze being responsible in a dual boot seemed to set my Spidey senses a tingling. Any dual boot with Windows can introduce unforeseen complications. Have you tried the solution suggested in the link I posted yet?

1 Like

A post was merged into an existing topic: User introductions