Cant get into boot menu when I put my usb (linux next to win11)

Hello!
Im new to linux and I watched a couple of videos about how to put linux next to win11 and i done everything as it said (put the usb on #1 bootable option) and yesterday I was able to get in to Grub and install but my install failed at choosing partition. After much tries I gave up and shut off my computer and plug my usb off. Today I tried it again but when I plug in my usb the menu wont let me in I smash f2 so hard but nothing but if i plug it out I can get into boot menu(I tired it with and out secure boot and fast boot) the thing is i cant see my 2 ssd drives only a "2." but nothing after it. I tried to set my boot into default but it frozes, format usb then bootable again, using other usb but still not booting and cant get into the menu. I dont know whats going on with my boot menu but im a little bit scared of losing data .

What should I do? Format my disks or idk?

Thanks,
Gerzson

1 Like

BTW, dual boot is not supported by Garuda Linux, it work fine until M$ break it, so, you are on your self.

4 Likes

I see, obviously you need to smash the key harder for things to work.

:rofl:

6 Likes

Welcome to the Garuda Forum
Are you able to boot into Win11 now?
Could you give some brief details about your PC, manufacturer, CPU, GPU...
So the issue is, you can boot the live Garuda USB, but it refuses to install on the disk, right?
Did you partition your disk for Garuda beforehand from Windows?

I would suggest you learn some basics about Linux partition schemes, maybe from youtube or some web articles(eg- https://www.howtogeek.com/howto/35676/how-to-choose-a-partition-scheme-for-your-linux-pc/)
I will suggest you to be familiar with manual partitioning instead of relying on automatic partitioning.
Basically, in short, you need,

  1. /boot/efi partition, where your boot files are stored
  2. /, partition, which is also known as the root partition where the system files are stored
  3. /home, where your(user's files are stored)

Don't try to modify your Windows partitions from the live media, it may cause Windows to be unbootable. Create space for Linux from Windows then try installing to that blank space in the disk.

Hey!

Yes i can boot into Win 11 when my Garuda usb is not in.
I have a Acer Nitro 5 AN-515-55

  • 1650 Ti
  • Intel I7 10750
  • 16gb ram

The issue is i cant get in to boot menu when my garuda usb is plugged in bootup and my win 11 dont boot in its stuck on my acer boot up logo. I think I can do the installing and others just idk how to fix that i cant boot when my usb in (I tried multiple usbs).

Yes I did and i choose the first option at the where-to-install and choose my disk but it couldnt find it i tried it multiple time too.

Thanks for your answer!

1 Like

There is no need to boot from live ISO to M$.
Remove fast and secure boot.

Did you read this and the manual too?

2 Likes

Try this:

try pressing F12 on boot to select USB.

by this you mean that pressing F2 won't bring the UEFI menu when the USB in plugged, right?

1 Like

Have you tried reverting this? (I assume you can access your BIOS if the USB is not plugged in).
If it works, when you'll need the live USB again, you could try using F12, to launch the boot menu instead of F2 to go to the BIOS.
If not working, I'd also try unflagging in windows (not in the BIOS) the "fast startup" (or whatever the name of the power-saving M$ functionality that sort of hibernates the system instead of fully shutdown)

2 Likes