Can't find Kernel on boot after an update

Hi, I was updating my system when my pc shutdown , and now my pc cant find the kernel, i tried to chroot but i get this error

sudo mount /dev/sda2 /mnt

but when i try to use 

sudo garuda-chroot /mnt/@ 

mount: /mnt/@/proc: mount point does not exist.
       dmesg(1) may have more information after failed mount system call.
==> ERROR: failed to setup API filesystems in chroot /mnt/@

Can someone help me? pls :slightly_frowning_face:

Hi there, welcome to the community!

Have you tried booting from a snapshot?


No, how do I do that?

I’m using a USB to access to my files, but I don’t know what is snapshot

Just move the cursor (arrow key) down and search for snapshot on grub page.


When you boot the Garuda Linux, there must be an option that says snapshots. I don’t remeber the exact name, but it is there.

If you don’t find it, I can share the image…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.