Can't boot on integrated Radeon GPU

Hello,
I am running a r5 4500u + integrated vega6 with no dedicated GPU.
Here's the problem,
When I try to boot from my USB stick it gets stuck so I removed quiet boot arg and it gets stuck on

[ 0.212208] ACPI BIOS Error (bug): Failure creating named object [\SMIB], AE_ ALREADY_EXISTS (20210604/dsfield-637)

[ 0.212909] ACPI BIOS Error (bug): Could not resolve symbol [_SB.PCIO.SBRG.E CO], AE_NOT_FOUND (20210604/dswload2-162)

[ 0.212914] ACPI Error : AE_NOT_FOUND, During name lookup/catalog (20210604/ps

object-220)

:: running early hook [udev]

Starting version 249.5-3-arch

:: running early hook [plymouth]

So I added the nomodeset boot arg and now it goes past a little I see a bunch of greenlit 'OK's and then

Starting Hold until boot process finishes up...

Starting Terminate Plymouth Boot Screen...

And it gets stuck at these lines.

I have tried running Arch, Clear Linux, EndeavourOs, Manjaro, PopOs and now Garuda.
Only EndeavourOs managed to install itself (with nomodeset) and boot, all the other's won't even boot the install media.
From all the reading and hearing I've done it seems like, the issue is with AMD divers.

I am a complete noob to Linux and it seems like I've picked myself a not ideal combo of hardware and software to begin with.
Could anyone help me with any of this?

A good point is that I can see other users in the forum with your CPU and amdgpu graphic driver, so there must be a way out :wink:
Just a few preliminary questions:
You are using the free drivers option in the grub, right?
Is your SATA mode set to AHCI in the BIOS?
Also in the BIOS, are fast boot and secure boot disabled?
Have you tried to set in the GRUB radeon.modeset=0 (do not include nomodeset in that test)?
What did you use, balena Etcher, Ventoy, ... ?

4 Likes

Maybe check also this one, about Vega 6, if you are using an external monitor...

2 Likes

Perhaps disable the radeon driver and use amdgpu drivers?

adeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 modprobe.blacklist=radeon```
Try adding these in your boot params
2 Likes

I think @regularCoder meant:

radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 modprobe.blacklist=radeon

Try adding these in your boot params

I added the initial r for radeon and restricted only code line in the code section.

1 Like

This sounds similar to my experiences with Ryzen and Linux. I found the following guide very helpful, especially the firmware section: [root tip] Dual boot Manjaro and Windows - Tutorials - Manjaro Linux Forum

Basically you need to make sure you have turned off any fast or secure boot options in the bios. You also need to ensure you have EFI fully enabled and Legacy boot support fully disabled. Or at least that's what worked for me.

Hope that helps!

2 Likes

Hey there,

So I've selected the free drivers in GRUB, the Nvidia version is highlighted by default but I manually select the free ones before booting or settings boot args.

I am using an MSI laptop with a very OEMey BIOS menu, it has no option to set SATA mode, but my laptop has just a single NVME drive and absolutely no SATA ports anywhere.

Fast boot and Secure boot are both disabled but My TPM device is enabled, I hope that's not an issue

I tried booting with radeon.modeset=0 but does the 'running early hooks [plymouth]' thing again

I used Rufus to make my boot media cebause etcher seems to corrupt my pendrives.

And like I mentioned, I am on a laptop so I can't change my monitor, I hooked up an external monitor and it did nothing. You see if the problem is with DPport or LVDS I don't have to privilege to removed my integrated screen.

Here's a few things I forgot to mention earlier.

I can get into TTY if I use the nomodeset boot arg.
I am running a dualboot alongside win11 on the same drive (diffrent partition tho)
Unfortunately my laptops has only one NVME slot and its very occupied by my one and only drive.

Also I'm really thankful to all the people who replied so quick, I am more confident than ever been about Linux.

1 Like

Did you try the boot args that Coder suggested?

radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 modprobe.blacklist=radeon

I tried your solution (with corrections from @anon26187667) and it didn't do anything, boot gets stuck here

:: running early hook [udev]

Starting version 249.5-3-arch

:: running early hook [plymouth]

Here are the default boot args

setparams Boot with open source drivers x86_64 lang-en_US keytable-us tz=UTC misobasedir-garud\ a misolabel=GARUDA_DR468NIZED_HARPYEAGLE quiet systemd. show_status=1' 

#set arguments above with the editor

linux /boot/valinuz-$2 driver=free nouveau.modeset=1 1915.modeset=1 radeon.modeset=1 

initrd /boot/and_ucode. Ing /boot/intel_ucode.ing /boot/initramfs-x86_64.img

I also tried your solution + radeon.modeset=0 but that didn't work either

P.S. also tried adding amdgpu.modeset=1 + your args
That doesn't work either

I have set my severely limited BIOS most optimally to the best of my knowledge but I'll read through the article and make modifications if necessary
Thanks

Indeed
I have left a reply with my findings

What is your laptop model ?

MSI Modern 14 B4MW

Linus was right, Linux is garbage, I get 404 when trying to look at the spec page on MSI's site for this laptop.
S'all Linux's fault. :rofl: :rofl:

msi normally have a advanced bios try right shift + right Ctrl + left alt + f2 when entering the bios if it has this ?
Also try ventoy for your garuda image on usb?

Here's the one I have.
The official MSI website is a big oooooff

Dear sir what the hell
Are you a wizard or something?

A simple iommu=soft boot arg solved everything.
Thankyou so very much.

3 Likes

I think you will have to try a few kernel boot parameters. I'd try e g.
iommu=soft
pci=noats
acpi=off

1 Like

Add follow to boot args

iommu=soft

That's it
This was suggested by @filo
I have no idea what it means, I'd leave that to the pros out there to explain