Cant boot into Garuda after installing it

I installed garuda(Garuda KDE Dr60nized) with the usb (garuda downloader+etcher), it installed without any problems, but after rebooting it just boots into the usb again. If i disconnect the usb then the system doesnt find any bootable devices.

I’m using a dell xps 15 9570, secure boot is turned off, fast boot is set to thorough(i cant set it “off”), i set the bootloader to uefi,SATA to AHCI.

I looked for an similar problems, the only one i found was this(After the instalation of Garuda KDE Dr460nized i cant boot the OS) but the dude just changed machine.

Thanks in advance

  1. Please post your garuda-inxi from live ISO as per template
  2. Try to update your BIOS I have seen this problem before and it was solved with BIOS updates.

This is my garuda-inxi output, i’ll try to update the bios and get back to you

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial: <filter>
Chassis: type: 10 serial: <filter>
Mobo: Dell model: 0D0T05 v: A00 serial: <filter> UEFI: Dell v: 1.27.0
date: 08/12/2022
ID-1: BAT0 charge: 5.0 Wh (100.0%) condition: 5.0/56.0 Wh (8.9%) volts: 12.3
min: 11.4 model: BYD DELL CP6DF89 type: Li-poly serial: <filter>
status: full
Info: model: Intel Core i7-8750H socket: BGA1440 (U3E1) note: check bits: 64
type: MT MCP arch: Coffee Lake gen: core 8 level: v3 note: check built: 2018
process: Intel 14nm family: 6 model-id: 0x9E (158) stepping: 0xA (10)
microcode: 0xF4
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 858 high: 900 min/max: 800/4100 base/boost: 2277/4100
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 896 2: 800 3: 868 4: 897 5: 900 6: 900 7: 877
8: 872 9: 800 10: 895 11: 800 12: 800 bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Dell
driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-09) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1c8c
class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-12:5
chip-ID: 0c45:671d class-ID: 0e02
Display: server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Sharp 0x149a built: 2018 res: 1920x1080 hz: 60
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: EGL Message: No EGL data available.
API: OpenGL v: 4.6 vendor: intel mesa v: 23.2.1-arch1.2 glx-v: 1.4
es-v: 3.2 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
device-ID: 8086:3e9b memory: 7.23 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 4 device: 0 type: integrated-gpu name: Intel
UHD Graphics 630 (CFL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:3e9b surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce GTX 1050 Ti with Max-Q Design driver: nvidia
v: 535.113.01 device-ID: 10de:1c8c surfaces: xcb,xlib device: 2 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.83 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 3b:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp59s0 state: down mac: <filter>
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4
chip-ID: 8087:0025 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c010c
Local Storage: total: 2.14 TiB used: 0 KiB (0.0%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba
model: KXG50ZNV256G NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: AADA4106 temp: 34.9 C scheme: MBR
SMART: yes health: PASSED on: 3y 14d 18h cycles: 3,553
read-units: 126,740,963 [64.8 TB] written-units: 84,835,643 [43.4 TB]
ID-2: /dev/sda maj-min: 8:0 model: Flash Disk 3.0 size: 1.91 TiB
block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
lanes: 1 mode: 2.0 tech: SSD serial: <filter> fw-rev: 2.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.4 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 75.0 C pch: 52.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 256 Uptime: 5m wakeups: 2652 Memory: total: 8 GiB
available: 7.4 GiB used: 3.68 GiB (49.7%) igpu: 64 MiB Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1274 libs: 358 tools: octopi,paru Shell: garuda-inxi (sudo)
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.17-1):
System install date:     2023-11-14
Last full system update: 2023-11-14 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

‘Sounds’ from your description like the bootloader may not have been installed, or installed in the wrong place. Was the ISO current? Are you going with the installation defaults?

You’re making the right selections in your BIOS but, like @NaN said, there are probably updates for it. Dell is pretty good about that. That’s all I buy and all I’ve used Linux on going back years.

Just finished updating the bios with the latest version i could find that supports my machine(1.27.0). Nothing changed, i still cant seem to load the os at startup, also the iso i downladed is the latest(dowloaded yesterday evening)

Hmm can you share the output of

lsblk -f

because according to your inxi it seems you haven’t installed the system at all? The drive is blank and empty. There are no partitions… :thinking: Can you try running calamares (the installer) once again?

1 Like

Hey thank you for the advice, i tried running the installer again and it worked! Maybe it worked now because of the updated bios…
Anyway the system was actually installed because when i was formatting the ssd during the installation it said it had partitioned the ssd to garuda linux and swap.
Also it froze 2 times while loading Garuda, it got stuck showing:

Booting 'Garuda Linux'
Loading Linux linux-zen ...
Loading initial ramdisk ...

Thank you for the help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.