Can't boot Garuda iso image

Garuda iso image doesn't boot into my PC. I prepared USB Drive with Ventoy.

In BIOS settings I tried both Legacy and Secure Boot, with Legacy active the screen remains black with only the symbol "_"

With Secure Boot active it say:
error: prohibited by secure boot policy.
Entering rescue mode...
grub rescue˃ _

I tried to boot Arcolinux iso image and boot normally in both modes

The iso is latest garuda-dr460nized-linux-zen-230319.iso

Try with both legacy and secure boot disabled.

1 Like

Same as having only Legacy active, after waiting about 2 minutes doesn't start

These are PC specs.
Windows iso also boot without problems

Have you verified the ISO checksum?
Or maybe just download again, verify the checksum and copy to the Ventoy USB.

1 Like

I download again iso image, with VirtualBox works.

I disabled also UEFI boot into the BIOS but Ventoy stay always at VTloading...
While with UEFI boot enabled starts, but only Ventoy, not Garuda iso

Can you confirm secure boot has been disabled? Describe the process you have used for disabling secure boot.

I'm not sure what this screenshot is. Does it have any information about secure boot?


It looks like you are still able to boot to Windows 11, which would imply your efforts to disable secure boot have not succeeded.


Here is disabled Secure Boot and enabled Legacy but also disabling both Garuda doesn't start

Here is UEFI enable or disabled

Is the Ventoy new? Or was it set up a while ago?

1 Like

Ventoy is latest on pendrive default settings, Secure Boot enabled, pendrive was formatted 2 days ago

Are you booting the Arcolinux ISO from the same Ventoy, or with another method?

Same Ventoy and pendrive and same PC. Kubuntu also works with Legacy and UEFI enabled and Secure Boot disabled.
While Manjaro give same problem of Garuda Linux, but Im interested to install Garuda near Windows

I would suggest as @filo said i would check your download with the checksum

1 Like

I just downloaded garuda-dr460nized-linux-zen-230319.iso and put it on a Ventoy, and in my case it works fine.

It is interesting the ISO works in VirtualBox--that would suggest you have a good ISO.

Check if you have options for your device's SATA controller in your BIOS menu. If you do, set to AHCI mode.

Just to confirm:

  • Secure boot, fast boot, and legacy boot are all disabled.
  • UEFI mode is enabled.
1 Like


AHCI is default then there is RAID and IDE

Disabling both Legacy and Secure Boot and enabled UEFI same result for Garuda, black screen with symbol "_"

With arcolinux the PC give 2 bips and boot normal, with Kubuntu the boot start normal without bips, with Manjaro same problem of Garuda

Maybe the Motherboard not fully compatible?

What kernel does Arco Linux boot with? Check if any kernel parameters are in use.

If you have one or can get one, try a different USB stick.

On arcolinux the kernel is 6.2.6, on Garuda the kernel is 6.2.7
I Will try with another pendrive