Cannot install Garuda Linux on My Computer (dual boot system)

Hi there,

Sorry to bother you but I was trying to reboot my Garuda Linux. However, it kept on restarting where there was a loop of it rebooting back to the GRUB Menu even if I shut it down. It gets to the GRUB menu which I will show in a picture. So then I tried clearing out my USB and my SSD then reinstalling (I don't really have any important files). I still Although I would like to use Garuda for most of my code, I need Windows for work.

I have an ASUS ROG GV301QE-211.ZG1.

Things I have tried:

Clearing out my SSD
Clearing out my USB
Every Detect EFI BootLoader possible
Boot with Open Source
Boot allowing propriety Drivershelp
Looked through the forum and couldn't find anything remotely similar
I keep on running into this issue. If you could help please do so! :slight_smile:

EDIT: Here it is! :slight_smile:

Unmount and remove the USB key from the USB port, please. Then reboot.

5 Likes

Hi,

How do I umount the USB?

Shut down the system. Remove USB media. Reboot.

We know what the installer screen looks like, no need to send photos of it as they will only clutter up our servers (they can't be deleted, they always stay in memory) as well as cause unnecessary traffic.

We are a Garuda help forum here and you should consider, if you want to use a rolling release, to deal with the basics. We don't like to repeat things here that can be done in 30 seconds with a whoogle or duckduckgo search. We also don't want to bring in help vampires.

Everything that is not in our wiki you can find here in the forum or in our "bible" the Arch Linux Wiki.

Deepl (free version) always translates a bit harder than it is meant :slight_smile: .

Translated with www.DeepL.com/Translator (free version)

BTW, how do you install last time?

3 Likes

I tried that already. I did the same thing last time, I installed Garuda and it worked. Now, when I try unmounting and removing and then trying to install Garuda, it just keeps going back to the installer screen. I am also trying not to post "30-second issues" on this forum, otherwise I would have done this myself. As you can see I only have been posting 3 times (including this one).

Wasn't this post already marked "solved"? What happened?

This does not seem possible, unless you are powering on the computer with the USB drive plugged in. The installer does not get stored on the computer.

This is the solution:

If it is still booting to the installer screen, there is something about that instruction you are not doing.

2 Likes

Did you checksum your ISO after downloading?

What method did you use to burn your image to disk (flashdrive)?

Perhaps it would be worth downloading and burning the Xfce edition as it uses the LTS kernel. If you successfully installed Garuda in the past perhaps the kernel in use could be a factor. If you can successfully initiate an install with Xfce at least that is useful information that could help in pinning down the cause of your problem.

1 Like

Hi there,

My full method was I used BalenaEtcher to burn my image to my flash drive and downloaded the .iso using Sourceforge. I haven't done a checksum as I do not know what checksum to perform. Also, I wanted to say, that I followed the instructions as above and I still get the same output no matter what I do.

On what drive did you install Garuda and where did you install GRUB?

Wait.

Which GRUB menu does it show, and is that actually the issue or is it that it reboots rather than shuts down?

1 Like

Bingo?!! !

So basically to explain my situtation:
USB: Lexar Flash
SSD: Samsung Portable SSD T7
GRUB GNU 2.06
I shut it down it shuts down. When I reboot without the USB my Windows 11 shows up. So I put in the USB and restart. I have already set my BIOS to boot the USB first and then my Windows 11. So then it goes to the Garuda Installer Menu. Often times I know that my computer is restarting again because it makes this sound with the ASUS Republic of Gamers logo showing up in the screen. So when I select my booting options and press enter (in which I have tried both boot selected) on my keyboard, it keeps on restarting but not to the actual Garuda installer/OS.
If I remove my USB stick it goes back to Windows.

What does that mean?

There is a point I'm still missing.
The title says "Cannot install Garuda...".
If this is the case (you haven't been able to install so far), it is normal that upon boot without USB plugged in you see Windows 11. Garuda is not in your SSD yet.
When the USB is plugged in and the (USB) GRUB menu shows up as per your picture, are you able to launch Garuda (live), either with free or proprietary drivers? What happened? Error messages, black screen, etc...
If you managed to boot from the live USB, have you been able to launch the installer? What happened then?
On the other hand, if you have already installed from the USB to your SSD, this is a different problem (could be due to wrong GRUB configuration, or simply you should set Garuda as first entry in your UEFI boot list). But the title and description so far don't seem to go in that direction.

2 Likes

I installed Garuda beforehand ( like Sep 2021-ish). I didn't use it due to the fact that I have been working and I could only use windows. Now, I need Garuda for a personal project of mine and when I try booting it turns black then restarts then goes back to the Installer Menu. I tried all the boot options.

Can you boot the live usb and provide your
garuda-inxi

from the live environment.
you will see a tab in garuda assistant/system specs and copy to forum

2 Likes

How do you try it?
Grub menu with Garuda, win10/11, advanced, snapshots?

Seems M$ update destroy grub, so chroot from live ISO and repair.

In the end, we do not support dual boot.

7 Likes

So you boot into the installer right then select boot with free drivers, or boot with non free drivers it then just reboots?

Yup! I boot into the installer and then it just reboots.

It will do if you are in the installer?

1 Like