Cannot change the konsole color theme

Hello All,

I am trying to install Dracula theme in my konsol via omf. It does show that it is installed but the color scheme is not changing (nor any other theme from omf) the theme seems to be applied. I am new to all this so any help for achieving this step by step will be appreciated

Thank you

Can we have your

garuda-inxi

as per the template

Welcome to the forum

4 Likes
Kernel: 5.18.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ceeb6801-7da0-4c8b-978d-0d079910275c rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.25.2 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 20TDCTO1WW v: ThinkPad E15 Gen 2
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20TDCTO1WW serial: <superuser required> UEFI: LENOVO
v: R1EET41W(1.41 ) date: 07/30/2021
Battery:
ID-1: BAT0 charge: 46.3 Wh (100.0%) condition: 46.3/45.0 Wh (102.8%)
volts: 12.6 min: 11.1 model: LGC 5B10X026 type: Li-poly serial: <filter>
status: full cycles: 83
CPU:
Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
arch: Tiger Lake built: 2020 process: Intel 10nm family: 6
model-id: 0x8C (140) stepping: 1 microcode: 0xA4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 758 high: 1712 min/max: 400/4700 scaling:
driver: intel_pstate governor: performance cores: 1: 1238 2: 447 3: 543
4: 541 5: 608 6: 1712 7: 579 8: 401 bogomips: 44851
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
ports: active: HDMI-A-1,eDP-1 empty: DP-1, DP-2, DP-3, DP-4
bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: N/A
alternate: nouveau non-free: 515.xx+ status: current (as of 2022-06)
arch: Turing process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s
lanes: 4 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.0
chip-ID: 10de:1f97 class-ID: 0302
Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-8:3 chip-ID: 13d3:56fb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4022x1080 s-dpi: 96 s-size: 1061x285mm (41.77x11.22")
s-diag: 1099mm (43.25")
Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,left
model: Idek Iiyama PL2481H serial: <filter> built: 2014 res: 1920x1080
hz: 60 dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54")
diag: 598mm (23.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
Monitor-2: eDP-1 pos: primary,right model: BOE Display 0x085e built: 2018
res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.3
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Sound Server-1: ALSA v: k5.18.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.55 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 4000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:7 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 1.4 TiB used: 90.37 GiB (6.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 5108AGLA
temp: 57.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung
model: MZALQ512HALU-000L1 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: BL1QFXV7 temp: 37.9 C scheme: GPT
Partition:
ID-1: / raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 62.31 GiB (13.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
ID-3: /home raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 62.31 GiB (13.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 62.31 GiB (13.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 476.68 GiB size: 476.68 GiB (100.00%)
used: 62.31 GiB (13.1%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.06 GiB used: 2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 420 Uptime: 1h 3m wakeups: 132 Memory: 31.06 GiB
used: 5.31 GiB (17.1%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1604
pacman: 1583 lib: 354 snap: 21 Shell: fish v: 3.4.1 running-in: konsole
inxi: 3.3.19
Garuda (2.6.4-2):
System install date:     2021-11-20
Last full system update: 2022-07-13
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:            bluetooth-autoconnect.service memavaild.service nohang-desktop.service open-fprintd.service optimus-manager.service prelockd.service`Preformatted text`

Can you provide more details about where you got the theme from, and how you installed it?

i installed Oh my fish and then tried to install one of the theme from the available theme and it was not successful. Then I tried to install Dracula from Dark theme for Fish and 271+ apps — Dracula, it does show that its installed but the terminal looks same.

I was able to get it to work from that link you posted.

I downloaded that .zip, extracted it, and moved dracula.fish to ~/.config/fish/config.d/ like it says.

mv dracula.fish ~/.config/fish/config.d/

Reload fish:

exec fish

Here is my terminal side-by-side with their example screenshot:

2 Likes

Yes I did the same. Still it is not working . I tried to share image here but it seems that it is not allowed for new users.

New users cannot share images in forum ..lol

That's to prevent spam bots from taking over.

Please paste the contents of your fish/config.d directory.

ls -la ~/.config/fish/config.d/
2 Likes
drwxr-xr-x    - lepton 17 Jul 19:27  .
drwxr-xr-x    - lepton 17 Jul 19:27  ..
.rw-r--r--  11k lepton  8 Aug  2021  done.fish
.rw-r--r-- 1.7k lepton 17 Jul 19:27  dracula.fish
.rw-r--r--  203 lepton 17 Jul 16:55  omf.fish

do i need to change permission of dracula.fish

No, the permission looks fine. You do not have mcfly.fish? :thinking:

I'm not sure what omf.fish is or does; I'm wondering if it might be interfering with your new file. Can you try to move it out of the directory for now to test? You could just stick it in your home folder, or any other folder you like.

mv omf.fish ~/

Reload fish:

exec fish
2 Likes

Please read

and edit your last post if you think of anything else as long as no one has replied to this one.
A forum is not a chat like Telegram.

1 Like

omf is oh my fish. It helps you install plugins or themes in fish. you have similar installer for zsh called oh my zsh. Nevertheless, no matter which method I use, the terminal looks same.

Is it necessary to restart the terminal/konsole to see the change?

1 Like

Please, no pictures from terminal.
Again, edit your last post, forum dos not changed to a chat room in the last minutes :slight_smile:

1 Like

Problem solved. It was color-scheme problem from Kde. Sorry for the troubles and thank you for your time and effort. Apologies for the not following the guidelines. I will try to do comply for next post on wards.

Hmm, this does not sound right. The template you have linked is a theme for Fish, not for KDE or Konsole.

What did you end up changing that gave you the desired result?

3 Likes

...and...

matrix-welcome-to-the-real-world-frannigan-smallest

:wink:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.