Cannot boot without two monitors

I recently reinstalled Garuda KDE Dragonised with two monitors, and it works as expected, but as soon as I try and boot with only one monitor connected, I can't get past "Loading initial ramdisk" after selecting Garuda in GRUB. Any idea how to get past it, or how I can prevent this from happening again?

Can you provide your inxi-Fza

2 Likes

where can I get this from?

Go to terminal and type inxi-Fza them copy and paste here with ~~~ before and after it

not sure how to get a normal terminal open if I can't boot, and the grub one from pressing C didn't recognise the command so I'm guessing that's a different thing entirely

Try pluging in your two monitors then boot , login then please provide?

I'm away for the weekend and only brought one :sweat:

Are you dual booting?

This can still be done from the terminal.

First:


How to boot to run level 3:


Then:


Posting outputs & logs via the terminal:

Termbin is an open source terminal/netcat based pastebin type service.

Usage:


inxi -Faz  | nc termbin.com 9999

sudo dmesg | nc termbin.com 9999

journalctl -b0 -p4 | nc termbin.com 9999

cat /var/log/Xorg.0.log | nc termbin.com 9999

Termbin accepts large log outputs without any size restrictions from my limited experience using it.


See:

termbin.com


5 Likes

Yes, and I'm using windows to type this rn.

Last night when I wasn't looking, windows did an update and now the name of my garuda partition, and the filesystem is changed and grub is in rescue mode. It sabotaged my partition again. Unbelievable. I've learned my lesson, buying another small SSD so I don't have to have this cancer running alongside linux lol. Might have to put fixing the monitor issue on hold :sweat:

If you end up reinstalling, then do the installation without your secondary monitor connected. Be sure to have a snapshot using only your laptop monitor saved.

3 Likes

will do, thanks so much for your help!! <3

1 Like

I'm home now on a new install with the same problem, but at least now I've got the inxi -Fza output:

parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=bdc23692-a79c-45e0-a2f0-9f968b6d38db  
rw rootflags=subvol=@ quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: ASUSTeK model: Z170M-PLUS v: Rev X.0x serial: <filter>  
UEFI: American Megatrends v: 1803 date: 05/09/2016  
Battery:   Device-1: sony_controller_battery_a4:53:85:9b:83:6f model: N/A serial: N/A charge: N/A  
status: Full  
CPU:       Info: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S family: 6  
model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27999  
Speed: 4200 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4200 2: 4124 3: 4200 4: 4200  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled  
Type: mds mitigation: Clear CPU buffers; SMT disabled  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort mitigation: TSX disabled  
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:1912 class-ID: 0300  
Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: N/A  
alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting  
display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: DP-1 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3") diag: 584mm (23")  
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes  
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel  
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403  
Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel  
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403  
Device-3: Sony DualShock 4 [CUH-ZCT2x] type: USB driver: snd-usb-audio,sony,usbhid  
bus-ID: 1-10:6 chip-ID: 054c:09cc class-ID: 0300  
Device-4: JMTek LLC. USB PnP Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid  
bus-ID: 1-3:4 chip-ID: 0c76:161f class-ID: 0300  
Sound Server-1: ALSA v: k5.14.3-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.35 running: yes  
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: f040  
bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200  
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Drives:    Local Storage: total: 1.94 TiB used: 25.36 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVPV128HDGM-00000 size: 119.24 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: BXW7300Q temp: 48.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC26 scheme: GPT
Partition: ID-1: / raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 25.36 GiB (21.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 25.36 GiB (21.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 25.36 GiB (21.3%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 118.99 GiB size: 118.99 GiB (100.00%) used: 25.36 GiB (21.3%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:      Processes: 227 Uptime: 4m wakeups: 1 Memory: 15.53 GiB used: 2.55 GiB (16.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1365 lib: 373 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

(note: just in case this matters, I usually change to nvidia in optimus manager on every fresh install, but this time optimus just doesn't exist.. :thinking: but anyway, I ran a game and it appears to be running on the GTX 970, which is good)

installing optimus and switching to nvidia seems to have fixed everything? very odd considering this configuration is now identical to what I had when I made the original post.. but ok I guess :sweat_smile:

big thanks to you both though :slight_smile:

1 Like