Cannot boot without two monitors

it can't find any process under latte, and clicking latte in krunner seems to do nothing

Start latte via the terminal, post any errors.

running latte-dock brought up the latte dock settings window (not the actual dock though), and terminal says:

Icon theme "gnome" not found.
"An instance is already running!, use --replace to restart Latte"

It is running and needs to be killed and restarted.

Just out of curiosity, have you tested alternate kernels?

If not test at least linux, linux-lts, and linux-mainline.

--replace didn't do anything.

I did try linux-lts seeing as it was mentioned in setup assistant as the "failsafe option" but not after the plymouth fix, so I'll give it another go, along with the other two.

(cacule stopped linux kernel from installing so I'll remove it for now)

1 Like

the linux kernel wouldn't install:

The following packages will be installed:

resolving dependencies...
warning: linux-mainline-5.15rc4-1 is up to date -- reinstalling
looking for conflicting packages...
Packages (5) linux-5.14.10.arch1-1  linux-headers-5.14.10.arch1-1  linux-lts-5.10.72-1  linux-mainline-5.15rc4-1  linux-zen-5.14.10.zen1-1
Total Installed Size:  609.63 MiB
Net Upgrade Size:      262.40 MiB
:: Proceed with installation? [Y/n]
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/5) Creating Timeshift snapshot before upgrade...
E: Commands listed below are not available on this system:
* rsync
 * /sbin/blkid
 * df
 * mount
 * umount
 * fuser
 * crontab
 * cp
* rm
 * touch
* ln
* sync
Please install required packages and try running TimeShift again
** (process:5231): CRITICAL **: 15:44:11.980: app_lock_remove: assertion 'self != NULL' failed
Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
Errors occurred, no packages were upgraded.
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)

Done ...

So I tried mainline/lts and there was no change in behaviour in either.

(Edit: on the two monitor setup that always worked properly previously, the resolution is still fine but now it also has the dock/top bar issue, so that isn't exclusive to the broken one monitor setup this topic is about. I brought the monitor in question with me though as I still want to get this all working on that monitor alone, because it's all I travel with)