Cairo Dock Blur Stuck after Auto Hide

Hello!

I'm attempting to use Cairo Dock in the meantime as a replacement for Latte on Plasma. I got it started, however, upon the dock hiding, it leaves this blurred rectangle block at the bottom of my screen that I can't figure out how to remove. I searched the forum and Arch Wiki and didn't find a post relevant to it, so I figured I'd see if you all knew how to fix this. Picture is below:

System:
Kernel: 6.1.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ecc9f01a-0d6a-403f-b80f-50e254d8bad8 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.7 info: cairo-dock
wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: LENOVO product: 82BG v: Yoga 9 14ITL5
serial: <filter> Chassis: type: 31 v: Yoga 9 14ITL5 serial: <filter>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709WIN serial: <filter>
UEFI: LENOVO v: EHCN74WW date: 05/17/2022
Battery:
ID-1: BAT0 charge: 34.2 Wh (59.4%) condition: 57.6/60.0 Wh (96.0%)
volts: 7.6 min: 7.7 model: Celxpert BASE-BAT type: Li-poly serial: <filter>
status: not charging cycles: 23
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Device-2: wacom_battery_0 model: Wacom HID 523A serial: N/A charge: 0%
rechargeable: yes status: N/A
CPU:
Info: model: 11th Gen Intel Core i7-1185G7 socket: U3E1 bits: 64
type: MT MCP arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xA6
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2174 high: 3000 min/max: 400/4800 base/boost: 3000/3000
scaling: driver: intel_pstate governor: powersave volts: 0.8 V
ext-clock: 100 MHz cores: 1: 3000 2: 764 3: 652 4: 981 5: 3000 6: 3000
7: 3000 8: 3000 bogomips: 47923
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: DP-7,eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, DP-6
bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-6:3 chip-ID: 04f2:b61e class-ID: 0e02 serial: <filter>
Device-3: Creative Live! Cam Sync 1080p type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2.1.3:7 chip-ID: 041e:409f
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1921x2160 s-dpi: 96 s-size: 506x570mm (19.92x22.44")
s-diag: 762mm (30.01")
Monitor-1: DP-7 mapped: DP-2-3 pos: primary,top-right model: MSI G271
serial: <filter> built: 2021 res: 1920x1080 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: eDP-1 pos: bottom-l model: LG Display 0x061f built: 2018
res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
diag: 355mm (14") ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.3.2 renderer: Mesa Intel Xe Graphics (TGL GT2)
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 5-2.1.1.2:8
chip-ID: 17ef:3083 bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0300
class-ID: 0401 serial: <filter>
Device-2: Lenovo ThinkPad Thunderbolt 3 Dock USB Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid
Device-3: Creative Live! Cam Sync 1080p type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2.1.3:7 chip-ID: 041e:409f
class-ID: 0102 serial: <filter>
Device-4: C-Media Q9-1 type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 5-2.1.4:9 chip-ID: 0d8c:0135 class-ID: 0300
Sound API: ALSA v: k6.1.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Lenovo ThinkPad TBT 3 Dock type: USB driver: r8152
bus-ID: 6-2.1.2:4 chip-ID: 17ef:3082 class-ID: 0000 serial: <filter>
IF: enp59s0u2u1u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 19.45 GiB (4.1%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVLB512HBJQ-000L2 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3L1QEXF7 temp: 33.9 C scheme: GPT
SMART: yes health: PASSED on: 43d 7h cycles: 328
read-units: 11,525,472 [5.90 TB] written-units: 15,377,787 [7.87 TB]
Partition:
ID-1: / raw-size: 139.09 GiB size: 139.09 GiB (100.00%)
used: 19.45 GiB (14.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-2: /boot/efi raw-size: 1.07 GiB size: 1.07 GiB (99.80%)
used: 608 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p5
maj-min: 259:5
ID-3: /home raw-size: 139.09 GiB size: 139.09 GiB (100.00%)
used: 19.45 GiB (14.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-4: /var/log raw-size: 139.09 GiB size: 139.09 GiB (100.00%)
used: 19.45 GiB (14.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
ID-5: /var/tmp raw-size: 139.09 GiB size: 139.09 GiB (100.00%)
used: 19.45 GiB (14.0%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.36 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
Src: /sys System Temperatures: cpu: 44.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 286 Uptime: 1h 17m wakeups: 103 Memory: 15.36 GiB
used: 3.99 GiB (26.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1365
libs: 361 tools: octopi,paru Shell: garuda-inxi (sudo) default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.13-1):
System install date:     2023-01-03
Last full system update: 2023-01-03 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Yes
Failed units:            systemd-networkd-wait-online.service

Thanks team!

So through some tinkering I was finally able to figure this out. I had to go in and disable the "Blur" desktop effect in System Settings -> Workspace Behaviour -> Blur (uncheck).

Replying for those who might have the same issue. This is just to get me by until the new ISO comes out. :nerd_face:

How do you like Cairo dock, could you share some experience and impressions from it ?

This might be caused by the force blur kwin script - try enabling the blur option and setting Cairo dock as excluded application via Kwin scripts -> force blur -> settings.

3 Likes

I don't see Cairo as an alternative to Latte since it's been a dead project for years with no patches whereas Latte has been a dead project but with bug fixes.

So I did that, logged out and back in, and so far it has fixed the blur issue, although previously it happened at random. I'll keep tabs on it throughout today, and update this post if it gets blurred again.

1 Like

As mentioned above, it's a dead project, so the dock feels a little bit outdated, but I always enjoyed how lightweight the dock is compared to Latte. It's got a little bit of a learning curve compared to Latte, but since Garuda will be switching away from Latte, I figured might as well get used to not having it, and save me some memory in the meantime. Lol The top bar took some configuring to get it to look similar (not the same though; for instance, I had to enable the titlebars again on maximization since I can't grab the window from the panel like I could with Latte.) as Latte's top panel. I've included what my Plasma top bar looks like, and Cairo Dock below.

image

It isn't hard to get it to match Garuda's sweetified theme with some tweaking. You'd just have to play around with it, and do some tweaking with it. Overall it's not a bad dock.

Considering Latte is no longer getting maintained at all (from my understanding; I could be wrong though), and the next ISO of Garuda will be shipping WITHOUT Latte, it doesn't bother me at all to switch to Cairo, as memory usage with Latte for me would always spike my memory up to 11 or 12 of my 16gb. Cairo is a more lightweight option, it does what I need, so I consider it a valid replacement to Latte dock for now. Again, this is just for usability until the next Garuda ISO comes out, and my memory footprint is much lower than it was with Latte (only 2.7gb of 16 with several programs open vs 11 to 12gb). But I see what you mean. Each person has their own preference for what tools work for them, and that's okay.

I am currently using the Developer version of Garuda that is without Latte. THe substitute dock is the KDE dock/panel and it works pretty good. Not so many options but I am very satisfied.
I also have a topic in the forum you can search for it sharing my experience.

2 Likes

@sudoman I tried to go and find the ISO for the dev version, but every link I clicked on gave me a 404 error. Do you still have that ISO? If so, I'd love to give it a try!

There is no need to perform a full reinstallation:

  1. Install garuda-dr460nized-next
  2. Apply the dr460nized global KDE theme via system settings
  3. Profit?? :joy:
6 Likes

Apply appearance AND desktop layout?

Yup, both need to be applied in order to get the Plasma panels set up.

1 Like

Am I okay to remove this?

1 Like

Yes, since it replaces the package that's intended use.

4 Likes

I held my breath and hit 'yes' anyway, and it all worked out! Stupid stuff like that is why I have to reinstall so often. :joy: I hold my breath, click through it, and break my system. Lol

I really like the design and the icon glow on hover. It seems like a suitable replacement for now! I noticed the layout didn't come with the Netspeed widget. Did maintenance support for that widget drop, or are we just not including it in this layout?

1 Like

Since Cairo don't seem to have the ability to clone the default panel I simply went back to the default panel at the top, a empty panel on the right for Virtual Desktop Bar, a empty panel on the right for browsers email and messaging app shortcuts, and a empty panel on the bottom for my most accessed apps. All autohidden.

Heh, I'm glad you seem to like it!

The netspeed widget is in fact not included anymore. I preferred a more clean look :slight_smile:

1 Like

That's okay, Garuda is still (dr460n)fire. It's why I have it on all computers in my home. :grin: It took my wife a while to get used to it (she is a KISS computer person), but she mains it now too! Though, I have to do all the updates and maintenance for her now. :sweat_smile:

1 Like

Please, never post picture from terminal, just copy and paste here as text.
With 3 ~ in first and last line
~~~
Terminal text
~~~
then others can easily expand or copy the text.

Terminal text.
then others can easily expand or copy the text the view. Move the mouse pointer over it in the upper right corner. 
Move the mouse pointer over it in the upper right corner.