Booting stuck after shutdown while updating

Hello there, so I believe I shutdown my computer while it was still updating. Now it load the grub and get stuck with an error that hasnt caused any problem when booting before, I had this error since a few months, and when looking about it it seems harmless. Anyway I tried boot repaire, reinstall or repair grub, dont have mbr or pbr backup. chroot tells me no linux partition detected. Tried mounting my drive with chroot but it tells me cannot find efi directory. In fact I dont know what I'm doing, is it a mount problem or grub or whatver?
Heres my garuda-inxi if helpfull:

Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 ibt=off driver=nonfree nouveau.modeset=0
i915.modeset=1 radeon.modeset=1
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z390-I GAMING v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2812
date: 10/12/2020
Info: model: Intel Core i5-9600K bits: 64 type: MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xF0
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 1800 high: 1801 min/max: 800/4600:5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 1800 2: 1800 3: 1800
4: 1800 5: 1800 6: 1801 bogomips: 44398
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Micro-Star MSI
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 4
link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1e89 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x342mm (31.57x13.46")
s-diag: 872mm (34.33")
Monitor-1: DP-2 res: 3440x1440 hz: 100 dpi: 109
size: 798x334mm (31.42x13.15") diag: 865mm (34.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA
520.56.06 direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno2 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 928.13 GiB used: 635.22 GiB (68.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS500G3X0C-00SJG0 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 111110WD temp: 50.9 C scheme: MBR
ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: B1D1 scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: DaneElec model: MicroUSB
size: 15.24 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No partition data found.
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 2.86 GiB (18.4%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 54 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Processes: 255 Uptime: 2h 9m wakeups: 0 Memory: 15.54 GiB used: 7.69 GiB
(49.5%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1195 libs: 295
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2023-07-01
Last full system update: 2023-07-01 ↻
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            snapper-cleanup.service

or redirect me to a post I missed

Use the search icon, please. I've seen this topic posted a dozen times here today.


Thats what I did for 4 days. the things Ive mentioned doing are things mentioned in most of the post mentioning that. I tried to mount boot and know I'm stuck at grub repair. Its good to read all post with same problem but most solutions arent the same and I dont know whats my specific problem. Do I have to add a line to etc/default grab? Add setfont to the binaries section of /etc/mkinitcpio.conf. ? I dont have snapshots. I've tried following advices I didnt realy understand and now I have another error and I cant manage to find a solution. All I can do is copy past solutions that works for others but not me and Im sure I made it worse. I tried chroot to mount my disk for it to boot correctly, but it tells me my device doesnt exist when I do sudo mount /dev/nvme0p1n1 /mnt/nvme0n1 in fact Im not sure what disk to put after /dev, saw many solutions with that but dont understand which disk they chose. Myabe it has nothing to do with kdfontop. When I look in gparted it only show btrfs and not the /boot/efi that should come with it. I dont know what to do and Im afraid to mess it up more and have to reinstall

Looks like the best fix is replacing the Zen kernel with the Mainline. In MY case, I installed the mainline, but it won't switch from the Zen kernel.

I did just run another update and Plymouth updated again but haven't rebooted yet

I believe your problem is a little different than the other posts you have read. At the moment, this is your most significant problem:

This is almost certainly the source of the issue:

This can definitely break things, and can often be difficult to fix.

This is correct, the KDFONTOP error is not significant. You can fix it or not fix it, it won’t have any effect on the current state of your device.

The device you have typed there is typo’d, for starters. Also, did you actually create a directory at /mnt/nvme0n1? You cannot mount a device on a directory that does not exist.

From the live environment, run lsblk -f. This will help clarify what partitions are what. In the live environment, connect to the internet, open a browser, and log into the forum. Paste the terminal output from lsblk -f here into the thread so we can see what it says.

This is a helpful guide for setting up a chroot (manually) from the live environment and reinstalling the Grub bootloader:

As you follow the guide, copy the terminal input and output and paste it into the forum here.

In your case, after you install Grub you should also attempt to bring your system up to date:


Again, paste the input and output into the forum thread so we can see what is happening.

If the terminal output grows too lengthy for a forum post, use the PrivateBin link in the upper right-hand corner of this or any other forum page. Put the terminal output into the paste bin and add the URL they give you to the forum thread.


Im sorry if I waste time.
the output of lsblk -f is:

NAME FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
squash 4.0                                                                  0   100% /run/miso/sfs/livefs
squash 4.0                                                                  0   100% /run/miso/sfs/mhwdfs
squash 4.0                                                                  0   100% /run/miso/sfs/desktopfs
squash 4.0                                                                  0   100% /run/miso/sfs/rootfs
exfat  1.0                       6BFF-FC83
sdb  iso966 Jolie GARUDA_DR460NIZED_TALON
2022-10-19-02-24-22-00                     0   100% /run/miso/bootmnt
│    iso966 Jolie GARUDA_DR460NIZED_TALON
│                                     2022-10-19-02-24-22-00
vfat   FAT12 MISO_EFI            E328-6EBB

btrfs                            f866fc2d-1df3-41b7-b10c-687849dfbd35
McFly: Importing shell history for the first time. This may take a minute or two...done.

I think nvme0n1p1 is my boot partition is nvme cause I installed garuda on it.
I dont really know which disk to put with /dev or /mnt, it was the solution for most post but the disks were different in most examples and I dont understand which disk to choose for that. After reading if I understand right when I write sudo mount /dev/nvme0n1p1 /mnt/nvme0n1p1/ Im telling my boot is where /dev is and I want to put it on /mnt ?
After that I try sudo garuda-chroot /mnt/nvme0n1p1/ but it gives me

mount: /mnt/nvme0n1p1//proc: mount point does not exist.
dmesg(1) may have more information after failed mount system call.
==> ERROR: failed to setup API filesystems in chroot /mnt/nvme0n1p1/
umount: bad usage
Try 'umount --help' for more information.

And thats where I've been stuck

This output looks a little odd, like it was cut off somehow? Since you have a UEFI system, you should have an EFI partition and a Btrfs partition on nvme0n1 (so p1 and p2).

It is important to determine which is the EFI partition and which is the Btrfs partition, so take another look at the output of lsblk -f and try find those details. Another way to get this information would be to run sudo parted -l.

You are still trying to use a mount point that doesn’t exist. The mount command is broken up like this:

mount [device] [mount point]

The device should be identified by partition (/dev/nvme0n1p1 or /dev/nvme0n1p2 for example). The mount point should be pointing to an actual directory on your filesystem. It’s okay to make one up for this purpose, but you have to actually create the directory before trying to use it as a mount point. That’s why in the tutorial I linked, there is a mkdir step:

Mount and chroot into the installed system (example partition /dev/nvme0n1p2)

sudo mkdir -p /mnt/broken
sudo mount /dev/nvme0n1p2 /mnt/broken
sudo garuda-chroot /mnt/broken/@

In the mkdir command, we are actually making a new directory at /mnt/broken (it can be called anything you want, it doesn’t have to be called “broken”).

Note: you should be mounting the Btrfs partition for this step. That’s why the example shows nvme0n1p2, because typically p1 will be the EFI partition which is mounted later.

1 Like

Im sorry I forgot to mention, I did the mkdir, it tells me the files exist cause I did it already the last few days from the same link. lsblk gave me this:

NAME FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
squash 4.0                                                                  0   100% /run/miso/sfs/livefs
squash 4.0                                                                  0   100% /run/miso/sfs/mhwdfs
squash 4.0                                                                  0   100% /run/miso/sfs/desktopfs
squash 4.0                                                                  0   100% /run/miso/sfs/rootfs
exfat  1.0                       6BFF-FC83
sdb  iso966 Jolie GARUDA_DR460NIZED_TALON
2022-10-19-02-24-22-00                     0   100% /run/miso/bootmnt
│    iso966 Jolie GARUDA_DR460NIZED_TALON
│                                     2022-10-19-02-24-22-00
vfat   FAT12 MISO_EFI            E328-6EBB

btrfs                            f866fc2d-1df3-41b7-b10c-687849dfbd35   61.9G    86% /mnt/nvme0n1p1

Is it possible that I dont have an EFI partition? When I looked inside gparted it show me the btrfs file but another of approximately 3mo is unallocated. Theres no nvme0n1p2 disk on my system it seems

I’m not sure how to read that quantity.

I believe the default installation will create a 300 MB EFI partition if you don’t already have one. If you have a chunk that size unallocated, perhaps your EFI partition was corrupted during the shutdown? Something is very odd about this whole thing…:thinking:

According to this, you have a UEFI board (not a BIOS one):

That means you should have an EFI partition. It is possible to install in “legacy” mode on a UEFI board (and not have an EFI partition), but if you did that should show up in the inxi output.

If you have a 300 MB unallocated chunk, I would say go ahead and create a new EFI partition in GParted. It should have boot and esp flags. Then you can proceed with the rest of the bootloader installation.

1 Like

Im almost certain I lost it, thats why I mentioned the unalocated 300mb because Ive seen thats how much is the efi partition. Can you tell me how to create an EFI in gparted? Im not sure what to look


The solution from that link is to reinstall windows and ubuntu. I tried to follow the instruction to create an EFI partition, created a 300MiB partition with mount point /boot/efi on gparted but if I try to reinstall garuda I cant use it like they did with their ubuntu usb. I try rebooting anyway and it still stuck. Or did you mean I have to reinstall from scratch anyway?

You don't need a guide to make the EFI partition, and you definitely don't need to install another operating system. Just make a FAT32 partition with Gparted and add the boot and esp flags. Then, use it as the target for the bootloader installation.


I tried with nvme0n1p2 but it didnt work so I use nvme0n1p1

sudo mkdir -p /mnt/uefi

sudo mount /dev/nvme0n1p1 /mnt/uefi

sudo garuda-chroot /mnt/uefi/@

got into chroot and follow the how to chroot guide

sh-5.1# lsblk -no PKNAME /dev/nvme0n1p1
sh-5.1# grub-install /dev/nvme0n1
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

I have to manage that before installing the bootloader?

Do you have any information that you do not wish to lose?
If yes just boot the live usb and transfer any data?
If no ! just download the latest version of garuda as your,s is quite old now re format your drive and reinstall.
It will be quicker!
You have a very broken install :sob:


Ok that what I wanted to know. Nothing really important just some games and videos. Sorry to have wasted your time. Thank you very much for the help and information, this error happened to me a few times before and I managed to fix it with remounting boot but here nothing worked. I'll try to post more meaningful post in the future and look harder on the posts on this forum. Y'all are cool

Just to clarify for future reference:

You must chroot to the root partition, not the EFI partition or any other partition. The other partitions are mounted from inside the chroot.

It is possible we could have managed to save this installation by establishing the chroot, reinstalling the bootloader and kernels, bringing the system back up to date, amending fstab, blah blah blah but @TilliDie is right: it’s probably easier to just reinstall if you can. I have marked his post as the solution.

Anyway, good on you for trying @PKman, and welcome to the community. :slightly_smiling_face:


I feel it might happen again. What is the root partion? How can I find it. I thought I was wasting peoples time

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.