Booting only to BIOS, can't access OS

Hi, I have an Dell XPS 7590 and been using Garuda Linux for more than 8 months now.

Earlier today I finished browsing internet and turned off the PC. Now, when I try to start my PC it's booting only into BIOS. When I exit BIOS it will boot once again there and can't get away from there.

In boot sequence there is only Garuda.
I have nothing connected to the laptop.
I tried it with AC plugged in and also plugged out.

Do you have any other ideas how to boot into Garuda?

Can you boot into the installation media used to install Garuda?

1 Like

Could this be the issue with the newest version of GRUB that is driving everyone else here? If so, there's a tutorial on how to fix it.

2 Likes
4 Likes

I tried this one's tutorial re:btrfs and it still is borked for me too. I'm thinking it's something i did wrong.

Time to reinstall again maybe...

1 Like

bruh, i had the same problem and i just executed the steps linked in the endeavouros forum and this is the link: Grub 2:2.06.r322.gd9b4638c5-1 won't boot and goes straight to the BIOS after update - General system - EndeavourOS

i only had the endeavouros os on my usb pen and this is how i fixed:

  • boot from the usb with the live os
  • open a terminal
  • type sudo btrfs subvolume list -p /mnt

it will give you an output like this

ID 257 gen 484265 parent 5 top level 5 path @home
ID 258 gen 483827 parent 5 top level 5 path @root
ID 259 gen 483827 parent 5 top level 5 path @srv
ID 260 gen 484237 parent 5 top level 5 path @cache
ID 261 gen 484265 parent 5 top level 5 path @log
ID 262 gen 484265 parent 5 top level 5 path @tmp

before you start, make sure what /dev/sdX or /dev/nvm.. you are playing with. mount the things you need and understand what u need. then sudo umount /mnt/ and start restoring your os. i have my garuda gnome since 2020 and never had the need to format the system. everything is fixable :slight_smile:

prepare the /mnt/

sdXn stands for the name of your storage name, in my case it is not starting with /sdX* but with /nvme0n1pX and for my, if is divided in 2 or 3 segment. if i remember correctly, in the p1 there is the grub, in p2 the /.

now, for encrypted storage there is an additional step:

  • sudo cryptsetup open /dev/sda2 mycryptdevice

this is the end:

  • type sudo arch-chroot /mnt if you have no encryption, type sudo arch-chroot /dev/mapper/mycryptdevice if you have encryption.
    type sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id="Garuda"

now the terminal act like you are operating in your garuda ecosystem.
if you want, you can even type fish and it will load w/o problems

now the final step is to type sudo pacman -S grub

buona fortuna! :sun_with_face:

I did this, still borked. I'm currently booted into my windows install to create a new live usb. I'll try it one more time before I reinstall. I just don't have the time to figure it out, i have to get going on my research now that i'm back from my vacation. Reinstall and setting everything up again is a more familiar process to me than troubleshooting whatever's going on, for which no instruction sets have helped yet.

(i've been banging my head against every proposed solution since 10am my time today, and now it's almost 3:30).

weird weird, so many users (including me) solved with this solution :confused:

Tried it again. Still no change. Reinstall it is.

Update:

I tried using the graphical boot repair in garuda to reinstall bootloader and grub config AFTER doing a garuda-update from inside the live usb. that last thing is something i hadn't tried yet. This got me back into my garuda environment without any errors, but i didn't trust it because that had happened a few times before, then on reboot, it was borked again.

From there, i did a garuda-update, and then downgraded grub per a staff suggestion, then rebooted back into my environment and it was fine. Going to try rebooting a few more times to make sure it is okay.

3 Likes

Thank you, tutorial inside this thread worked for me :slight_smile: just entered chroot from live ISO and ran 'grub-intstall'.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.