Boot stuck at target graphical interface

output of garuda-inxi
System:
  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=aeb3c7e0-45af-4344-ba3f-05339ad86d76
    rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Console: tty 2 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B550M DS3H AC v: x.x serial: <superuser required>
    UEFI: American Megatrends LLC. v: F15 date: 07/29/2022
CPU:
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check
    built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3924 high: 4834 min/max: 2200/4850 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 3851 2: 3800 3: 3800 4: 3800 5: 3800
    6: 4834 7: 3800 8: 3800 9: 3800 10: 3866 11: 3800 12: 3800 13: 3865 14: 4444 15: 3872 16: 3853
    bogomips: 121380
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: ASUSTeK driver: N/A alternate: nouveau
    non-free: 525.xx+ status: current (as of 2022-12) arch: Turing code: TUxxx process: TSMC 12nm FF
    built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 06:00.0 chip-ID: 10de:2187 class-ID: 0300
  Display: server: X.org v: 1.21.1.5 with: Xwayland v: 22.1.6 driver: N/A tty: 102x38
  API: OpenGL Message: GL data unavailable in console. Try -G --display
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 06:00.1
    chip-ID: 10de:1aeb class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: no
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:4
    chip-ID: 8087:0aa7 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 395.58 GiB (82.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 002C temp: 42.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.58 GiB (83.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.58 GiB (83.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.58 GiB (83.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.58 GiB (83.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.52 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 334 Uptime: 1m wakeups: 0 Memory: 15.52 GiB used: 1.53 GiB (9.9%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6
  Packages: 2178 pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0 pm: pacman
  pkgs: 2177 libs: 457 tools: gnome-software,octopi,pamac,paru,yay pm: flatpak pkgs: 1 Shell: Zsh
  v: 5.9 running-in: tty 2 inxi: 3.3.24
e[1;34mGaruda (2.6.10-1):e[0m
e[1;34m  System install date:e[0m     2022-01-29
e[1;34m  Last full system update:e[0m 2022-12-14
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m xbindkeys-startup.service 
output of startx
X.Org X Server 1.21.1.5
X Protocol Version 11, Revision 0
Current Operating System: Linux jbh5 6.0.12-zen1-1-zen #1 ZEN SMP PREEMPT_DYNAMIC Thu, 08 Dec 2022 11:03:40 +0000 x86_64
Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=aeb3c7e0-45af-4344-ba3f-05339ad86d76 rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
 
Current version of pixman: 0.42.2
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec 14 23:11:54 2022
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) no screens found(EE) 
(EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
output of mhwd -l
e[1me[31m> e[m0000:06:00.0 (0300:10de:2187) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-nvidia-dkms            2022.11.30               false            PCI
video-nvidia-470xx-dkms            2022.11.30               false            PCI
           video-linux            2021.08.29                true            PCI
     video-modesetting            2020.07.13                true            PCI
            video-vesa            2017.03.12                true            PCI


e[1me[31m> e[m0000:05:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2020.05.22                true            PCI

output of sudo pacman -Qs nvidia
local/egl-wayland 2:1.1.11-2
    EGLStream-based Wayland external platform
local/garuda-nvidia-config 1:r63.2f652e8-2
    Meta configuration package for nvidia systems on Garuda Linux
local/gwe 0.15.5-3.1
    A system utility for controlling NVIDIA GPUs
local/lib32-libvdpau 1.5-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 525.60.11-1
    NVIDIA drivers utilities (32-bit)
local/lib32-opencl-nvidia 525.60.11-1
    OpenCL implemention for NVIDIA (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 525.60.11-2
    NVIDIA NV-CONTROL X extension
local/mhwd-nvidia 525.60.11-1
    mhwd-nvidia pci id
local/mhwd-nvidia-390xx 390.143-1
    mhwd-nvidia-390xx PCI ID database
local/mhwd-nvidia-470xx 470.94-1
    mhwd-nvidia-470xx PCI ID database
local/nvidia-dkms 525.60.11-1
    NVIDIA drivers - module sources
local/nvidia-settings 525.60.11-2
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 525.60.11-1
    NVIDIA drivers utilities
local/opencl-nvidia 525.60.11-1
    OpenCL implemention for NVIDIA
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards
output of sudo dkms autoinstall
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/nvidia/495.46/source/dkms.conf does not exist.

Seeing this post should I boot the plain linux kernel?

sudo pacman -S nvidia-dkms && sudo modprobe nvidia && garuda-inxi

2 Likes

Nuh-uh.

resolving dependencies...
looking for conflicting packages...

Packages (1) nvidia-dkms-525.60.11-1

Total Installed Size:  68.44 MiB
Net Upgrade Size:       0.00 MiB

checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/2) Performing snapper pre snapshots for the following configurations...
IO Error (.snapshots is not a btrfs subvolume).
==> root: 
(2/2) Remove upgraded DKMS modules
==> dkms remove nvidia/525.60.11
:: Processing package changes...
reinstalling nvidia-dkms...
:: Running post-transaction hooks...
(1/9) Arming ConditionNeedsUpdate...
(2/9) Install DKMS modules
==> dkms install --no-depmod nvidia/525.60.11 -k 6.0.12-zen1-1-zen
Error! Bad return status for module build on kernel: 6.0.12-zen1-1-zen (x86_64)
Consult /var/lib/dkms/nvidia/525.60.11/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/525.60.11 -k 6.0.12-zen1-1-zen' exited 10
==> dkms install --no-depmod nvidia/525.60.11 -k 5.15.82-1-lts
Error! Bad return status for module build on kernel: 5.15.82-1-lts (x86_64)
Consult /var/lib/dkms/nvidia/525.60.11/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/525.60.11 -k 5.15.82-1-lts' exited 10
(3/9) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.15.82-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.15.82-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 6.0.12-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 6.0.12-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
==> Starting build: 6.0.12-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
==> Starting build: 6.0.12-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
==> Image generation successful
(4/9) Refreshing PackageKit...
(5/9) Foreign/AUR package notification
auto-complete-clang-async 0.5-1
bloaty 1.1-1
bluewho 0.5.2-1
ceph-libs 15.2.17-1
cling 0.9-3
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
emacs-auto-complete 1.5.1-2
emacs-fuzzy 0.1-2
emacs-popup-el 0.5.3-3
findent 3.1.7-1
fortran-language-server 1.12.0-1
freefilesync-bin 11.23-1
ictree 1.0.1-1
jellyfin-bin 10.8.6-1
jellyfin-server-bin 10.8.6-1
jellyfin-web-bin 10.8.6-1
libguess 1.2-4
libkipi 22.04.0-1
libquicktime 1.2.4-27
metis 5.1.0.p10-2
pi-hole-ftl 5.16.2-1
pi-hole-server 5.11.4-3
python-bluezero 0.7.1-0
python-pylspci 0.4.2-1
rbenv 1.2.0-1
rootactions-servicemenu 2.7.3-1
samba-mounter-git 186.29ebad4-1
seer-gdb 1.11-1
tabby-terminal 1.0.179-1
windscribe-bin 2.4.11-1
(6/9) Orphaned package notification...
ant 1.10.12-2
bluetooth-autoconnect 1.3-1.2
ceph-libs 15.2.17-1
coffeescript 2.7.0-1
cronie 1.6.1-1
crypto++ 8.7.0-1
cunit 2.1.3-3
debugedit 5.0-4
doxygen 1.9.5-1
electron 20.3.8-1
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
electron17 17.4.11-4
ethtool 1:6.0-1
extra-cmake-modules 5.101.0-1
fcgi 2.4.2-2
gcc11 11.3.0-5
gendesk 1.0.9-3
geocode-glib 3.26.4-2
go 2:1.19.4-1
gperf 3.1-3
gtest 1.12.1-1
img2pdf 0.4.4-1
java11-openjfx 11.0.17.u1-1
js78 78.15.0-4
kfiredragonhelper 5.0.6-1.1
leveldb 1.23-3
lib32-at-spi2-core 2.46.0-2
lib32-gdk-pixbuf2 2.42.10-1
lib32-libpng12 1.2.59-2
lib32-pango 1:1.50.12-1
lib32-pcre 8.45-3
lib32-readline 8.2.001-2
libcmis 0.5.2-12
libcroco 0.6.13-2
libgee 0.20.6-1
libguess 1.2-4
libkipi 22.04.0-1
libofa 0.9.3-9
libquicktime 1.2.4-27
librabbitmq-c 0.11.0-2
librdkafka 1.9.2-2
libxml++2.6 2.42.1-1
memavaild 0.6-2.1
metis 5.1.0.p10-2
neard 0.18-1.1
nm-connection-editor 1.30.0-1
nohang 0.2.0-1.1
ntp 4.2.8.p15-2
pngquant 2.17.0-2
prelockd 0.9-2.1
python-bcrypt 4.0.1-1
python-beaker 1.11.0-8
python-blessings 1.7-9
python-build 0.9.0-1
python-cachecontrol 1:0.12.11-1
python-cherrypy 18.8.0-2
python-coloredlogs 15.0.1-3.1
python-contextlib2 21.6.0-1
python-defusedxml 0.7.1-4
python-elasticsearch 7.9.0-1
python-flask-restful 0.3.9-4
python-google-api-python-client 2.66.0-1
python-importlib_resources 5.10.1-1
python-installer 0.6.0-1
python-isodate 0.6.1-2
python-mock 3.0.5-9
python-nose 1.3.7-14
python-nspektr 0.4.0-2
python-pdfminer 20220524-1
python-pecan 1.4.2-2
python-pkgconfig 1.5.5-3
python-prettytable 3.5.0-1
python-progress 1.6-5
python-prometheus_client 0.15.0-2
python-py 1.11.0-1
python-pybluez 0.23-4
python-pycodestyle 2.10.0-1
python-pyjwt 2.6.0-1
python-pylint 2.15.8-1
python-pytest-cov 4.0.0-1
python-resolvelib 0.9.0-1
python-retrying 1.3.3-14
python-rich 12.6.0-2
python-scikit-learn 1.2.0-1
python-setuptools-scm-git-archive 1.4-1
python-sphinx 5.3.0-1
python-tenacity 8.1.0-1
python-tqdm 4.64.1-1
python-xmlsec 1.3.13-1
rabbitmq 3.10.7-1
rest 0.8.1+r4+ge5ee6ef-1
unicode-cldr-annotations 41.0-1
unpaper 7.0.0-1
uresourced 0.5.3-1.1
xapp 2.4.2-1
xf86-video-intel 1:2.99.917+916+g31486f40-2
xmlstarlet 1.6.1-3
yarn 1.22.19-1
zita-alsa-pcmi 0.5.1-1
(7/9) Checking for .pacnew and .pacsave files...
e[1m.pac* files found:e[0m
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/pamac.conf.pacnew
/etc/libvirt/libvirtd.conf.pacnew
/etc/libvirt/qemu.conf.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/ssh/sshd_config.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
e[1mPlease check and mergee[0m
(8/9) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.
==> root: 
(9/9) Syncing all file systems...

sudo modprobe nvidia:

modprobe: FATAL: Module nvidia not found in directory /lib/modules/6.0.12-zen1-1-zen

System:
  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=aeb3c7e0-45af-4344-ba3f-05339ad86d76
    rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Console: tty 2 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B550M DS3H AC v: x.x serial: <superuser required>
    UEFI: American Megatrends LLC. v: F15 date: 07/29/2022
CPU:
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 gen: 4 level: v3 note: check
    built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 0
    microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3800 min/max: 2200/4850 boost: enabled scaling: driver: acpi-cpufreq
    governor: performance cores: 1: 3800 2: 3800 3: 3800 4: 3800 5: 3800 6: 3800 7: 3800 8: 3800
    9: 3800 10: 3800 11: 3800 12: 3800 13: 3800 14: 3800 15: 3800 16: 3800 bogomips: 121375
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: ASUSTeK driver: N/A alternate: nouveau
    non-free: 525.xx+ status: current (as of 2022-12) arch: Turing code: TUxxx process: TSMC 12nm FF
    built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 06:00.0 chip-ID: 10de:2187 class-ID: 0300
  Display: server: X.org v: 1.21.1.5 with: Xwayland v: 22.1.6 driver: N/A tty: 102x38
  API: OpenGL Message: GL data unavailable in console. Try -G --display
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 06:00.1
    chip-ID: 10de:1aeb class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: no
Network:
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:4
    chip-ID: 8087:0aa7 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 395.98 GiB (83.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 002C temp: 37.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.98 GiB (83.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.98 GiB (83.1%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.98 GiB (83.1%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 395.98 GiB (83.1%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.52 GiB used: 512 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 41.6 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 325 Uptime: 5m wakeups: 0 Memory: 15.52 GiB used: 2.47 GiB (15.9%) Init: systemd
  v: 252 default: graphical tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6
  Packages: 2178 pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 0 pm: pacman
  pkgs: 2177 libs: 457 tools: gnome-software,octopi,pamac,paru,yay pm: flatpak pkgs: 1 Shell: Zsh
  v: 5.9 running-in: tty 2 inxi: 3.3.24
e[1;34mGaruda (2.6.10-1):e[0m
e[1;34m  System install date:e[0m     2022-01-29
e[1;34m  Last full system update:e[0m 2022-12-14
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m No/Undetected
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m xbindkeys-startup.service 

Upload /var/lib/dkms/nvidia/525.60.11/build/make.log please.

DKMS make.log for nvidia-525.60.11 for kernel 5.15.82-1-lts (x86_64)
Wed Dec 14 11:31:35 PM IST 2022
make[1]: Entering directory '/usr/lib/modules/5.15.82-1-lts/build'
cc: error while loading shared libraries: libhiredis.so.1.0.0: cannot open shared object file: No such file or directory
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 12.2.0
  You are using:           

The C compiler 'cc' does not appear to be able to
create executables.  Please make sure you have 
your Linux distribution's gcc and libc development
packages installed.

*** Failed CC sanity check. Bailing out! ***


Warning: Compiler version check failed:

The major and minor number of the compiler used to
compile the kernel:

gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0

does not match the compiler used here:

cc: error while loading shared libraries: libhiredis.so.1.0.0: cannot open shared object file: No such file or directory

It is recommended to set the CC environment variable
to the compiler that was used to compile the kernel.

To skip the test and silence this warning message, set
the IGNORE_CC_MISMATCH environment variable to "1".
However, mixing compiler versions between the kernel
and kernel modules can result in subtle bugs that are
difficult to diagnose.

*** Failed CC version check. ***

make[2]: *** [/var/lib/dkms/nvidia/525.60.11/build/Kbuild:335: cc_sanity_check] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Makefile:1900: /var/lib/dkms/nvidia/525.60.11/build] Error 2
make[1]: Leaving directory '/usr/lib/modules/5.15.82-1-lts/build'
make: *** [Makefile:82: modules] Error 2

I remember now. A few days back clang, ccache, a few others gave the same error. I just locally installed the latest clang from their website and didn't give it a second thought.

I have the 1.1.0-1 version of hiredis installed.

Partial upgrade? Do you ignore any packages?

garuda-update output?

I have been running garuda-update for a while now.
However I used to use pamac. Did that screw something up?

How do I check for ignored packages?

/etc/pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc garuda-system
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
Color
#NoProgressBar
CheckSpace
#VerbosePkgLists
ILoveCandy
ParallelDownloads = 5

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

[garuda]
Include = /etc/pacman.d/chaotic-mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

[chaotic-aur]
Include = /etc/pacman.d/chaotic-mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Please do it and share the output.

:: Synchronizing package databases...
 garuda downloading...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
 chaotic-aur downloading...

e[1;33m-->e[1;34m Refreshing mirrorlists using rate-mirrors, please be patient..e[0m
:: Synchronizing package databases...
 garuda downloading...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
 chaotic-aur downloading...
spawn pacman -Su
e[?25le[1;34m::e[0;1m Starting full system upgrade...
e[0m there is nothing to do
e[?25h
Checking for plugin updates
Failed to query plugin channel:
 Get "https://raw.githubusercontent.com/micro-editor/plugin-channel/master/channel.json": dial tcp [2405:200:1607:2820:41::36]:443: i/o timeout
unable to find a matching version for "aspell"

e[1;32mSystem updated! 🐧
e[0m

Since that log file is unfortunately diagnostically useless, I'll need some more info:

sudo pacman -R linux-lts linux-lts-headers && pacman -S nvidia-dkms and then upload /var/lib/dkms/nvidia/525.60.11/build/make.log

Share as many command outputs as you can of course.

1 Like
checking dependencies...
:: dkms optionally requires linux-lts-headers: build modules against the LTS kernel

Packages (2) linux-lts-5.15.82-1  linux-lts-headers-5.15.82-1

Total Removed Size:  270.69 MiB

:: Running pre-transaction hooks...
(1/3) Performing snapper pre snapshots for the following configurations...
IO Error (.snapshots is not a btrfs subvolume).
==> root: 
(2/3) Removing linux initcpios...
(3/3) Remove DKMS modules
:: Processing package changes...
removing linux-lts-headers...
removing linux-lts...
:: Running post-transaction hooks...
(1/9) Arming ConditionNeedsUpdate...
(2/9) Updating module dependencies...
(3/9) Refreshing PackageKit...
(4/9) Foreign/AUR package notification
auto-complete-clang-async 0.5-1
bloaty 1.1-1
bluewho 0.5.2-1
ceph-libs 15.2.17-1
cling 0.9-3
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
emacs-auto-complete 1.5.1-2
emacs-fuzzy 0.1-2
emacs-popup-el 0.5.3-3
findent 3.1.7-1
fortran-language-server 1.12.0-1
freefilesync-bin 11.23-1
ictree 1.0.1-1
jellyfin-bin 10.8.6-1
jellyfin-server-bin 10.8.6-1
jellyfin-web-bin 10.8.6-1
libguess 1.2-4
libkipi 22.04.0-1
libquicktime 1.2.4-27
metis 5.1.0.p10-2
pi-hole-ftl 5.16.2-1
pi-hole-server 5.11.4-3
python-bluezero 0.7.1-0
python-pylspci 0.4.2-1
rbenv 1.2.0-1
rootactions-servicemenu 2.7.3-1
samba-mounter-git 186.29ebad4-1
seer-gdb 1.11-1
tabby-terminal 1.0.179-1
windscribe-bin 2.4.11-1
(5/9) Orphaned package notification...
ant 1.10.12-2
bluetooth-autoconnect 1.3-1.2
ceph-libs 15.2.17-1
coffeescript 2.7.0-1
cronie 1.6.1-1
crypto++ 8.7.0-1
cunit 2.1.3-3
debugedit 5.0-4
doxygen 1.9.5-1
electron 20.3.8-1
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
electron17 17.4.11-4
ethtool 1:6.0-1
extra-cmake-modules 5.101.0-1
fcgi 2.4.2-2
gcc11 11.3.0-5
gendesk 1.0.9-3
geocode-glib 3.26.4-2
go 2:1.19.4-1
gperf 3.1-3
gtest 1.12.1-1
img2pdf 0.4.4-1
java11-openjfx 11.0.17.u1-1
js78 78.15.0-4
kfiredragonhelper 5.0.6-1.1
leveldb 1.23-3
lib32-at-spi2-core 2.46.0-2
lib32-gdk-pixbuf2 2.42.10-1
lib32-libpng12 1.2.59-2
lib32-pango 1:1.50.12-1
lib32-pcre 8.45-3
lib32-readline 8.2.001-2
libcmis 0.5.2-12
libcroco 0.6.13-2
libgee 0.20.6-1
libguess 1.2-4
libkipi 22.04.0-1
libofa 0.9.3-9
libquicktime 1.2.4-27
librabbitmq-c 0.11.0-2
librdkafka 1.9.2-2
libxml++2.6 2.42.1-1
memavaild 0.6-2.1
metis 5.1.0.p10-2
neard 0.18-1.1
nm-connection-editor 1.30.0-1
nohang 0.2.0-1.1
ntp 4.2.8.p15-2
pngquant 2.17.0-2
prelockd 0.9-2.1
python-bcrypt 4.0.1-1
python-beaker 1.11.0-8
python-blessings 1.7-9
python-build 0.9.0-1
python-cachecontrol 1:0.12.11-1
python-cherrypy 18.8.0-2
python-coloredlogs 15.0.1-3.1
python-contextlib2 21.6.0-1
python-defusedxml 0.7.1-4
python-elasticsearch 7.9.0-1
python-flask-restful 0.3.9-4
python-google-api-python-client 2.66.0-1
python-importlib_resources 5.10.1-1
python-installer 0.6.0-1
python-isodate 0.6.1-2
python-mock 3.0.5-9
python-nose 1.3.7-14
python-nspektr 0.4.0-2
python-pdfminer 20220524-1
python-pecan 1.4.2-2
python-pkgconfig 1.5.5-3
python-prettytable 3.5.0-1
python-progress 1.6-5
python-prometheus_client 0.15.0-2
python-py 1.11.0-1
python-pybluez 0.23-4
python-pycodestyle 2.10.0-1
python-pyjwt 2.6.0-1
python-pylint 2.15.8-1
python-pytest-cov 4.0.0-1
python-resolvelib 0.9.0-1
python-retrying 1.3.3-14
python-rich 12.6.0-2
python-scikit-learn 1.2.0-1
python-setuptools-scm-git-archive 1.4-1
python-sphinx 5.3.0-1
python-tenacity 8.1.0-1
python-tqdm 4.64.1-1
python-xmlsec 1.3.13-1
rabbitmq 3.10.7-1
rest 0.8.1+r4+ge5ee6ef-1
unicode-cldr-annotations 41.0-1
unpaper 7.0.0-1
uresourced 0.5.3-1.1
xapp 2.4.2-1
xf86-video-intel 1:2.99.917+916+g31486f40-2
xmlstarlet 1.6.1-3
yarn 1.22.19-1
zita-alsa-pcmi 0.5.1-1
(6/9) Checking for .pacnew and .pacsave files...
e[1m.pac* files found:e[0m
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/pamac.conf.pacnew
/etc/libvirt/libvirtd.conf.pacnew
/etc/libvirt/qemu.conf.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/ssh/sshd_config.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
e[1mPlease check and mergee[0m
(7/9) GRUB update after transactions...
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Garuda Linux on /dev/nvme0n1p2
Found Debian GNU/Linux 11 (bullseye) on /dev/nvme0n1p2
Detecting snapshots ...
Found snapshot: 2022-12-14 19:39:22 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/31/snapshot                                                                           | post     | krita svt-av1                                                            |
Found snapshot: 2022-12-14 19:39:20 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/30/snapshot                                                                           | pre      | pacman -Syu                                                              |
Found snapshot: 2022-12-14 17:40:03 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/29/snapshot                                                                           | post     | xf86-video-fbdev                                                         |
Found snapshot: 2022-12-14 17:40:01 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/28/snapshot                                                                           | pre      | pacman -Syu xf86-video-fbdev                                             |
Found snapshot: 2022-12-14 17:32:40 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/27/snapshot                                                                           | post     | vim vim-runtime xf86-video-vesa xorg-bdftopcf xorg-docs xorg-font-util x |
Found snapshot: 2022-12-14 17:32:35 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/26/snapshot                                                                           | pre      | pacman -Syu xorg                                                         |
Found snapshot: 2022-12-14 17:13:40 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/25/snapshot                                                                           | post     | xf86-video-fbdev                                                         |
Found snapshot: 2022-12-14 17:13:38 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/24/snapshot                                                                           | pre      | pacman -R xf86-video-fbdev                                               |
Found snapshot: 2022-12-14 16:53:50 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/23/snapshot                                                                           | post     | corefreq-client corefreq-dkms corefreq-server                            |
Found snapshot: 2022-12-14 16:53:18 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/22/snapshot                                                                           | pre      | pacman -R --config /etc/pacman.conf -- corefreq-client corefreq-server c |
Found snapshot: 2022-12-14 16:35:51 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/15/snapshot                                                                           | single   | Before installing nvidia                                                 |
Found snapshot: 2022-12-14 15:00:00 | timeshift-btrfs/snapshots/2022-12-13_20-10-23/@/.snapshots/4/snapshot                                                                            | single   | N/A                                                                      |
Found snapshot: 2022-12-13 20:10:24 | @_backup_20221412214741565                                                                                                                       | N/A      | N/A                                                                      |
Found snapshot: 2022-12-10 00:32:35 | timeshift-btrfs/snapshots/2022-12-10_00-32-35/@                                                                                                  | ondemand | N/A                                                                      |
Found snapshot: 2022-12-09 23:48:25 | timeshift-btrfs/snapshots/2022-12-09_23-48-25/@                                                                                                  | ondemand | N/A                                                                      |
Found snapshot: 2022-12-09 23:24:17 | timeshift-btrfs/snapshots/2022-12-09_23-24-17/@                                                                                                  | ondemand | N/A                                                                      |
Found snapshot: 2022-01-30 23:48:06 | timeshift-btrfs/snapshots/2022-01-30_23-48-06/@                                                                                                  | ondemand | N/A                                                                      |
Found 17 snapshot(s)
Unmount /tmp/grub-btrfs.34OPbAmjCq .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
(8/9) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.
==> root: 
(9/9) Syncing all file systems...
resolving dependencies...
looking for conflicting packages...

Packages (1) nvidia-dkms-525.60.11-1

Total Installed Size:  68.44 MiB
Net Upgrade Size:       0.00 MiB

checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Running pre-transaction hooks...
(1/2) Performing snapper pre snapshots for the following configurations...
IO Error (.snapshots is not a btrfs subvolume).
==> root: 
(2/2) Remove upgraded DKMS modules
==> dkms remove nvidia/525.60.11
:: Processing package changes...
reinstalling nvidia-dkms...
:: Running post-transaction hooks...
(1/9) Arming ConditionNeedsUpdate...
(2/9) Install DKMS modules
==> dkms install --no-depmod nvidia/525.60.11 -k 6.0.12-zen1-1-zen
Error! Bad return status for module build on kernel: 6.0.12-zen1-1-zen (x86_64)
Consult /var/lib/dkms/nvidia/525.60.11/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/525.60.11 -k 6.0.12-zen1-1-zen' exited 10
(3/9) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 6.0.12-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 6.0.12-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'default'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen.img
==> Starting build: 6.0.12-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-zen.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-zen -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-zen-fallback.img -S autodetect
==> Starting build: 6.0.12-zen1-1-zen
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
  -> Running build hook: [grub-btrfs-overlayfs]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-zen-fallback.img
==> Image generation successful
(4/9) Refreshing PackageKit...
(5/9) Foreign/AUR package notification
auto-complete-clang-async 0.5-1
bloaty 1.1-1
bluewho 0.5.2-1
ceph-libs 15.2.17-1
cling 0.9-3
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
emacs-auto-complete 1.5.1-2
emacs-fuzzy 0.1-2
emacs-popup-el 0.5.3-3
findent 3.1.7-1
fortran-language-server 1.12.0-1
freefilesync-bin 11.23-1
ictree 1.0.1-1
jellyfin-bin 10.8.6-1
jellyfin-server-bin 10.8.6-1
jellyfin-web-bin 10.8.6-1
libguess 1.2-4
libkipi 22.04.0-1
libquicktime 1.2.4-27
metis 5.1.0.p10-2
pi-hole-ftl 5.16.2-1
pi-hole-server 5.11.4-3
python-bluezero 0.7.1-0
python-pylspci 0.4.2-1
rbenv 1.2.0-1
rootactions-servicemenu 2.7.3-1
samba-mounter-git 186.29ebad4-1
seer-gdb 1.11-1
tabby-terminal 1.0.179-1
windscribe-bin 2.4.11-1
(6/9) Orphaned package notification...
ant 1.10.12-2
bluetooth-autoconnect 1.3-1.2
ceph-libs 15.2.17-1
coffeescript 2.7.0-1
cronie 1.6.1-1
crypto++ 8.7.0-1
cunit 2.1.3-3
debugedit 5.0-4
doxygen 1.9.5-1
electron 20.3.8-1
electron13 13.6.9-3
electron14 14.2.9-2
electron16 16.2.8-2
electron17 17.4.11-4
ethtool 1:6.0-1
extra-cmake-modules 5.101.0-1
fcgi 2.4.2-2
gcc11 11.3.0-5
gendesk 1.0.9-3
geocode-glib 3.26.4-2
go 2:1.19.4-1
gperf 3.1-3
gtest 1.12.1-1
img2pdf 0.4.4-1
java11-openjfx 11.0.17.u1-1
js78 78.15.0-4
kfiredragonhelper 5.0.6-1.1
leveldb 1.23-3
lib32-at-spi2-core 2.46.0-2
lib32-gdk-pixbuf2 2.42.10-1
lib32-libpng12 1.2.59-2
lib32-pango 1:1.50.12-1
lib32-pcre 8.45-3
lib32-readline 8.2.001-2
libcmis 0.5.2-12
libcroco 0.6.13-2
libgee 0.20.6-1
libguess 1.2-4
libkipi 22.04.0-1
libofa 0.9.3-9
libquicktime 1.2.4-27
librabbitmq-c 0.11.0-2
librdkafka 1.9.2-2
libxml++2.6 2.42.1-1
memavaild 0.6-2.1
metis 5.1.0.p10-2
neard 0.18-1.1
nm-connection-editor 1.30.0-1
nohang 0.2.0-1.1
ntp 4.2.8.p15-2
pngquant 2.17.0-2
prelockd 0.9-2.1
python-bcrypt 4.0.1-1
python-beaker 1.11.0-8
python-blessings 1.7-9
python-build 0.9.0-1
python-cachecontrol 1:0.12.11-1
python-cherrypy 18.8.0-2
python-coloredlogs 15.0.1-3.1
python-contextlib2 21.6.0-1
python-defusedxml 0.7.1-4
python-elasticsearch 7.9.0-1
python-flask-restful 0.3.9-4
python-google-api-python-client 2.66.0-1
python-importlib_resources 5.10.1-1
python-installer 0.6.0-1
python-isodate 0.6.1-2
python-mock 3.0.5-9
python-nose 1.3.7-14
python-nspektr 0.4.0-2
python-pdfminer 20220524-1
python-pecan 1.4.2-2
python-pkgconfig 1.5.5-3
python-prettytable 3.5.0-1
python-progress 1.6-5
python-prometheus_client 0.15.0-2
python-py 1.11.0-1
python-pybluez 0.23-4
python-pycodestyle 2.10.0-1
python-pyjwt 2.6.0-1
python-pylint 2.15.8-1
python-pytest-cov 4.0.0-1
python-resolvelib 0.9.0-1
python-retrying 1.3.3-14
python-rich 12.6.0-2
python-scikit-learn 1.2.0-1
python-setuptools-scm-git-archive 1.4-1
python-sphinx 5.3.0-1
python-tenacity 8.1.0-1
python-tqdm 4.64.1-1
python-xmlsec 1.3.13-1
rabbitmq 3.10.7-1
rest 0.8.1+r4+ge5ee6ef-1
unicode-cldr-annotations 41.0-1
unpaper 7.0.0-1
uresourced 0.5.3-1.1
xapp 2.4.2-1
xf86-video-intel 1:2.99.917+916+g31486f40-2
xmlstarlet 1.6.1-3
yarn 1.22.19-1
zita-alsa-pcmi 0.5.1-1
(7/9) Checking for .pacnew and .pacsave files...
e[1m.pac* files found:e[0m
/etc/locale.gen.pacnew
/etc/default/grub.pacnew
/etc/pamac.conf.pacnew
/etc/libvirt/libvirtd.conf.pacnew
/etc/libvirt/qemu.conf.pacnew
/etc/mkinitcpio.conf.pacnew
/etc/ssh/sshd_config.pacnew
/etc/pacman.d/mirrorlist.pacnew
/etc/paru.conf.pacnew
e[1mPlease check and mergee[0m
(8/9) Performing snapper post snapshots for the following configurations...
Invalid snapshot '--type'.
==> root: 
(9/9) Syncing all file systems...
DKMS make.log for nvidia-525.60.11 for kernel 6.0.12-zen1-1-zen (x86_64)
Thu Dec 15 12:02:47 AM IST 2022
make[1]: Entering directory '/usr/lib/modules/6.0.12-zen1-1-zen/build'
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 12.2.0
  You are using:           

The C compiler 'cc' does not appear to be able to
create executables.  Please make sure you have 
your Linux distribution's gcc and libc development
packages installed.

*** Failed CC sanity check. Bailing out! ***


Warning: Compiler version check failed:

The major and minor number of the compiler used to
compile the kernel:

gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0

does not match the compiler used here:

cc: error while loading shared libraries: libhiredis.so.1.0.0: cannot open shared object file: No such file or directory

It is recommended to set the CC environment variable
to the compiler that was used to compile the kernel.

To skip the test and silence this warning message, set
the IGNORE_CC_MISMATCH environment variable to "1".
However, mixing compiler versions between the kernel
and kernel modules can result in subtle bugs that are
difficult to diagnose.

*** Failed CC version check. ***

make[2]: *** [/var/lib/dkms/nvidia/525.60.11/build/Kbuild:335: cc_sanity_check] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Makefile:1849: /var/lib/dkms/nvidia/525.60.11/build] Error 2
make[1]: Leaving directory '/usr/lib/modules/6.0.12-zen1-1-zen/build'
make: *** [Makefile:82: modules] Error 2

Okay, this is rather special, huh?

ldd /usr/bin/cc; pacman -Qo /usr/bin/cc; cc --version

GCC does not use this library as far as I can tell, so let's figure out what's going on with it.

1 Like

Is it sensible and/or possible to install that version of hiredis?

Uh, I guess, but that's not exactly a solution, now is it? That's not how packages and dependencies work, after all, and I am specifically looking for the root cause of this issue instead of giving you a half-assed solution that will just lead to more breakage later on.

1 Like
	linux-vdso.so.1 (0x00007ffdedbd0000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f6d2af0d000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f6d2b136000)

As an aside, why did this happen?? I've ran Garuda since Jan and it flawlessly.

A week back I ran garuda-update and I encountered problem after problem: first it got stuck in boot at loading initial ramdisk, then it gave a separate out of range pointer issue. I used chroot for the first time and updated grub. That fixed the pointer error, but then it didn't load a gui.
(some of them were my fault of course, I'm a noob in this area of linux. I should have taken snapshots, and should have switched to snapper which takes one before and after updates anyways)

I can't say that for sure without first diagnosing the issue you are having, which is very frustrating through forum text because I could rattle down these commands in a terminal in a couple seconds instead of having to wait a couple of minutes between every command :stuck_out_tongue:

(You are still missing two commands)

1 Like

Why do both GCC and Clang compilers need a database package for that matter

I'm so so thankful for Garuda's community.
I had never used web forums for tech problems before, unix.stackexchange would suffice.