Boot stuck at target graphical interface

Yeah yeah great and all but can I have the outputs of those commands now :sweat_smile:

1 Like
/usr/bin/cc is owned by gcc 12.2.0-1

No version, just the same error

Running plain /usr/bin/gcc works though.

gcc (GCC) 12.2.0
Copyright (C) 2022 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Ok i think I got it.
As I suspected, ccache uses redis
and the ccache symlinks are in $PATH
If I run /usr/bin/cc it works.
See the manual ccache(1) for symlinks and
ccache(1) for hiredis

Alright, I figured it was ccache, I have a suspicion as to what the root cause is at this point.

pacman -Q ccache


I realise I also had ccache 4.7.4 manually installed (not through pacman)

But the same version is also in /usr/bin/

Oh my god... Just.. Why..

Anyway, let's get rid of that garbage.

echo $PATH


I piped it into a python one-liner to put it on newlines

Oh my god, that's horrible. You have /home things in your system PATH? Get rid of anything /home in your system PATH, no wonder you ended up in this situation, it was inevitable.

1 Like

ccache I don't remeber actually :man_facepalming: :man_facepalming: :man_facepalming:

clang, gcc I installed locally because I needed their latest versions.

I put these $PATH changes in my ~/.zshenv I didn't realise it would be used by literally everything
Should I put in my ~/.zshrc instead

I forgot how $PATH works, I though it would only be for commands I type for some reason.
Excuse my brain damage

That's fine for your user path, but oh god don't do that for your system PATH.

This should be your system PATH: /usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

Nothing more, nothing less.

After you did that, run sudo pacman -S linux-zen linux-zen-headers (to rebuild all DKMS modules) and then reboot. You should have your precious GUI back.

Once you are there, verify snapper-support is installed and then run garuda-update remote reset-snapper and then share the output of sudo btrfs subvolume list /.

1 Like

Ok I'll be honest, there's stuff in my $PATH I don't even remeber where I added.
They're not in .zshenv or .zshrc
Do you know any other places?

Also would you please enlighten me the difference between system and user $PATH
Where should I add it for the user?

It's the year of the linux desktop, the least I can ask is a GUI

1 Like

Damn! Still gets stuck at target graphical interface

I manualy ran startx


[    31.278] 
X.Org X Server
X Protocol Version 11, Revision 0
[    31.279] Current Operating System: Linux jbh5 6.0.12-zen1-1-zen #1 ZEN SMP PREEMPT_DYNAMIC Thu, 08 Dec 2022 11:03:40 +0000 x86_64
[    31.279] Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=aeb3c7e0-45af-4344-ba3f-05339ad86d76 rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
[    31.279]  
[    31.279] Current version of pixman: 0.42.2
[    31.279] 	Before reporting problems, check
	to make sure that you have the latest version.
[    31.279] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    31.279] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 15 00:49:20 2022
[    31.280] (==) Using config file: "/etc/X11/xorg.conf"
[    31.280] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    31.280] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    31.281] (==) ServerLayout "Layout0"
[    31.281] (**) |-->Screen "Screen0" (0)
[    31.281] (**) |   |-->Monitor "Monitor0"
[    31.281] (**) |   |-->Device "Device0"
[    31.281] (**) |-->Input Device "Keyboard0"
[    31.281] (**) |-->Input Device "Mouse0"
[    31.281] (==) Automatically adding devices
[    31.281] (==) Automatically enabling devices
[    31.281] (==) Automatically adding GPU devices
[    31.281] (==) Automatically binding GPU devices
[    31.281] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    31.281] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    31.281] 	Entry deleted from font path.
[    31.281] (==) FontPath set to:
[    31.281] (==) ModulePath set to "/usr/lib/xorg/modules"
[    31.281] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    31.281] (WW) Disabling Keyboard0
[    31.281] (WW) Disabling Mouse0
[    31.281] (II) Module ABI versions:
[    31.281] 	X.Org ANSI C Emulation: 0.4
[    31.281] 	X.Org Video Driver: 25.2
[    31.281] 	X.Org XInput driver : 24.4
[    31.281] 	X.Org Server Extension : 10.0
[    31.282] (++) using VT number 2

[    31.282] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    31.284] (--) PCI:*([email protected]:0:0) 10de:2187:1043:8769 rev 161, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    31.284] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    31.284] (II) LoadModule: "glx"
[    31.284] (II) Loading /usr/lib/xorg/modules/extensions/
[    31.285] (II) Module glx: vendor="X.Org Foundation"
[    31.285] 	compiled for, module version = 1.0.0
[    31.285] 	ABI class: X.Org Server Extension, version 10.0
[    31.285] (II) LoadModule: "nvidia"
[    31.285] (II) Loading /usr/lib/xorg/modules/drivers/
[    31.288] (II) Module nvidia: vendor="NVIDIA Corporation"
[    31.288] 	compiled for, module version = 1.0.0
[    31.288] 	Module class: X.Org Video Driver
[    31.288] (II) NVIDIA dlloader X Driver  525.60.11  Wed Nov 23 22:56:57 UTC 2022
[    31.288] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    31.288] (II) Loading sub module "fb"
[    31.288] (II) LoadModule: "fb"
[    31.288] (II) Module "fb" already built-in
[    31.288] (II) Loading sub module "wfb"
[    31.288] (II) LoadModule: "wfb"
[    31.288] (II) Loading /usr/lib/xorg/modules/
[    31.288] (II) Module wfb: vendor="X.Org Foundation"
[    31.288] 	compiled for, module version = 1.0.0
[    31.288] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    31.288] (II) Loading sub module "ramdac"
[    31.288] (II) LoadModule: "ramdac"
[    31.288] (II) Module "ramdac" already built-in
[    31.290] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    31.290] (EE) NVIDIA:     system's kernel log for additional error messages and
[    31.290] (EE) NVIDIA:     consult the NVIDIA README for details.
[    31.290] (EE) No devices detected.
[    31.290] (EE) 
Fatal server error:
[    31.290] (EE) no screens found(EE) 
[    31.290] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[    31.290] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    31.290] (EE) 
[    31.291] (EE) Server terminated with error (1). Closing log file.

Oh god why didn't I choose an AMD graphics card. Also I recently switched from and intel 9400 which had integrated drivers

You probably didn't reboot after changing your system wide path properly before running the command to trigger DKMS.

echo $PATH; pacman -S nvidia-dkms and then upload /var/lib/dkms/nvidia/525.60.11/build/make.log

Share all logs.

Hmm I thought I did?
Does running sudo reboot suffice or do I have to do a full powerdown?