Boot Repair (the old dual boot drama)

It's probably a super newbie question, but I couldn't know the right terms to search for it on the forum, so point me the way if this is said elsewhere

I don't have Windows, but I have Pop!OS and turns out in upgrading the system it also vanished with my grub.
The Garuda partition is not showing at all on bios, (although it's shown in gparted, hallelujah) and I'm almost certain the Garuda Boot Repair can solve the problem
But I wasn't expecting so many options xD on this particular case, should I choose "Install on"

MBR
Root or
ESP
?

I have a guess that's ESP, but I do want to avoid trouble by selecting the wrong option and vanishing with something else ^^"

Thanks for the help in advance.

It is not showing because other linux distributions don't recognise it on the BTRFS partition. I think it is mentioned on the wiki or something.

1 Like

I think you could use this procedure.
It is a bit more complex, but it also show you how to recognize your UEFI partition.
And I think it should work.

4 Likes

Thank you both, people.

Yeah, Pop!OS do not have a grub so I think while upgrading, it didn't mind erasing Garuda's one. It didn't even try to recognize other OSs
That's why I installed it before Garuda but guess it didn't do much good on the long-term

And for the other "tutorial" I'll follow it along, but I'm at work today and I'll only be able to do so tomorrow. I'm really hoping that it works, I don't want to have to reinstall anything... that's for Windows users only xDD

1 Like

Not sure if this will be any help? I had opposite problem with Solus couple days ago.
After fresh install there was no way to boot it as it wasn't even showing up in (F12) boot menu and BIOS.
I found this.
Mint update-grub was detecting it, but not adding to grub boot as Solus is not using grub.
In my case sudo efibootmgr -c -d /dev/sda -p 1 -l "\EFI\systemd\systemd-bootx64.efi" -L "Linux Boot Manager" created BIOS/boot entry and I was able to boot into it. I only had to change sda to nvme01p1
Like I said I don't know it it helps, but Pop!OS upgrade might only remove entry from BIOS/boot menu leaving files in EFI partition.

1 Like

How about side chaining Bootloader ?

Sacrificing Time us worth if Risk of Multi Boot

Install GRUB as master Boot Loader ( Friendly with all OS uf configured correctly ).
It will detect Garuda on btrfs , PopOS! And any other & offer you options . For faster boot time set default to PopOS!(or any other) and set countdown to 1 sec( even 0).

I have 5 linux systems installed. So I can relate. Since installing Refind, life is so much easier!

I really hope this either solve the problem or at least don't finally let me totally out of access from any OS because I just typed it as is.
Update: it didn't break anything, so it's good, but it didn't really do anything at all, so... not great yet. But good try, tho

People, you have no idea how much I am affraid of messing the stuff up xD
Well, in any case, I always have a bootable pendrive, so at least that's it
But most of all, thanks everyone, so much, for giving me so many ideas! One of them ought to work : 3

I just installed grub on Pop! OS, it doesn't recognize btrfs partitions, but... well, at least I can access Mint again : V
Also

@nalisan007 I didn't quite understand what you meant, can you elaborate a little for me please? How to install grub as master boot loader?

1 Like

If you followed @petsam 's tutorial, and it didn't give you errors, it should have worked.
I looked through it, and it will for sure update grub and get it working.

1 Like

Maybe he was referring to the efibootmgr suggestion, not the tutorial

2 Likes

Sorry, @arco I was referring to this, that didn't do anything at all:

When it failed, I went to follow the tutorial that @filo referred to from @petsam and it should have worked indeed, but I got this output:

lsblk -f

NAME FSTYPE FSVER LABEL               UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash 4.0                                                                  0   100% /run/miso/
loop1
     squash 4.0                                                                  0   100% /run/miso/
loop2
     squash 4.0                                                                  0   100% /run/miso/
loop3
     squash 4.0                                                                  0   100% /run/miso/
sda
├─sda1
│    ext4   1.0                       3ad0ba6b-2cfe-45ec-a7c2-f29a2b670f8f
└─sda2
     vfat   FAT32                     062E-E4BF
sdb
├─sdb1
│    btrfs                            1409d596-84e3-4768-b0e5-996dc20bb2a5
├─sdb4
│    ext4   1.0                       8d7a36da-c5a9-4a95-b603-c45da94e7ae5
├─sdb6
│    ntfs         Archieves           01D5D24B78806C00
└─sdb7
     ntfs         Backup 1            01D6169267332650
sdc  iso966 Jolie GARUDA_LXQTKWIN_SOARING_
│                                     2021-05-07-13-46-46-00                     0   100% /run/miso/
├─sdc1
│    iso966 Jolie GARUDA_LXQTKWIN_SOARING_
│                                     2021-05-07-13-46-46-00
└─sdc2
     vfat   FAT12 MISO_EFI            13A9-0F24
zram0
                                                                                          [SWAP]
zram1
                                                                                          [SWAP]
zram2
                                                                                          [SWAP]
zram3
                                                                                          [SWAP]

 ╭─[email protected] in ~ took 88ms
 ╰─λ sudo mkdir -p /mnt/broken

 ╭─[email protected] in ~ took 85ms
 ╰─λ sudo mount /dev/sdb1 /mnt/broken

 ╭─[email protected] in ~ took 123ms
 ╰─λ sudo garuda-chroot /mnt/broken/@

sh-5.1# parted -l | grep iE "^Disk /|esp" | grep -B1 esp
grep: ^Disk /|esp: No such file or directory
sh-5.1# parted -l | grep iE "sdb /|esp" | grep -B1 esp
grep: sdb /|esp: No such file or directory
sh-5.1# parted -l | grep iE "sdb1 /|esp" | grep -B1 esp
grep: sdb1 /|esp: No such file or directory

sh-5.1# lsblk -no PKNAME /dev/sdb1
sdb
sh-5.1# grub-install /dev/sdb
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.

sh-5.1# mount /dev/sdb1 /boot/efi
sh-5.1# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
grub-install: error: /boot/efi doesn't look like an EFI partition.

I don't know what I did wrong, or how to workaround, so any help would be pretty much appreciated

This

and

are meant for UEFI systems, which I don't think is applicable here.
But that shouldn't have affected anything.
When you did

I don't know why it didn't work.
It is all beyond my knowledge now.

BTW, from all this, as an answer to your original question, I think you should choose MBR.

2 Likes

I am not sure but I think you must use FAT32 part, for legacy I am not sure. There is no /boot/efi.

sudo grub-install /dev/sda2

For efi?

sudo grub-install /dev/sda1

check the path with

lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
sda      8:0    0 232,9G  0 disk 
├─sda1   8:1    0   260M  0 part /boot/efi
└─sda2   8:2    0 232,6G  0 part /var/tmp
                                 /var/log
                                 /var/cache
                                 /home
                                 /root
                                 /srv
                                 /
sdb      8:16   0 111,8G  0 disk 
├─sdb1   8:17   0   260M  0 part 
└─sdb2   8:18   0 111,5G  0 part 
sdc      8:32   0 931,5G  0 disk 
├─sdc1   8:33   0   300M  0 part 
├─sdc2   8:34   0 324,1G  0 part 
├─sdc3   8:35   0   306G  0 part 
└─sdc4   8:36   0 301,1G  0 part 
sdd      8:48   0   3,6T  0 disk 
├─sdd1   8:49   0   2,6T  0 part /mnt/sdd1
├─sdd2   8:50   0   640G  0 part 
└─sdd3   8:51   0 392,5G  0 part 
sde      8:64   0   1,8T  0 disk 
└─sde1   8:65   0   1,8T  0 part /mnt/sde1
sr0     11:0    1  1024M  0 rom  
zram0  254:0    0  15,6G  0 disk [SWAP]

You must change terminal shell to bash, fish dosn't work with this syntax.
Just type

bash

in terminal

1 Like

If there is is really no esp, I think it should be
grub-install /dev/sda

2 Likes

Where is the information on the partition size in your output?

lsblk -f | grep sd
sda                                                                              
├─sda1 vfat   FAT32          4C0D-6FA4                             253,7M     1% /boot/efi
└─sda2 btrfs                 00a0c0cb-8fbe-4bbf-a7ef-72f4d595947f  173,1G    25% /var/tmp
1 Like

In the tutorial, there was none "grep sd" on the first command so I couldn't know xD
But okay, let me see if I got this right, first I should try this

If nothing, then

sudo grub-install /dev/sda1
or just sudo grub-install /dev/sda

And what is this for again?

I didn't really understand the purpose of this command. But, noted, is to use in bash.
I'm going to see if it works now, brb!

It just posts all sd partitions, no sr or zram or other.

2 Likes

If parted didn't grep any esp in your disks, I think your system is installed in Legacy BIOS/MBR, so I hope grub-install /dev/sda should work...

3 Likes

@sgs @filo @arco your help with the tutorial from petsam was all that I needed.
Indeed, the problem was that I was trying to install the grub on a device without EFI or any bios at all, as my EFI bios is in sda2, in the SSD.

Thank you all so much for your help!! The problem is solved and I'm currently already logged in on my favourite OS once more!
Also thanks @petsam for the tutorial : 3

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.