Boot into black screen after upgrade

I can install and use garuda from the April garuda KDE image, but yesterday after the sudo pacman -Syu, I can only reboot into a black screen. I am using an XPS 9570 laptop with a GTX 1050ti. I suspect it is somewhat related to the GPU drivers. Also, I tried the latest Garuda installing image, it also leads to a black screen so I can't even install it.

Also, I can't switch to the terminal after pressing ctrl alt fx, so I really don't know what I can do at this situatiion.
Do you guys know what happened?

Probability is that the drivers fault . Restore a previous snapshot to undo the changes update made . Try to see if you this is working.

That indeed works but seems whenever I use the GUI software manager to install something, it will update the system automatically. So I end up having to roll back again, which is really cumbersome.

Install through terminal

Tell when you had update the nvidia driver or intel graphics driver.
Probably problem is with intel driver since mainly it is physX

Found this in the log:

Install DKMS modules
==> dkms install --no-depmod -m nvidia -v 465.27 -k 5.11.11-zen1-1-zen
==> dkms install --no-depmod -m nvidia -v 465.27 -k 5.12.1-zen2-1-zen
==> depmod 5.12.1-zen2-1-zen
==> depmod 5.11.11-zen1-1-zen
Perhaps I should fall back to the 5.11.11-zen1-1-zen kernel?

I can't find anyway to downgrade the kernel, so I guess I will just use the snapshot for now. Thank you for the help man!
Refer to this

I found the problem was that instead of a booting failure, the system actually boots fine, it just doesn't output anything to my laptop's screen. When I connect it to an external monitor, the desktop starts to show on the external monitor, but still, my laptop's internal monitor is black.

I also tried adding the grub option "i915.modeset=0" / "nouveau.modeset=0", as described in Black screen on boot / Newbie Corner / Arch Linux Forums, while the first one leads booting to freeze at loading kernel, the second option doesn't seem to have any effect.

Had marked thanks for suggesting.

1 Like

Thank you man, it is nice to have your suggestions and feel the community.

I figured it should be a kernel bug, may be related to FS#61964 : Linux 5.0 XPS 15 9570 Built in screen blinks but doesn't show anything.. I switched to the LTS kernel and now it works fine.

1 Like

You can disable automatic updates for Discover in KDE System settings.
If you use pamac, I am sure you can also disable this in the GUI or disable a service or something.


Also if you have a problem with any package you can also hold at the current package version by editing pacman's configuration file.


Wow, I didn't know that, thank you!

Well it's not really recommended, because that creates a partial upgrade situation. However, sometimes it's the only option until the problematic package is corrected.


I have an XPS 7590 and this happened to me 2 days ago too after updating the kernel. For now i rollbacked to 5.11 and disabled pacman updates to linux-zen and linux-zen-headers. Do you guys have any updates if this was intentional or not? I don't want an LTS kernel because the primary focus of Arch it's to keep rolling but at the same time I have work to do. Is there any kernel issue open that I can follow?
Thanks in advance.

This is on arch forum

1 Like

It's an issue from 2017, I don't really think that would be the same one.

Linux is very good but vendors do not get benefited hugely especially gpu so there support is slightly less in these cases . But our community will make "Jugad" for that :wink::+1:

Honestly, I haven't noticed any obvious difference between the zen kernel and lts one, maybe you should give it a try.