Boost.Python error in job "bootloader" (/boot/efi doesn't look like an EFI partition)

I was trying to install garuda over my external harddisk. So I just created a partition over my harddisk and tried to install it over that. I had properly made partitions for boot/efi, linux swap and the basic installation area but still, I couldn't figure out how to resolve this issue.

We even have a similar issue on this forum but I believe that the user who had this issue earlier was unable to make you understand it clearly, so he hasn't got it resolved.

PS - I also figured out the same issue on the majaro linux forum but it stated the solution something related to NVRAM, can someone please be more specific about that!

Hey there,
This looks like you didnt setup EFI partition correctly, it needs to be FAT32 & flagged as boot if you setup manually.

3 Likes

This is probably IIRC a Calamares limitation.

  • Try the installation with manual partitioning.
  • Select a vfat/fat32 partition on external disk (flag as boot).
  • If possible (in Calamares options), don't install bootloader. This may not be an option, or may fail again anyway.
  • After the end of installation (even with the same error), don't reboot.
  • Exit Calamares and use File manager to check there is a system installed on external drive.
  • If so, chroot into the (external drive) system with garuda-chroot and install grub manually, by Archwiki instructions (or reading grub manual)

Note: If garuda-chroot is not installed, (or anyway) install it without system upgrade.

sudo pacman -S garuda-chroot

About installations on external drives, you cannot (practically) use nvidia proprietary drivers, just using open-source nouveau driver.
Either don't install any video driver, so the system will use kernel embedded (open-source) modesetting drivers, or install video-linux with mhwd utility, which will install the same drivers' packages.
Kernel default (first/main grub entry) images include HW drivers for HW that is present at the time of image building (mkinitcpio).
If you plug this (external drive) system on a different PC, with different accessories (mouse, keyboard etc) and some HW is not recognized/used, try booting to the fallback grub menu entry, which includes a richer drivers collection.

3 Likes

Thankyou you for your help. That issue got resolved.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.