Bluetooth issue

my bluetooth is not working properly it is switching off automaticaly every time i try to connect it to my device


post your inxi -Faz

1 Like

Also, you have provided very little background information. You have been a member of the forum for a fair while, so you should know what's required to help you.

Is this a new install?

Was your bluetooth working properly in the past on Garuda (or other distros)?

Did your BT break after an update?

If it broke at update do you know the aprox date it broke?

Have you tested other kernels such as the LTS kernel?

What things have you tried (list all) to fix your issue?

Have you checked your journal logs (please provide excerpts) for any bluetooth related errors?

You can't expect anyone to seriously be able to help you when you have provided zero information.

Please answer all questions put to you. Also, please provide your inxi -Faz output and any pertinent logs.


This can be from a few things none of which that are super solid in the logic or reproducible areas. So rather than connect to the device disconnect and distrust it first. You can restart the bt service for good measure

sudo systemctl restart bluetooth.service

Then try to pair the device and then connect/trust after.

I've seen this a few times where you connect, it connects then says disconnected immediately for no reason. The backwards "unpair/distrust" (when you want to connect heh) always fixes far anyhow.

this is not a new install my bluetooth was warking properly perviously on garuda but suddenly it started misbehaving

Have you tried what I suggested? I recently had this happen on a machine a few days ago as well.

yes i ran that command and removed my device and tried to connect again but again the same problem is there it connects and then the bluetoooth turns off automaticaly

Please, edit your post and user proper format and full in and output from inxi -Faz.

Well I didn't give a "command" perse but when you say bt turns off do you mean the adapter or the device you connected? If you mean like bt disables itself have you done sudo systemctl status bluetooth.service ?

Also yes you need to toss in your inxi -Faz

Its like the bluetooth connects to my device and it turns itself off imediatley after connecting to my device

I have already posted inxi -faz above

"It's like" isn't overly scientific :wink: Did you check the service with the command I gave you to see if bt is disabling itself or is the device just disconnecting?

As @SGS noted your inxi -Faz is not complete and lacks the correct formatting.

this is the only output i am getting from inxi -faz can you plz tell what is mistake here sorry for the inconvinence as i am still not used to of all this

F not f
Use three ~ in first and last line.

You got

inxi -Faz

Please refrain from pinging me or maybe even the Garuda team with @.

If you want to write to several people in one thread, it also works with one post.

Thank you and just a sample.

1 Like

Not this, please, inxi -Faz

1 Like

SGS may I ask why to not use that format for mentioning you when it's your post I'm referencing?

Directly "pinging" distro staff is considered rude behavior. We have too many users on the forum these days to have users constantly pinging forum staff using the forum's "@username" notification feature. Please only ping distro staff regarding development.

1 Like

It is unnecessary and should only be used when life is in danger.
What value is there in letting someone know I wrote something and waking me up unnecessarily with the @?

Thank you tbg :slight_smile:


Gotcha...SGS if someone's life is in danger they shouldn't be on the forum :stuck_out_tongue:

I think you've got it. :smiley:

Either way sorry, been a long time since I've been on forums and that whole twitter mention deal has kinda stuck so I'm used to adding @ to anyone's username.