Bluetooth cutting out and reconnecting

My Bluetooth speaker connects and works for few minutes and then after a few minutes stops working then after about a minute it disconnects and reconnects immediately and resumes working and this cycle repeats. Any ideas what could be wrong?

System:
Kernel: 5.16.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f8ed4bcf-36f3-424d-a4df-031651f7603b rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: GNOME 41.4 tk: GTK 3.24.32 wm: gnome-shell dm: GDM 41.3
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: X79-DELUXE v: Rev 1.xx
serial: UEFI: American Megatrends v: 4805
date: 02/02/2016
Battery:
Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
status: N/A
Device-2: hidpp_battery_0 model: Logitech Wireless Mouse M525
serial: charge: 100% (should be ignored) rechargeable: yes
status: Discharging
Device-3: hidpp_battery_1 model: Logitech Wireless Solar Keyboard K750
serial: charge: 100% rechargeable: yes status: Full
CPU:
Info: model: Intel Core i7-4930K bits: 64 type: MT MCP arch: Ivy Bridge
family: 6 model-id: 0x3E (62) stepping: 4 microcode: 0x42E
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3371 high: 3702 min/max: 1200/3900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3291 2: 3597 3: 3702
4: 3668 5: 3695 6: 2856 7: 3608 8: 3678 9: 3700 10: 2675 11: 2372
12: 3616 bogomips: 81648
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GK104 [GeForce GTX 770] vendor: [eVga.com](http://eVga.com). driver: nvidia
v: 470.103.01 alternate: nouveau,nvidia_drm pcie: gen: 2 speed: 5 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1184 class-ID: 0300
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 2-1.4:5 chip-ID: 046d:0825 class-ID: 0102 serial:
Display: x11 server: [X.Org](http://X.Org) v: 1.21.1.3 compositor: gnome-shell driver: X:
loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
gpu: nvidia display-ID: :1 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.0x22.5")
s-diag: 1166mm (45.9")
Monitor-1: DP-1 res: 3840x2160 hz: 60 dpi: 157
size: 621x341mm (24.4x13.4") diag: 708mm (27.9")
OpenGL: renderer: NVIDIA GeForce GTX 770/PCIe/SSE2
v: 4.6.0 NVIDIA 470.103.01 direct render: Yes
Audio:
Device-1: Intel C600/X79 series High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1d20
class-ID: 0403
Device-2: NVIDIA GK104 HDMI Audio vendor: [eVga.com](http://eVga.com). driver: snd_hda_intel
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e0a class-ID: 0403
Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 2-1.4:5 chip-ID: 046d:0825 class-ID: 0102 serial:
Sound Server-1: ALSA v: k5.16.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp9s0 state: up mac:
IF-ID-1: enp8s0u1c4i2 state: down mac:
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-1.6:4 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address:
Drives:
Local Storage: total: 1.86 TiB used: 121.08 GiB (6.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: BB6Q scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Intel model: SSDSC2BP480G4
size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 0420 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 1B6Q scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: Ultra
size: 57.28 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: 1.00 scheme: MBR
Partition:
ID-1: / raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 120.86 GiB (27.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 120.86 GiB (27.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 120.86 GiB (27.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 446.83 GiB size: 446.83 GiB (100.00%)
used: 120.86 GiB (27.0%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.29 GiB used: 4.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 45%
Info:
Processes: 389 Uptime: 5h 38m wakeups: 103 Memory: 31.29 GiB
used: 3.93 GiB (12.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1578 lib: 484 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.13
Garuda (2.5.5-1):
System install date: 2022-02-27
Last full system update: 2022-03-04
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: Probably (Run as root to verify)
Snapshots: Snapper
Failed units:

Tried disconnecting and repairing Bluetooth device and tried the kernel and did not fix the problem.

4 Likes

Please edit your post.

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

1 Like

Thanks I will do that in the future

Updated the system and the problem seems to have fixed itself.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.