Blackscreen at boot (poss display manager issues)

I'm new to Arch based linux, but have used many Debian based distros in the past, still got a bit of a learning curve to work out.
Anywho, my issue is that after booting from grub I am greeted with about 1 frame of the login screen followed by unresponsive black screen. I can Ctrl+Alt+F2 to ttl2 and run startx then the gui works as i would expect. However as I have not been able to identify the actual cause I have stumbled around and reinstalled a couple of times.
I am using Dragonized KDE, and as I have learned it uses SDDM by default. Previous examples of this issue seem to indicate it may be an issue, so I attempted to use the git one, but resulted in no change (if I even did it correctly).
I have not messed with my bios SATA settings as I seem to be able to boot just fine, no fast boot or fast startup.
I removed the boot splash screen as one post indicated that helped them for no particular reason, but that also did not help.

I expect it is the display manager as I have mentioned, however I have not had issues with display managers prior, and I have little experience with Arch based linux so I am at a loss as to how to go about fixing it.

i7 10700k
RTX 3080

Garuda Linux Dragonized
Kernal 5.14.8-zen1-1-zen (64-bit)
nVidia 470.74
KDE Plasma 5.22.5

Welcome :slight_smile:

Use forum search, upper right, "black screen" show


Not sure this is a driver issue - a couple of people have reported an issue with SDDM over recent days.

I wonder whether this is related to 470.74 adding Wayland support, and e.g. this is confusing SDDM... :thinking:


I have used the search, that is how I have found the things that I have attempted. That is also why I suspect it is the display manager. However, finding out that it is probably the display manager doesn't help me fix it if I don't know what to do to fix the display manager/what is preventing the display manager from working properly.

The forum post that would have been my best bet is nearly a half year old, and says to use the sddm-git, which i tried to no avail (as I mentioned in my original post).

I wouldn't think it is the driver if i can manuly startx, but as I am new to arch based linux my assumption may be incorrect. Hence why I am asking on the forums, I have spent the last week searching around for answers and have not found anything that has fixed the issue.


Could this be due to the known bug mentioned here (strange it is not fixed after two years)?,_but_no_greeter_shows


It might be helpful if you could provide your inxi and also perhaps some logs.

inxi -Faz
journalctl -b0 | nc 9999
cat /etc/sddm.conf 
cat /etc/sddm.conf.d/*.conf

Please post the outputs and the link to your journal log here.


inxi -Faz

System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d0768ad5-a584-4655-a857-d4505edb976e 
rw [email protected] rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter> 
Mobo: ASUSTeK model: ROG MAXIMUS XII HERO (WI-FI) v: Rev 1.xx serial: <filter> 
UEFI: American Megatrends v: 2201 date: 05/03/2021 
CPU:       Info: 8-Core model: Intel Core i7-10700K bits: 64 type: MT MCP arch: Comet Lake family: 6 
model-id: A5 (165) stepping: 5 microcode: EC cache: L2: 16 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 121596 
Speed: 4334 MHz min/max: 800/5100 MHz Core speeds (MHz): 1: 4334 2: 4765 3: 4801 4: 4396 
5: 4800 6: 4802 7: 4358 8: 4807 9: 4800 10: 4800 11: 4760 12: 4796 13: 4801 14: 4740 15: 3339 
16: 4801 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GA102 [GeForce RTX 3080] vendor: driver: nvidia v: 470.74 
alternate: nouveau,nvidia_drm bus-ID: 0000:01:00.0 chip-ID: 10de:2206 class-ID: 0300 
Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia 
unloaded: modesetting alternate: fbdev,nouveau,nv,vesa display-ID: :1 screens: 1 
Screen-1: 0 s-res: 3440x1440 s-dpi: 109 s-size: 802x333mm (31.6x13.1") s-diag: 868mm (34.2") 
Monitor-1: DP-4 res: 3440x1440 dpi: 109 size: 800x330mm (31.5x13.0") diag: 865mm (34.1") 
OpenGL: renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:06c8 
class-ID: 0403 
Device-2: NVIDIA GA102 High Definition Audio vendor: driver: snd_hda_intel v: kernel 
bus-ID: 0000:01:00.1 chip-ID: 10de:1aef class-ID: 0403 
Device-3: Focusrite-Novation Scarlett 4i4 USB type: USB driver: snd-usb-audio bus-ID: 1-11:10 
chip-ID: 1235:8212 class-ID: 0103 serial: <filter> 
Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.37 running: yes 
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 0000:00:14.3 
chip-ID: 8086:06f0 class-ID: 0280 
IF: wlo1 state: down mac: <filter> 
Device-2: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: efa0 
bus-ID: 0000:00:1f.6 chip-ID: 8086:0d4d class-ID: 0200 
IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
IF-ID-1: anbox0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:14 
chip-ID: 8087:0026 class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter> 
RAID:      Hardware-1: Intel Device driver: intel_nvme_remap v: N/A port: 4020 bus-ID: 0000:00:17.0 
chip-ID: 8086.06d6 rev: class-ID: 0104 
Supported mdraid levels: raid0 
Device-1: md126 maj-min: 9:126 type: mdraid level: raid-0 status: active size: 3.64 TiB 
Info: report: N/A blocks: 3907023872 chunk-size: 128k 
Components: Online: 
0: nvme1n1 maj-min: 259:0 size: 1.82 TiB 
1: nvme2n1 maj-min: 259:1 size: 1.82 TiB 
Device-2: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive size: N/A 
Info: report: N/A blocks: 5296 chunk-size: N/A 
Components: Online: N/A Spare: 
0: nvme2n1 maj-min: 259:1 size: 1.82 TiB state: S 
1: nvme1n1 maj-min: 259:0 size: 1.82 TiB state: S 
Drives:    Local Storage: total: raw: 12.06 TiB usable: 8.42 TiB used: 29.52 GiB (0.3%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: MZVLW256HEHP-00000 size: 238.47 GiB 
block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: CXB7401Q 
temp: 24.9 C scheme: GPT 
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: WD BLACK SN750 2TB 
size: 1.82 TiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
rev: 112000WD temp: 29.9 C 
ID-3: /dev/nvme2n1 maj-min: 259:1 vendor: Western Digital model: WDS200T3X0C-00SJG0 
size: 1.82 TiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
rev: 102430WD temp: 24.9 C 
ID-4: /dev/sda maj-min: 8:0 vendor: Mushkin model: MKNSSDRE1TB size: 931.51 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 7C scheme: GPT
ID-5: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WD4005FZBX-00K5WB0 size: 3.64 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: 1A01 scheme: GPT
ID-6: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD4005FZBX-00K5WB0 size: 3.64 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: 1A01 scheme: GPT
Partition: ID-1: / raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 29.52 GiB (3.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 29.52 GiB (3.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 29.52 GiB (3.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 931.26 GiB size: 931.26 GiB (100.00%) used: 29.52 GiB (3.2%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 125.69 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 27 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:      Processes: 506 Uptime: 21h 19m wakeups: 21 Memory: 125.69 GiB used: 5.93 GiB (4.7%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1939 lib: 541 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.06

journalctl -b0 | nc 9999

cat /etc/sddm.conf


HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot




ServerArguments=-nolisten tcp

cat /etc/sddm.conf.d/*.conf

File: /etc/sddm.conf.d/dr460nized.conf
HaltCommand=/usr/bin/systemctl poweroff
RebootCommand=/usr/bin/systemctl reboot


1 Like

I see that latte-dock is creating the dump.
I think you could give a look at this post:

But especially you should try adding a delay like here:


Thank you for the suggestions, but unfortunately there was no apparent effect for either of them. I even tried entirely turning off latte-dock and launching it from the terminal after logging in. That said I shall leave on the delay for good measure.

I forgot to mention I have also checked tty7, just like tty1, black screen.


So I'm out of my (few) ideas... :frowning:
My last suggestion would be to try with other kernels, maybe starting with linux-lts.
I've seen some users had problems with the latest zen kernels and moved to lts, but it was usually a matter of random freezes. That's why I'm not really convinced...


I found someone with an slightly older version of Garuda Linux same dragonized edition, just slightly older, and it worked, rebooted with no updates and it worked again.

Garuda Linux Dragonized (Bateleur)
Kernal 5.13.9-zen1-1-zen(64-bit)
KDE Plasma 5.22.4
nvidia driver 470.57.02
sddm 0.19.0-6 (update would install 0.19.0-7)

However after an update (ignoring sddm and sddm-kcm [double checked it wasn't getting upgraded by reading the terminal list of upgrades and downloads]) the problem started up again.

I have used time shift to get back to before the update, and all is working again.

so I have tried
sddm+kernel+nvidia drivers

not upgrading sddm, the kernel, and the drivers finally did the trick. so the issue appears to lie with the nvidia drivers

These are the packages being ignored by pacman:


I did it in bulk because I don't want to spend all day afterwork troubleshooting it, at least not today, maybe tomorrow I shall continue to narrow down the list.
P.S. I included linux as well and not just linux-zen just incase

1 Like

With this information I'm a bit more confident that it's worth trying the linux-lts kernel. That's 5.10, while both your current kernels are 5.14 in the end.

1 Like

Unfortunately, the issue is not resolved when using the LTS kernel with the newer nVidia drivers. However it is not just the nVidia drivers, if i update/upgrade either the nVidia drivers, or the linux-zen kernel the problem presents its self again.

Linux-zen 5.13.9 with nVidia 470.57 works.
Linux-LTS 5.10 with nVidia 470.57 works.
Linux-LTS 5.10 with nVidia 470.74 does not work.
Linux-zen 5.13.9 with nVidia 470.74 does not work.
Linux-zen 5.14.8 does not work with either nVidia driver.


Could you also check with linux ?


Also be sure to try the linux-mainline kernel if you haven't already.


linux 5.14.8 nVidia 470.57 issue persists
linux-mainline 5.15.0 nVidia 470.57 issue persists
linux 5.14.8 nVidia 470.74 issue persists
linux-mainline 5.15.0 nVidia 470.74 issue persists


So, if it is a matter of that nvidia version, I suggest you go back to one of the two working configurations and add nvidia* to IgnorePkg in pacman.conf.
To be honest, I don't know if the wildcard works or you'll have to specify your nvidia packages separated with a comma...
In this way, you can keep your system fully updated.

1 Like

That is what I have been doing since I found a working state :wink: I have the kernel and nvidia drivers ignored as updating either break it.

That said I was not going to ignore anyone attempting to find a fix rather than my workaround, as keeping my system out of date is not a state I want to permanently stay in. But as it stands it looks like l will have to await the next update for both and continue to see if my issue is fixed.

I appreciate all the suggestions from everyone, and if there are more let me know and I will attempt them. Thank you all!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.