Trouble with boot

Hi guys. I am newbie in garuda. Sooo.... Sometimes when I turn on computer after shutting down ( not reboot) I see that :

I just dont get latte-dock panels and half of all windows are clipped

Icant even imagine whats trouble
P.S. Sorry for my English

Maybe it is a driver problem, in that case to start we'll need your system info, posting the results of
inxi -Fxxxza as text
In the meanwhile, try also to check if the compositor is enabled (I read sometimes in the past that some games switch it off)

3 Likes

System: Kernel: 5.12.2-153-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq
root=UUID=9630025b-d670-492f-9b14-4d199959c6c3 rw [email protected] quiet splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
base: Arch Linux
Machine: Type: Laptop System: ASUSTeK product: X540LJ v: 1.0 serial:
Mobo: ASUSTeK model: X540LJ v: 1.0 serial: UEFI: American Megatrends v: X540LJ.305 date: 04/17/2019
Battery: ID-1: BAT0 charge: 24.8 Wh (100.0%) condition: 24.8/24.8 Wh (100.2%) volts: 11.2 min: 11.2
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging cycles: 199
CPU: Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61)
stepping: 4 microcode: 2F cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17578
Speed: 884 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 884 2: 1051 3: 1074 4: 881
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616
class-ID: 0300
Device-2: NVIDIA GK208BM [GeForce 920M] vendor: ASUSTeK driver: nouveau v: kernel bus-ID: 04:00.0
chip-ID: 10de:1299 class-ID: 0302
Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 04f2:b52b class-ID: 0e02
serial:
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel,nouveau unloaded: modesetting
alternate: fbdev,nv,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.1.0 direct render: Yes
Audio: Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0
chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
Device-3: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 10de:0e0f
class-ID: 0403
Sound Server-1: ALSA v: k5.12.2-153-tkg-bmq running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.27 running: yes
Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 4000
bus-ID: 02:00.2 chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0f2 state: down mac:
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave driver: ath9k v: kernel
port: 4000 bus-ID: 03:00.0 chip-ID: 168c:0036 class-ID: 0280
IF: wlp3s0 state: up mac:
Bluetooth: Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-4:4 chip-ID: 13d3:3423 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Drives: Local Storage: total: 465.76 GiB used: 82.31 GiB (17.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: SDM1 scheme: GPT
Partition: ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 82.31 GiB (17.7%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 560 KiB (0.2%) fs: vfat dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 82.31 GiB (17.7%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 82.31 GiB (17.7%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%) used: 82.31 GiB (17.7%) fs: btrfs dev: /dev/sda2
maj-min: 8:2
Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.92 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
Sensors: System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 36.0 C
Fan Speeds (RPM): cpu: 2200
Info: Processes: 234 Uptime: 1h 31m wakeups: 1 Memory: 7.67 GiB used: 3.51 GiB (45.8%) Init: systemd v: 248
tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1848 lib: 553 flatpak: 0 Shell: fish
v: 3.2.2 running-in: konsole inxi: 3.3.04

I think we'll need someone more experienced than me here, my hardware is too low end to have this type of problems (IMO the double cards).
Many times I read about this Nvidia Optimus, which seems to me (at a quick reading) exactly what you need.
https://wiki.archlinux.org/title/NVIDIA_Optimus
But someone will for sure confirm and provide more hints...

1 Like

kk
thanks
ill look further

From other threads on the forum this seems to indicate the compositor has exited (or crashed). Re-enable it from within the KDE settings.

2 Likes

is kwin the compositor in garuda?
Could you show where its settings are located?

I'm pretty sure you can just open the KDE settings and type "compositor" in the search box.

Or, do a web search for "kde compositor settings".

2 Likes

It works normal

Can changing of opengl version help?

You have to try it, so you"ll find out. It's possible, but it depends...

Also, the problem may just be that latte starts too early. There are cases that were fixed by adding a small delay in latte-dock start-up command.
If you want to try, edit the latte command in KDE Settings => Autostart applications => Latte properties
Prepend Command with sleep 3; (or higher number). Like this

sleep 3 ; latte-dock
7 Likes

yep! its finally working!
thank you!

What was the corrective action?

2 Likes

after that, the problem did not appear

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.