Black screen when attempting to boot from installation USB

I recently decided to install Garuda on my Dell Latitude E6410 laptop. When I attempt to boot using an installation USB, I can only get a black screen to show up. I’ve determined that the USB is not the issue, as it works in my main PC (using a 3070 and i5-11400). I’ve tried all of the options I could find online to no avail. The laptop doesn’t support Secure Boot, and Fast Boot is disabled. The SATA is set to AHCI as well. I’ve tried modifying the kernel options for the graphics as well, and still haven’t gotten anything. I’ve also tried using an external display, which showed the same results.

I have little experience with Linux as a whole, and no experience with Garuda.

Try using Ventoy to burn yours usb stick if you haven’t already


Ventoy wouldn’t provide much help, considering that the USB is verified to work.

So you get to the grub menu and then there’s a black screen? The Intel iGPU shouldn’t be the problem.

That may be, but you’re forgetting that your laptop’s hardware is over 20 years old.
Check the checksum of the ISO.
Try ventoy and try a different USB stick.
Have you tried all the fast boot settings (minimal/thorough/auto) in your BIOS?

If none of them work, try the LTS version:


Maybe the device doesn’t meet the minimum requirements for Garuda Linux, so it would be nice if everyone would always post their garuda-inxi, or inxi -Faz from MX Linux (MX works on my 2002 PC :grin: ).

1 Like

The checksums were identical.
I tried using Ventoy, and the result was identical to before, same with using a different USB drive.
There was also no change from using different fast boot settings.
As for the linked LTS version, it consistently fails when I try to download it.

That is a possibility. The only thing that’s different about mine compared to a stock one is that I’ve recently upgraded the RAM to 2x 16GB DDR3. The laptop is able to boot into Ubuntu, so I don’t believe the RAM could be an issue.

This sounds like when I tried booting without AHCI.

When I said that the kernel could handle unsupported hardware or config better, that’s what I mean. An error message would be appreciated here.

Then use ubuntu for inxi -Faz

1 Like

99% you have already tried this, but it is not mentioned: have you tried the option to boot with free drivers?
The problem might be, with proprietary drivers, that your model I believe uses an Nvidia dGPU ( NVIDIA GT218M [NVS 3100M]?) which requires the nvidia-340xx-dkms package which, by-the-way, seems to be having big troubles lately. See e.g.:
So, staying with free drivers might be the only option (if this issue can be solved).


I can confirm that, the download of the LTS version constantly breaks after a few minutes @SGS.


It works fine here (~30 MB/s), the problem is, this max. only 1 or 2 GB download error, are occur sporadically, and unfortunately I don’t know what the cause could be.

Just try Xfce, it use also LTS kernel and maybe it work better for old hardware.


@Lunaluu Hey, how’s it going? Glad you’re stepping into the world of GNU/Linux! I know you might be frustrated right now trying to get it to work.

Can you use your phone to take a picture of the black screen and post it here? If it’s literally a totally black screen with no cursor, symbols, or letters on the screen at all, then I’m not sure what to do. However, if it allows you to type on that screen or if there is a cursor or something showing, then we should probably be able to resolve this.

Try to boot again and when it goes to that black screen, press [ tab], [ space ], or type [ ls ] then hit [ enter ] and see what the response is.

It doesn’t let me upload an image yet (tells me that new users can’t upload images), but I tried all of the things you mentioned and never got any result. The screen is completely black, and the backlights are on.

@Lunaluu Ah, also I just thought about something else too. Sometimes, depending on your hardware or the usb stick or the boot process, it simply just takes much longer than usual for the system to startup. It’s happened to me several times. In fact, I think it has only happened with certain Arch-based distributions (fyi Garuda is also Arch-based) that I’ve tried in the past, such as Arcolinux or Archcraft. It took at least 5 minutes before anything showed up on my screen, but once it did, it was beautiful. Hope this helps!

Someone here had a similar problem recently, but the LTS version booted without any issues.

This was aimed at you, try the xfce spin from garuda linux:

Have you tried this:

I’ll try Xfce now. I’ve already tried both driver options multiple times with the same result.
@SGS I’m currently having trouble running inxi, as Ubuntu is throwing errors when I try to install. On top of that, my computer’s begun powering itself off abruptly even though it’s charging properly.

If you can spare the time, reboot and set a timer for 10 minutes (just to be extra liberal). If that doesn’t work, then I would either a) try a different method of obtaining the same iso image. For example, if you used direct download, then try the torrent. b) try to use one of the other versions on the Garuda download page (avoiding Sway or i3wm).

If you used KDE Plasma, try Gnome. If you used Gnome, then try Xfce (which might be the best for older hardware).

I’ll go ahead and see how it does after 10 minutes. If nothing changes, I’ll attempt to boot with Xfce as other people had recommended.

1 Like

I know it’s super frustrating. Just hang in there. If none of the solutions on here work for you, please don’t give up on Linux. There are a ton of other distributions that will almost certainly work for your particular machine. BigLinux, for example, doesn’t have high hardware requirements and I’ve never seen it not work. It’s also Arch-based like Garuda.