Bitlocker messed Grub menu?

Hello there,

I'm experiencing a problem where I cannot boot into Garuda.
My setup is Garuda i3 + Windows 11 Dual Boot.

Always had the Linux Grub which let me select either the Windows Boot Loader or Garuda.
Recently I decided to enable Bitlocker on Windows. I see that it encrypts only the C drive which is the partition of Windows 11 OS only.

After the encryption I noticed that during boot the Grub wouldn't show at all and it would straight boot on Windows. At first I though that somehow the boot order changed. Went to UEFI settings and saw that boot order wasn't changed at all.
It's so strange. Did Bitlocker messed with Linux Grub ?

What I did after that is to turn off Bitlocker. Tried to boot again but nothing. Even selected explicitly from one-time boot selection to boot to Garuda Grub but went straight to Windows(or went to the Grub and Grub said go to Windows...)

Any help and ideas to solve the problem and boot to Garuda and also have a functional bootloader again?

The first thing that comes to my mind is to boot from a (recent) live iso, reinstall the grub, and try again.
You can use the tools in the live US Garuda Welcome or:

Check also that Secure Boot on BIOS is still disabled. You never know with windows...
Careful here :point_up_2: (disable bitlocker from windows first, if renabled after your tests)
With a quick search on the Arch Wiki, I found this possible warning (I don't know if this applies only to Surface laptops):
And maybe also consider:


I will try it and come back with confirmation!

Surface things doesn't apply to me. Windows boots up normally.

Followed the guide provided on chrooting with Live ISO into the old installation. Found where GRUB was installed and updated it. Also after I had GRUB working and logged back in my Garuda, I had to update os-prober because it didn't find Windows bootloader at first.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.