BCM4360 - Broadcom Wifi problem

Best garuda users, today i installed garuda linux again on my macbook, the install media allowed me to connect to a wifi network, however after installation reboot no single SSID shows up on the wifi list, i tried restarting network manager however without any succes. The inxi -Fxxxza command gives the following output under

Device-1 Broadcom and subsidaries BCM43602 802.11ac  Wireless LAN SoC vendor: Apple Driver: N/A
modules: brcmfmac, wl port: efa0 bus ID: 03:00.0 chip ID: 14e4:43ba

I really want to use garuda linux as the main driver on the laptop however i cannot use it without internet. any help is much appreciated!

The issue persists in the Dragonized version and the normale KDE lite version.

Check if drivers are installed (using usb tethering for example if you dont have internet access)


Those Apple computers with their Broadcom chips are always causing problems. Do me a favour and please run this command and post the output:

hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  

Why don't you try running this command then test your wifi:

sudo systemctl stop NetworkManager; sudo modprobe -r wl; sudo modprobe -r brcmfmac; sleep 3; sudo modprobe brcmfmac; sudo systemctl start NetworkManager

There should be at least one error generated by the last command, please post the output generated by the last command as well.

Welcome to the forum BTW.


manually loading brcmfmac module after boot solves the issue for me, however i cannot get the module to boot automatically on startup. Quick connecting from the kde panel throws an error aswell saying that my user is not allowed to manage the network, however from within the system settings i can manually add my wifi and that will work.

Do you have autologin enabled?

1 Like

hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"

returns --->

Model: "Broadcom BCM43602 802.11ac Wireless LAN SoC"
Driver: "brcmfmac"
Device File: wlp3s0
Link detected: yes
Driver Status: brcmfmac is active
Driver Activation Cmd: "modprobe brcmfmac"
Driver Status: wl is active
Driver Activation Cmd: "modprobe wl"

Autologin is enabled yes

I would advise to disable it as its currently preventing the autostart of kde-polkit (needed to install software via pamac for example, which tells not able to authenticate if polkit isnt running). Im pretty sure the issue of not being able to manage networks is also caused by this one.

1 Like



Instead of starting a new thread I decided to comment on the one that helped a bit. Please advise as to whether this was a faux pas. I am accustomed to XDA Developers website. And the custom there is to avoid creating new threads.

Anyway, I ran:

No error was generated. No outpurt as well. Although, oddly enough, the wifi was made to work. The issue is taht it does not survive a reboot. I have to re-enter the command after every re-boot. How can I solve??

All help is appreciated. Also, Just a heads up, I am a linux nooB!!

Generally, it is preferred that you start a new thread rather than reviving an old one. That is because many people think their issues are identical when in fact they are only semi related or not at all.

In this case however the issue actually is identical.

This is not odd at all really, if you understand how modprobing a driver works. The command is only designed to last for the current session.

Uninstall the wl driver and your issue will likely resolve itself.


Going forward I will create new threads. The rationale behind doing so makes sense.

In the XDA modding world it is quite easy to remain an end user while benefitting from the systems used to increase the functionality of your handset. Not so much so with Linux. I apparently find Linux appeals to me. I made the full switch three years ago and always gravitate away from the 'set it and forget it' distros. Here woth Garuda even more so. Suffice to say I must learn!

On it in the afternoon.. I will, of course, update with the results. On to Google to learn how to uninstall the wl driver. Thank you!

1 Like

So, with a lead from @tbg, I went ahead and found that using pamac I could uninstall the wl driver. This after searching for a way to do it in the command line. As I could find none I guessed at a search(wl) in pamac, found one installed instance and removed it. Rebooted and reward. Wifi works as expected after reboot. Mark as solved.

1 Like