BalenaEtcher does not open from applauncher link, but will from terminal?

So I installed BalenaEtcher today using Octopi; everything seemed to go well, as an entry was made with an icon in the application launcher. I click it, and I get a little bounding green box for a few seconds, and......nothing.

Strange.

So, I go into terminal and go to /bin, I see etcher using ls etcherand type sudo etcher, enter my pw, and poof! Etcher starts up and runs perfectly. I see a whole lot of messages in the terminal window while it's running too, some of which were yellow warnings. I don't recall specifically; I'd have to run etcher again and see. Anyhoo, I see file permissions for etcher shouldn't be an issue:

[🔴] × ls etcher
.rwxr-xr-x 57 root  5 Nov 04:24  etcher

right? I mean, it's not a permission issue it seems, and if it was, shouldn't I get a "root" dialogue box prompting me for my root pw?

If I click on the icon in the app launcher, it shows this:

and this:

and shows the program location as /opt/balenaEtcher/balena-etcher-electron, which is not the file I'm running in the terminal (obviously). If I open terminal, navigate to /opt/balenaEtcher/ and attempt to run balena-etcher-electron, this is what I get:

sudo balena-etcher-electron
[sudo] password for mx372:
sudo: balena-etcher-electron: command not found

So now I'm stumped. I'm doing something wrong I'm sure, I just don't know what.

Thanks for the help and education as I'm continuing to learn linux.

garuda-inxi:

System:
Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=33bab7e2-354b-4a41-90a0-a035436b4688 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=d50fe1fb-623e-4546-b2a6-59b370feff67 loglevel=3
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4901
date: 07/25/2022
Battery:
Device-1: hidpp_battery_0 model: Logitech G700s serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3598 high: 3600 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3600 2: 3582
3: 3600 4: 3600 5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600
12: 3600 bogomips: 86401
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
protection
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: eVga.com.
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 07:00.0 chip-ID: 10de:2482
class-ID: 0300
Device-2: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 046d:0892
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 5360x1685 s-dpi: 94 s-size: 1447x455mm (56.97x17.91")
s-diag: 1517mm (59.72")
Monitor-1: DP-4 pos: primary,top-left res: 3440x1440 hz: 60 dpi: 109
size: 800x335mm (31.5x13.19") diag: 867mm (34.15") modes: N/A
Monitor-2: HDMI-0 pos: bottom-r res: 1920x1080 hz: 60 dpi: 96
size: 509x286mm (20.04x11.26") diag: 584mm (22.99") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX 3070
Ti/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA GA104 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel bus-ID: 5-2:2 v: kernel pcie: chip-ID: 046d:0892
gen: 3 class-ID: 0102 speed: 8 GT/s serial: <filter> lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 07:00.1 chip-ID: 10de:228b class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech C920 HD Pro Webcam type: USB
driver: snd-usb-audio,uvcvideo
Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 13.19 TiB used: 2.46 TiB (18.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDBRPG0010BNC-WRSN size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 111130WD temp: 40.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: MBR
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWE140 size: 3.64 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: <filter> rev: FP1R scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: MD04ACA500
size: 4.55 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: FP2A scheme: GPT
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Toshiba
model: External USB 3.0 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: N/A serial: <filter> rev: 5438 scheme: GPT
Partition:
ID-1: / raw-size: 896.83 GiB size: 896.83 GiB (100.00%)
used: 209.37 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 896.83 GiB size: 896.83 GiB (100.00%)
used: 209.37 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 896.83 GiB size: 896.83 GiB (100.00%)
used: 209.37 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 896.83 GiB size: 896.83 GiB (100.00%)
used: 209.37 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 1.5 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 34.39 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
System Temperatures: cpu: 35.0 C mobo: 29.0 C gpu: nvidia temp: 47 C
Fan Speeds (RPM): cpu: 800 case-1: 749 case-2: 0 case-3: 878 gpu: nvidia
fan: 0%
Power: 12v: 9.92 5v: N/A 3.3v: N/A vbat: 3.23
Info:
Processes: 344 Uptime: 2h 43m wakeups: 10 Memory: 31.26 GiB
used: 5.01 GiB (16.0%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 2040 libs: 556 tools: octopi,pamac,paru Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-10-29
Last full system update: 2022-11-07 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Reboot

Last full system update: 2022-11-07 ↻

Use pacman, and install Ventoy :smiley:

Try

etcher

in terminal.

3 Likes

What is Ventoy?

I did an update this morning. I have not rebooted yet though....so, duh!

And yes, etcher in a terminal works fine, but I would like to get the link in the applauncher working correctly. Maybe a reboot will fix that. I'll post back the results....thanks.

Sorry, but

is a better way to use live ISO's.

2 Likes

Also, never use Octopi to install things. It will break the internet. (No seriously, use pacman in a terminal, GUI package installers tend to do bad things)

And I'm not one to ever recommend balenaEtcher, not after finding out that they needlessly use the tool to capture metrics (and no, I'm not a privacy freak, this is a simple tool for a simple job, why is it gathering any metadata at all on you?).

Ventoy, however, as was suggested, is something I use regulary and strongly recommend, and it's insanely easy to use. Install, copy ISO files to it, boot it.

5 Likes

If you want to continue with balena etcher, consider that etcher is probably this one here, which doesn't have a desktop file (can be created manually) . See comments here:
https://aur.archlinux.org/packages/etcher-bin
While the balena-etcher-elektron is this one, with a desktop file:
https://aur.archlinux.org/packages/balena-etcher

2 Likes

Time to remove balena from chaotic-aur :smiley:

Just bloat for things dd can also do :slight_smile:

sudo dd bs=4M if=garuda-i3-$date-linux-zen.iso of=/dev/sdX status=progress oflag=sync
8 Likes

Well, there's also mediawriter, which is Fedora's Media Writer, which is as simple as belenaEtcher, but without the monitoring metrics included for absolutely no reason. (I mean, belenaEtcher is freaking Electron for no reason).

And yep! This, in most modern distros, works great, provided you know the of value properly..

4 Likes

Oh wow. Bloat.

I have been downloading the appimage from balena themselves and using that. Not ideal in my book, but it works...

Guess i'm moving to ventoy instead.

5 Likes

Non-bloated tools to write images to USB sticks: USBImager and MintStick.

If you are launching etcher from terminal with $ etcher, open menu editor, highlight etcher and click properties and in the command box replace whatever it has with just etcher, or whatever you are entering in terminal to launch it. That should do it.

1 Like

Open With: Kate ????!!!!

Should not open with Kate.

Here is the .desktop in the aur:

[Desktop Entry]
Name=BalenaEtcher
Comment=Flash OS images to SD cards and USB drives, safely and easily.
Exec="/usr/bin/balena-etcher-electron" %U
Terminal=false
Type=Application
Icon=balena-etcher-electron
Categories=Utility;

I'm removing Etcher Chaotic-AUR because it hasn't updated to a modern version of electron. When that happens, it will likely be much smaller. At that point, we could consider adding it back. etcher-git will be the most likely candidate when that eventually happens.

6 Likes

Replace Octopi with pamac-all and only use the pamac gui to see what updates are available and then do the updating from your terminal. As for SGS's Ventoy suggestion yes use it and not Etcher.

2 Likes

Yikes! NO! This is not the way. There's far better ways to check for updates and keep up-to-date.

Two prime examples:

kalu - Systray app that keeps you notified of updates, and can be customized to run garuda-update like it should be if you use it.
gnome-shell-extension-arch-update - GNOME extension very similar to kalu.

1 Like

Nice tip, kalu sounds like a very convenient all-in-one reminder, I'll check it out.

edit: forgot to add, I'm happy with the little waybar widget that comes with the Sway edition.

1 Like

If you want to use a GUI utility for creating your boot disks, then I would recommend Suse ImageWriter. It is small, does not collect any user info, and has always worked flawlessly on Arch derivatives in my experience. Of course dd is the surest method, as long as you are careful to point to the right destination drive.

4 Likes

My way or your way both work perfectly fine. NOTHING wrong with either.

Thank you all for the replies, much appreciated.

Although I desire to learn the CLI better, I am of the opinion that modern computers should have GUI applications that are just as powerful as any CLI commands. One should not have to learn the CLI in order to have full control over their machine, just like one should not require an engineering degree in automotive engineering in order to drive their car. Maybe not the best comparison, but I think I make my point.

I do however desire to learn as much as I can, and yes, using the CLI to do things will help me to do that. But at the same time, if a GUI app exists to do "the thing", why not use it?

I was not aware of those details about balenaEtcher; it's just what I've used in Windows. I'll remove it and try out Ventoy or some of the other suggestions.

I do search the Wiki, to include Arch, before posting. Also, if Octopi is not so good, why is it included by default in Garuda, and why not some other GUI app instead?

Thanks all!

2 Likes

It sure helps to know a thing or two about how it works though...

My two cents about GUI tools in general is, I wish they were made in a way that guides the user to learn what happens behind the scene rather than hide it from view.
Something like an IDE, where you click "build" but still get to see the compiler command line.

3 Likes