Audio problems after update (2022-08-19)

Hello everyone, after updating the system (2022-08-19) , there was a problem with the sound when turned on, I'll try to attach a video.
After starting the system, the application that initializes the sound makes an incomprehensible noise (duration up to 1 second)
video of problem Audio problem Garuda Linux - YouTube.
On the video i just click on the sound icon and I hear this sound.
The same happened if i start google chrome and go to youtube, only in first initialization of sound i always hearing something like this.
I am found on the forum Topic with Audio (Audio Problems) and tryed do the same, but no results.
How it is possible to solve it? thanks in advance)
My inxi:

╭─[email protected] in ~ 
╰─λ garuda-inxi
System:
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0faf27b9-047d-4003-b67d-2b431e93daf8 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-M2 MAX (MS-7B84) v: 2.0
serial: <superuser required> UEFI: American Megatrends v: A.70
date: 06/10/2020
CPU:
Info: model: AMD Ryzen 5 3500X bits: 64 type: MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
desc: 2x16 MiB
Speed (MHz): avg: 2524 high: 3603 min/max: 2200/4120 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3603 2: 2056
3: 2890 4: 2199 5: 2200 6: 2200 bogomips: 43199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1 empty: DP-1, DP-2,
DVI-D-1, HDMI-A-2 bus-ID: 29:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: LG (GoldStar) FULL HD
serial: <filter> built: 2016 res: 1920x1080 hz: 75 dpi: 102 gamma: 1.2
size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.46 5.18.16-zen1-1-zen) v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 912.89 GiB used: 244.32 GiB (26.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP510
size: 447.13 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFM22.6
temp: 39.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWD105
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A8R0
scheme: GPT
Partition:
ID-1: / raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 26.07 GiB
(13.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 311.8 MiB size: 311.2 MiB (99.80%) used: 608
KiB (0.2%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 218.25
GiB (46.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 26.07
GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 26.07
GiB (13.6%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 55.8 C mobo: N/A gpu: amdgpu temp: 48.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 229
Info:
Processes: 285 Uptime: 12m wakeups: 0 Memory: 15.57 GiB used: 2.31 GiB
(14.8%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1525 lib: 479 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-06-20
Last full system update: 2022-08-19
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Hi there, welcome to the forum.
Your

is not consistent with

(should be 5.19)
Have you restored a snapshot?
If not, maybe you could try to

garuda-update

again...

1 Like

Yes, the first time I restored the snapshot. There were no problems with sound on the old version of garuda) Then I updated again.

It is possible that after full update kernel was not updated ? )
Just now i started garuda-update, here is my new inxi

╭─[email protected] in ~ 
╰─λ garuda-inxi
System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0faf27b9-047d-4003-b67d-2b431e93daf8 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-M2 MAX (MS-7B84) v: 2.0
serial: <superuser required> UEFI: American Megatrends v: A.70
date: 06/10/2020
CPU:
Info: model: AMD Ryzen 5 3500X bits: 64 type: MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
desc: 2x16 MiB
Speed (MHz): avg: 2492 high: 3943 min/max: 2200/4120 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2267 2: 2198
3: 2200 4: 2199 5: 2146 6: 3943 bogomips: 43200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1 empty: DP-1, DP-2,
DVI-D-1, HDMI-A-2 bus-ID: 29:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: LG (GoldStar) FULL HD
serial: <filter> built: 2016 res: 1920x1080 hz: 75 dpi: 102 gamma: 1.2
size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
3.47 5.19.2-zen1-1-zen) v: 4.6 Mesa 22.1.6 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 912.89 GiB used: 249.44 GiB (27.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP510
size: 447.13 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFM22.6
temp: 46.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWD105
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A8R0
scheme: GPT
Partition:
ID-1: / raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 31.15 GiB
(16.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 311.8 MiB size: 311.2 MiB (99.80%) used: 608
KiB (0.2%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 218.29
GiB (46.9%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/log raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 31.15
GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 191.88 GiB size: 191.88 GiB (100.00%) used: 31.15
GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 57.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 250
Info:
Processes: 286 Uptime: 1m wakeups: 0 Memory: 15.57 GiB used: 1.61 GiB
(10.3%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1547 lib: 480 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-06-20
Last full system update: 2022-08-20
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

This is unlikely to happen, the update process would stop.
Before rebooting after kernel upgrade, inxi shows the old kernel, but in that case you can see the ↻ symbol after the last full upgrade date. Strange.
Have you tried to switch to the linux-lts kernel now, with fully updated system, to see if you have better luck?

1 Like

after full update garuda problem was not solved, my kernel now - (Kernel: 5.19.2-zen1-1-zen)

i did some tests,theese artifacts with sound also has in livecd with (5.18.16-zen1-1-zen), when i startup from flash, before install new system.

Just now tryed linux-lts kernel , on this kernel no any problems with sound. Thank you )
Probably on my configuration of PC something wrong with zen kernel, also i install garuda on laptop and make fully upgrade, no any problems on zen kernel on my laptop

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.