Audio issues teclast f7 plus 3

hi , after the installation of garuda on my new laptop teclast f7 plus 3, i can t hear audio playing by speaker or headphones.
i also tried mirroring on a monitor with speakers by hdmi, but nothing.

following i post garuda-inxi output

System:
Kernel: 5.17.2-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6bd9b760-f993-4776-aa65-d8495dff886f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=afda87c6-cacc-4262-a2c2-95974183e977 loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop Mobo: N/A model: N/A serial: <superuser required>
UEFI: American Megatrends v: tPAD3.03 date: 11/08/2021
Battery:
ID-1: BAT0 charge: 20.1 Wh (44.1%) condition: 45.6/45.6 Wh (100.0%)
volts: 7.6 min: N/A model: Emdoor Li-ion Battery type: Li-ion
serial: <filter> status: charging
CPU:
Info: model: Intel Celeron N4120 bits: 64 type: MCP arch: Goldmont Plus
family: 6 model-id: 0x7A (122) stepping: 8 microcode: 0x1C
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
desc: d-4x24 KiB; i-4x32 KiB L2: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2487 min/max: 800/2600 scaling: driver: intel_cpufreq
governor: schedutil cores: 1: 2487 2: 2487 3: 2487 4: 2487 bogomips: 8755
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel GeminiLake [UHD Graphics 600] vendor: nCipher Security
driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
Device-2: IMC Networks XHC Camera type: USB driver: uvcvideo
bus-ID: 1-6:4 chip-ID: 13d3:784b class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: BOE Display 0x0a78 built: 2021
res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.69")
diag: 355mm (14") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.0.1
direct render: Yes
Audio:
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
driver: sof-audio-pci-intel-apl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_apl
bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0401
Sound Server-1: ALSA v: k5.17.2-zen3-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:3165 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-4:3 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 238.47 GiB used: 33.09 GiB (13.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Teclast model: BD256GB SHCB-2280
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 5A0 scheme: GPT
Partition:
ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 33.09 GiB (14.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 33.09 GiB (14.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 33.09 GiB (14.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 33.09 GiB (14.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 7.59 GiB used: 270.5 MiB (3.5%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 92.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 254 Uptime: 29m wakeups: 1 Memory: 7.59 GiB
used: 2.67 GiB (35.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1328 lib: 343 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.1-1):
System install date:     2022-04-13
Last full system update: 2022-04-15 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Please edit your post and

:slight_smile:


2 Likes

I recently had a laptop with a similar issue but found this piece of cake fix:

First fully update:

garuda-update

Then install alsa-utils:

sudo pacman -S alsa-utils

Unmute master volume:

amixer sset Master unmute

Reboot.

If you don't get lucky like me with a nice easy fix, you might have to do some digging. This is a good place to start: Advanced Linux Sound Architecture - ArchWiki

i tried, i m not lucky :frowning:
thanks by the way