Astro A50 need some Help plx Discord picking lineIn as Microphone

Inxi

since a few Updates my Astro Headset is showing Both Audio Channels before i only had 1 Channel In and 1 Out and it worked, a poor Quality but it Worked... now i got Both Channel In Game and Voice also Surround Sound is Working nice but my Microphone i don´t know its Messed up a bit.
Discord is Streaming all Incoming Sound to the Audience but not the Incoming Voices from Discord (only other Application Sounds) and i dont Know were to start digging if 1 of u had the same Headset and knows the glue plx give me a hint. Thanks a Lot :wink:

I Only found a PulseAudio Fix at Github and a Forum from EndeavorOS pointing to that Gist but... only 10 Star and i use pipewire and dunno if that impacts something ...

Gist

╰─λ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 137
Tile Size: 65472
User Name: nudel
Host Name: Gott
Server Name: PulseAudio (on PipeWire 0.3.42)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-Astro_Gaming_Astro_A50-00.pro-output-0
Default Source: alsa_input.usb-Astro_Gaming_Astro_A50-00.pro-input-1
Cookie: cd8b:c50c
[    3.017758] usb 3-2.4: New USB device found, idVendor=9886, idProduct=0015, bcdDevice= 0.00
[    3.017761] usb 3-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.017762] usb 3-2.4: Product: Astro A50
[    3.017763] usb 3-2.4: Manufacturer: Astro Gaming
[    3.113279] hid-generic 0003:9886:0015.000A: hiddev103,hidraw9: USB HID v1.00 Device [Astro Gaming Astro A50] on usb-0000:07:00.3-2.4/input6
[    3.116694] systemd[1]: Finished Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling.
╰─λ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 2537:1081 Norelsys NS1081
Bus 004 Device 003: ID 05e3:0620 Genesys Logic, Inc. USB3.0 Hub
Bus 004 Device 002: ID 174c:3074 ASMedia Technology Inc. ASM1074 SuperSpeed hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0b05:1824 ASUSTek Computer, Inc. ROG SPATHA Receiver
Bus 003 Device 006: ID 9886:0015 Astro Gaming A50
Bus 003 Device 005: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 003 Device 004: ID 0b05:181c ASUSTek Computer, Inc. ROG SPATHA
Bus 003 Device 002: ID 174c:2074 ASMedia Technology Inc. ASM1074 High-Speed hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 0b05:18f3 ASUSTek Computer, Inc. AURA LED Controller
Bus 001 Device 005: ID 1b1c:0c10 Corsair Commander PRO
Bus 001 Device 006: ID 1b1c:0c21 Corsair H115iRGBPROXT
Bus 001 Device 004: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 05ac:0256 Apple, Inc. AZIO Retro Classic USB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Switch the device profile to Analog Duplex.

(I use pavucontrol for this, but KDE probably has that setting somewhere in its audio configuration.)

1 Like

i could switch to

  1. Analog Stereo Out and Mono In ( Crashes Sound Settings and Won´t Work)
  2. Analog Stereo Out (Disables Mic only 1 Out)
  3. Digital Stereo (IEC958) Out and Mono In (Works Out but Mic doesnt Recognize me)
  4. Digital Stereo (IEC958) Out (no Mic)
    5 Pro Audio (Works all getting 2 Out Devices but Streams Sounds trough Mic)
  5. Mono In ... Microphone Works but have no Sound

But didnt found an Analog Duplex

1 Like

Hmm.

I'd have a look at inxi -Aaz to find out the audio chipset, then look for any other threads/issues on this, the EnOS, and the Arch fora, as well as for any similar models on the Arch wiki.

Could you link to this so I can have a look?

1 Like

first Post is the Link

[🔍] × inxi -Aaz
Audio:
Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 0a:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: Astro Gaming A50 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2.4:6 chip-ID: 9886:0015
class-ID: 0300
Sound Server-1: ALSA v: k5.15.10-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
1 Like

Oops, I read past that!

1 Like

Yea i Vomit to much in that first post :wink:

OK, so there's an old (and resolved) bug report here:

This indicates support was added in alsa-card-profiles=14.1-2 which has since been replaced by a PipeWire version, currently 1:0.3.42-1 .

Do you have this installed?

I can see there's an entry for the Astro A50 Gen4 in /usr/lib/udev/rules.d/90-pipewire-alsa.rules :

...
# Lucidsound LS31
ATTRS{idVendor}=="2f12", ATTRS{idProduct}=="0109", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
# ID 9886:002c is for the Astro A50 Gen4
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="002c", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
# ID 1532:0520 is for the Razer Kraken Tournament Edition
ATTRS{idVendor}=="1532", ATTRS{idProduct}=="0520", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"
...

but this doesn't match your headset:

So - adapting the existing line, let's create a new rule to match your headset:

/etc/udev/rules.d/90-astro-50.rules

# ID 9886:0015 is for the Astro A50
ATTRS{idVendor}=="9886", ATTRS{idProduct}=="0015", ENV{ACP_PROFILE_SET}="usb-gaming-headset.conf"

If that works then you can figure out why there's a different USB ID. :grin:

[🔴] × pacman -Q pipewire
pipewire 1:0.3.42-1

and i should take the Gist and change the /etc/udev/rules.d/90-astro-50.rules ?
or only make a rule <3

Only make a rule file using the line above.

(The gist creates a new profile, but that's not needed as it already exists in alsa-card-profiles)

1 Like

Got

  1. Chat Out like the Old Stereo out
    2 Chat Out and Chat In Crashes Audio Config at Testing the Output :wink: after switching to any Other Option and then Back the Output Works but Mic nope i see the Amp. going up with my Voice but Discord dont Rekognize me...
    3 Pro Audio (best Audio Quality and Both Channel but Mic is Streaming)
    4 Chat In only Mic and Works ....

its so weird and every turn from Pro Audio to any other i need to restart for Action...
or just restart the alsa and pipewire ctl's ?

1 Like

I don't know - it looks like "something else" needs to be done to get this one working. I assume this is a Gen3... there's some mention on the gist about someone doing some more editing but it isn't clear what they actually did.

1 Like

yea i read that too and yes its a gen 3 short before logitech bought the company :wink:

never mind.. i just have to be aware at watching porn and having a chat at discord ...

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.