Are there any instructions on how to design the Garuda interface? | Theme does not suit my taste


I am a computer dilettante, new to Arch/Garuda system that I installed just to test and learn, I come from Debian systems.

I would like to know if there is any basic tutorial, in brief with the main thing to know/do in this system, after installing/updating it, for example I don’t see that it looks like it appears in your web page:

Thank you very much and best regards!

 ╭─alnone@alnone in ~ took 7ms
 ╰─λ inxi -Faz
  Kernel: 6.6.21-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=91c0a886-25fe-452a-b52b-00f0e5b90cbe rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver avail: xautolock vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 3583 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0WHCP7 v: A00 serial: <superuser required> part-nu: 08CA
    uuid: <superuser required> UEFI: Dell v: 1.5.1 date: 05/30/2019
  ID-1: BAT0 charge: 39.9 Wh (100.0%) condition: 39.9/42.0 Wh (95.0%)
    volts: 12.6 min: 11.4 model: SMP DELL VM73283 type: Li-poly serial: <filter>
    status: full
  Info: model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 8 level: v3 note: check
    built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
    stepping: 0xC (12) microcode: 0xFA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 800 min/max: 400/3900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 28808
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:3ea0
    class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:3 chip-ID: 0bda:5520
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x10ec built: 2017 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1366x768
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: Intel
    UHD Graphics 620 (WHL GT2) driver: mesa intel v: 24.0.2-arch1.2
    device-ID: 8086:3ea0 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.2-arch1.2 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  API: ALSA v: k6.6.21-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Local Storage: total: 238.47 GiB used: 23.19 GiB (9.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN520 NVMe WDC 256GB size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
    fw-rev: 20200012 temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 48.48 GiB size: 48.48 GiB (100.00%) used: 7.69 GiB (15.9%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1.43 GiB size: 1.43 GiB (99.80%)
    used: 27.1 MiB (1.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 48.48 GiB size: 48.48 GiB (100.00%)
    used: 7.69 GiB (15.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 48.48 GiB size: 48.48 GiB (100.00%)
    used: 7.69 GiB (15.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 48.48 GiB size: 48.48 GiB (100.00%)
    used: 7.69 GiB (15.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 1.42 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: swap-2 type: zram size: 7.63 GiB used: 211 MiB (2.7%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 47.0 C pch: 46.0 C mobo: 39.0 C
  Fan Speeds (rpm): cpu: 0
  Memory: total: 8 GiB available: 7.63 GiB used: 3.18 GiB (41.6%)
  Processes: 261 Power: uptime: 4h 12m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 3.04 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1367 libs: 419 tools: octopi,paru pm: flatpak
    pkgs: 0 Compilers: gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.33

 ╭─alnone@alnone in ~ took 1s

I found a lot of things, except how to achieve the aesthetic factor that appears on your website (?). I must be missing something but I can’t find what it could be, if someone else, please, tell me how to get that beautiful configuration … – my settings are still showing an ugly white backgrounds, without colors …

That’s just taste, many like the light version, other like me not, but that’s not ugly! :slight_smile:

I think I set the dark things with kvantummanager or try nwg-look.


I had installed ‘flat-remix-gtk’ and made changes too into the xfce4-appearance and now also the ‘nwg-look’ as you recomended but those are tools for xfce4 and as far as I know they do not modify the system/Garuda applications, for example “garuda linux spizaetus” after all I have configured it is still as pale/ugly :rage: as before, am I in an error or unfortunately the screenshot that appears on your web site does not correspond to Xfce4?

*kvantummanager is not here, maybe because I don’t have the proprietary … I avoid them. :thinking:

Thanks for your advice :slightly_smiling_face:


sudo pacman -Syu kvantum-qt5 kvantummanager

kvantum-qt5 for garuda-apps


Make sure you have done the following before you post:

╭─alnone@alnone in ~ took 9ms
 ╰─λ LANG=C sudo pacman -Syu kvantum-qt5 kvantummanager
[sudo] password for alnone:    
:: Synchronizing package databases...
 garuda is up to date
 core                  132.2 KiB   523 KiB/s 00:00 [----------------------] 100%
 extra                   8.4 MiB  4.41 MiB/s 00:02 [----------------------] 100%
 multilib              142.5 KiB   548 KiB/s 00:00 [----------------------] 100%
 chaotic-aur             2.5 MiB  1647 KiB/s 00:02 [----------------------] 100%
error: target not found: kvantummanager

 ╭─alnone@alnone in ~ as 🧙 took 6s
[🔴] × 

Ok, my terminal open kvantummanager, but it seems to be qt5-settings, I hate if they don’t use one name, or different, in other languages.

LOL, let me whoogle about :slight_smile:

Its just kvantum it includes the manager.

I was able now to get only …

 ╭─alnone@alnone in ~ as 🧙 took 13s
 ╰─λ LANG=C sudo pacman -Syu kvantum-qt5 kvantummanager
:: Synchronizing package databases...
 garuda is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 chaotic-aur             2.5 MiB  2.09 MiB/s 00:01 [----------------------] 100%
warning: kvantum-qt5-1.0.10-3 is up to date -- reinstalling
error: target not found: kvantummanager

 ╭─alnone@alnone in ~ as 🧙 took 1s
[🔴] × 

sudo pacman -Syu kvantum-qt5 kvantum
1 Like
 ╭─alnone@alnone in ~ as 🧙 took 25s
 ╰─λ LANG=C sudo pacman -Syu kvantum-qt5 kvantum
:: Synchronizing package databases...
 garuda is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 chaotic-aur is up to date
warning: kvantum-qt5-1.0.10-3 is up to date -- reinstalling
warning: kvantum-1.0.10-3 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (2)        Old Version  New Version  Net Change

extra/kvantum      1.0.10-3     1.0.10-3       0.00 MiB
extra/kvantum-qt5  1.0.10-3     1.0.10-3       0.00 MiB

Total Installed Size:  8.91 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(2/2) checking keys in keyring                     [----------------------] 100%
(2/2) checking package integrity                   [----------------------] 100%
(2/2) loading package files                        [----------------------] 100%
(2/2) checking for file conflicts                  [----------------------] 100%
(2/2) checking available disk space                [----------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 79
:: Processing package changes...
(1/2) reinstalling kvantum                         [----------------------] 100%
(2/2) reinstalling kvantum-qt5                     [----------------------] 100%
:: Running post-transaction hooks...
(1/8) Arming ConditionNeedsUpdate...
(2/8) Foreign/AUR package notification
=> No foreign/AUR packages found.
(3/8) Orphaned package notification...
irqbalance 1.9.3-2
preload 0.6.4-9
(4/8) Checking for .pacnew and .pacsave files...
.pac* files found:
Please check and merge
(5/8) Updating icon theme caches...
(6/8) Updating the desktop file MIME type cache...
(7/8) Performing snapper post snapshots for the following configurations...
==> root: 80
(8/8) Syncing all file systems...

 ╭─alnone@alnone in ~ as 🧙 took 16s

kvantum does not change anything in the system, I tried several options, thanks.

Did you try the link?

Did you search the web?

Did you reboot?

If you need another look and don’t know how to set use GNOME, Hyprland, Sway or KDE from Garuda.


‘Kvantum (default)’ is back again and again …

Did you get this through configurations?:

If so apparently I am not able to do it, I do not have the basic knowledge … now, you recommend other desktops, I have always been a user of Xfce4 and I have not stayed on others, because they have always seemed to me ‘not intuitive’, do you think that maybe Cinnamom is a good choice for me? - I guess I can install it also here as another desktop without problems.


Sure, it’s very nice.
But, nwg-look

or lxappearance-gtk3

are easy to use, and give you the same look.

Ahh, its adwaita-dark, you must install this theme.


Just follow the guide SGS linked above:

It explains step by step how to download and install themes for both GTK and QT apps, and has some other good tips as well. You can skip over the rest of the guide and just follow the theming advice if you want.


I tried to keep everything as simple as possible.


Someone definitely set up the very nice Garuda app shown in the screenshot above.

Of course I saw the instructions in the link and installed nwg-look, etc and it looks much better now in Xfce4, but the problem is with the Garuda apps, these don’t change, are still as pale as before, and kvantum didn’t work either, the Xfce4 desktop has no relation with Garuda/system – BTW in Cinnamon it was a much worse experience, not even ‘nwg-look’ worked, I was so frustrated that I uninstalled it. Maybe all of this it is due to the installation is into Spanish and not in English (?).

Have you tried this advice in the guide?

Note: An update of Kvantum broke the theming of the Garuda Apps. If you find this is the case on your machine open the terminal and enter sudo pacman -S kvantum-qt5 - this install will restore the theming of the apps.