Application window goes behind under panel in KDE Plasma (Latte Dock)

I have dual monitor setup. Whenever I maximize any window it always goes below under the top panel of latte.

I have already set it up with "Always Visible". Whenever I switch to single monitor it fixes itself but when I enable my other monitor again it covers the maximized windows again.

When I create a new user it behaves as normal.

Can anyone point out which config file is responsible for this behavior?

Hi there, welcome!
I'm not sure I fully understood your issue, but maybe it could be something like this one? Or anyway the solution and hints might guide you in the right direction...

3 Likes

You are propably in a multi-screen environment. The in question top panel is probably between your two monitors. Panels and docks that are between screens they lose that characteristic under x11 and kwin combination. KWin can not handle the case under x11 and for that reason it is blocked.

If you use plasma panels you will get same results. Plasma has also blocked that characteristic under x11.

3 Likes

If I add an empty plasma panel the maximized window does not go under the panel. The always visible option seems to work for them.

Sadly I cannot upload any images as a new user to clarify my issue.

The strange thing is that is happened all of a sudden. When I put a latte panel at the bottom of my screen the windows do not go under the panel.

  1. Are you or are you not using a multi-screen environment?
  2. Isnt your top panel between two of your monitors?
  3. Plasma failing to identify the scenario is not Latte fault
  4. If you report the case to Plasma they will also consider it a bug of Plasma
  5. Working? Really? Can you place any window at the screen above your top panel?

Your screen above your top panel is useless when using plasma panels and they don't identify the scenario.

2 Likes
  1. Are you or are you not using a multi-screen environment?
    Yes, my primary screen is on the left bottom orientated in landscape, My secondary screen is above my primary screen. My third screen is in portrait mode on the right hand side of the 2 other screens.

  2. Isnt your top panel between two of your monitors?
    Yes it is located between my primary and second screen.

  3. Plasma failing to identify the scenario is not Latte fault
    Plasma panels acts as normal and are always visible. When a windows is maximized it does not
    cover the window. As for latte it does.

  4. If you report the case to Plasma they will also consider it a bug of Plasma
    I don't think plasma will consider this as a bug because my widgets on the desktop move down when I move the latte panel from the bottom to the top of my screen.

  5. Working? Really? Can you place any window at the screen above your top panel?
    For the latte panel it is not working. But it is for a plasma panel. Any window that I maximize maximizes full screen. Acting as that the panel isn't there. And thus they go under the panel. So for example my browser tabs are not visible because they are hidden underneath the panel.

Since I cannot upload any pictures as a new user I will upload one to Imgur.

Latte panel:
https://i.imgur.com/mMpDUfJ.png

Plasma panel:
https://i.imgur.com/3uACJiM.png

I tried to explain you but you dont consider it a bug. My proposal is to use plasma panels if that makes a workable system for you.

Latte wont change anything related to this until kwin supports properly the case. Plasma can continue providing a broken experience, no problem from my side.

2 Likes

plasma-workspace/panelview.cpp at master · KDE/plasma-workspace · GitHub this is the plasma panel code reference that should work at this scenario but as it appears it fails.

2 Likes

This is one of those awkward moments...

@D03mpie was right, struts should always be forwarded to KWin and KWin should take responsibility.... always trust KWin for setting struts (0f7a4bcd) · Commits · Plasma / Latte Dock · GitLab fixed in upcoming 0.10.7 .

If struts(AlwaysVisible) mode fails then KWin should take responsibility.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.