Alacritty Garuda theme (restoration)

I had some Alacritty errors, so I did a config reset (as seen somewhere on this forum):

After deleting the config folder, I solved the errors but ...

I lost the beautiful Garuda theme. :frowning:

Please help me restore the Garuda theme! (Timeshift didn't work)

Welcome to the forum :slight_smile:
Get the config from /etc/skel

cp /etc/skel/.config/alacritty/alacritty.yml ~/.config/alacritty/alacritty.yml

Need to look into whats causing the error (happened since last update of Alacritty) :thinking:

I had the same error after an update, found out I just had to remove the # before a newly added line into the config file:

- --login
1 Like

I get

cp: cannot create regular file '/home/kitwar/.config/alacritty/alacritty.yml': No such file or directory

I need someone to give me that original alacritty.yml, isn't it?

You can grab it from the guest account.

1 Like

Awesome, it worked! :smiley:

So, to formulate the solution for future users:

Here's a link to the default file with the fixed error: :open_file_folder:

You'd copy this to ~/.config/alacritty/ (if the folder is missing, create alacritty it in ~/.config/)

⠶ Manual method :wrench:

ERROR PROBLEM ( thx @joojmachine )

In the ~/.config/alacritty/alacritty.yml file, replace

# args:
# - --login
- --login

THEME PROBLEM ( thx @dr460nf1r3 & @Zod )

cp /home/guest/.config/alacritty/alacritty.yml ~/.config/alacritty/alacritty.yml
  • might need to create the alacritty folder in ~/.config/ first.

or if you messed with the file but didn't delete it:

cp /etc/skel/.config/alacritty/alacritty.yml ~/.config/alacritty/alacritty.yml

Fix Alacritty config (72718ddf) · Commits · Garuda Linux / Themes and Settings / Settings / garuda-dr460nized · GitLab to get the default file with the error fixed if the above link doesn't work. :grinning:


I am having a similar issue in which I created a file in ~/.config/fish/. The alacritty configuration is untouched, yet my settings are overwritten (?).

Please no pictures from terminal output.
Open new thread, this one is solved.
Path is

cd /home/$USER/.config/alacritty/
micro alacritty.yml


micro /home/$USER/.config/alacritty/alacritty.yml

it must be