After updating windows/bios, this OS no longer appears as a boot option

Just as it sounds, does no even go into GRUB if it even is there anymore. I think I know how to fix this, somebody just please show me how to reinstall grub properly with chroot.
I tried this:

But it just gives me:
mount: /mnt: mount failed: Operation not permitted.

What am I supposed to do? All I want to do is chroot

Search in forum, please.
There is more than one thread about.

I know, I've looked at them as well, that was the most informative of the half-dozen

BTW, I fixed it with petsam's "wiki" post, after booting in Garuda I must use

sudo update-grub

it dos not work from chroot.

Grub was over-written by the windows update, how is updating going to help when it doesn't exist? I'll try what you said but it doesn't make much sense to me...

When? Please provide the exact input and output

1 Like

You post here a text without value, out of context, we are not psychics, how about you post everything?

1 Like

BTW, this is why we discourage and do not support dual boot. Those who can't fix it should delete M$ or do without Linux.

1 Like

Like I had said, I was following this solution, right here:

I know you're not psychics but you can infer.

I inputted (as the solution suggested):

sudo mount /dev/sdxy /mnt

What did you use for /dev/sdxy?

Show me how to run Excel without Microsoft and fix Pipewire, but until then, no, I cannot get rid of M$

Thats normal :slight_smile:

sudo mount /dev/sdxy /mnt
mount: /mnt: Spezialgerät /dev/sdxy ist nicht vorhanden.
       dmesg(1) könnte nach einem fehlgeschlagenen mount-Systemaufruf
       weitere Informationen liefern.
1 Like

Please check this

2 Likes

Thank you but I'm stuck at one final place, I cannot install grub do to a read-only file system.

sh-5.1# sudo grub-install /dev/sda
Installing for x86_64-efi platform.
grub-install: error: cannot backup `/boot/grub/x86_64-efi/acpi.mod': Read-only file system.
sh-5.1# sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
grub-install: error: cannot backup `/boot/grub/x86_64-efi/acpi.mod': Read-only file system.
sh-5.1# sudo update-grub
/usr/bin/grub-mkconfig: line 262: /boot/grub/grub.cfg.new: Read-only file system
sh-5.1#

Any ideas on how to fix this?

EDIT:
Never mind actually... it's probably just fast boot enabled that's causing this (although I'm unsure)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.