After updating from 6.6.1 1-1-zen my screen won't come back on from sleep

~ ❯ garuda-inxi
  Kernel: 6.6.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=24c0577f-ba95-4525-a1c8-cee208707548 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: Z590 Pro4 serial: <superuser required>
    UEFI: American Megatrends LLC. v: P1.60 date: 06/17/2021
  Info: model: 11th Gen Intel Core i5-11400 bits: 64 type: MT MCP
    arch: Rocket Lake gen: core 11 level: v4 note: check built: 2021+
    process: Intel 14nm family: 6 model-id: 0xA7 (167) stepping: 1
    microcode: 0x5D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/4400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 62208
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Micro-Star MSI
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-10; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DP-1 empty: DP-2, DP-3, DVI-D-1, HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
    s-diag: 692mm (27.26")
  Monitor-1: DP-1 mapped: DP-0 note: disabled model: Acer XB270HU
    serial: <filter> built: 2013 res: 2560x1440 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9
    modes: 2560x1440
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    memory: 7.81 GiB
  API: Vulkan v: 1.3.269 layers: 10 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 1070 driver: nvidia v: 545.29.06
    device-ID: 10de:1b81 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: Intel Tiger Lake-H HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:43c8 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  API: ALSA v: k6.6.4-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Fujitsu Client driver: rtw89_8852ae v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 03:00.0 chip-ID: 10ec:8852
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
  Device-1: Fujitsu Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:6 chip-ID: 04c5:165c
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
  Local Storage: total: 983.83 GiB used: 581.37 GiB (59.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Neo Forza
    model: NFP075PCI51-3400000 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: ECFM22.7 temp: 27.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Corsair model: Force LE SSD
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 12.2 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: Flash Drive
    size: 59.75 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.1 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
    fw-rev: 1100 scheme: MBR
  ID-1: / raw-size: 140.81 GiB size: 140.81 GiB (100.00%)
    used: 96.97 GiB (68.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.7 MiB (26.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 140.81 GiB size: 140.81 GiB (100.00%)
    used: 96.97 GiB (68.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 140.81 GiB size: 140.81 GiB (100.00%)
    used: 96.97 GiB (68.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-5: /var/tmp raw-size: 140.81 GiB size: 140.81 GiB (100.00%)
    used: 96.97 GiB (68.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 53 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
  Processes: 446 Uptime: 1m wakeups: 0 Memory: total: 16 GiB
  available: 15.48 GiB used: 3.16 GiB (20.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1685 libs: 531 tools: pamac,pikaur,yay Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
  System install date:     2023-03-09
  Last full system update: 2023-12-06 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:  

~ ❯
My system is a Asrock Z590 Pro 4 motherboard and intel 11400 cpu, gtx 1070 gpu, adata 16GB 3600mhz ram, NeoForza 500 GB NVME, and I have another corsair regular ssd 480GB.
After updating from 6.6.1 1-1 My screen won’t come back on from sleep also the plymoth text starts reguar size gets big and then back small. I’ve held the upgrade for kernel and nvidia drivers neither fixed it when updating had to roll back
Also, other than problems listed in title part of the text disappears when rebooting from plymouth screen and sometimes the whole screen turns a gray color. But I use the sleep alot so I’ve had to roll back till I get it figured out. I read that you all removed plymouth from new build, but I’ve been running this version for like a year so my system still has plymouth on it, and I’m afraid to mess with it to see if it’s the problem without instructions. I’ve done a lot of tweaks to how kde plasma looks; I’d hate to have to reinstall. Any help would be appreciated Thanks, Jonathan PS

Here’s a list of packages that are installed when it messes up the sleep and text size on boot.

Starting full system upgrade... 
resolving dependencies... 
looking for conflicting packages... 
warning: dependency cycle detected: 
warning: qt6-multimedia-ffmpeg will be installed before its qt6-multimedia dependency 

Packages (233) aisleriot-3.22.30-1  akonadi-23.08.3-2  akonadi-contacts-23.08.3-2  akonadi-notes-23.08.3-2 
              alsa-card-profiles-1:1.0.0-2  aom-3.7.1-1  appstream-1.0.0-5  appstream-qt5-1.0.0-5 
              archlinux-appstream-data-20231203-1  avahi-1:0.8+r189+g35bb1ba-1  bash-5.2.021-1  blas-3.12.0-2 
              bluedevil-1:5.27.10-1  breeze-5.27.10-1  breeze-gtk-5.27.10-1  c-ares-1.23.0-1  ca-certificates-mozilla-3.95-1 
              calcmysky-0.3.1-1.1  cblas-3.12.0-2  cfitsio-1:4.3.1-1  cmake-3.27.9-1  dtkcommon-5.6.20-1  dtkcore-1:5.6.20-1 
              dtkgui-1:5.6.20-1  dtkwidget-5.6.20-1  enchant-2.6.3-1  faad2-2.11.1-1  faudio-23.11-1  feh-3.10.2-1 
              ffmpeg-2:6.1-2  floorp-11.6.1-1  fwupd-1.9.10-1  fzf-0.44.1-1  garuda-nvidia-config-2:1.1.6-1 
              garuda-video-linux-config-2:1.1.6-1  gettext-0.22.4-1  git-2.43.0-1  glslang-13.1.1-2  gnupg-2.4.3-2 
              google-chrome-120.0.6099.71-1  gpgme-1.23.2-1  grantleetheme-23.08.3-2  gst-plugin-pipewire-1:1.0.0-2 
              heroic-games-launcher-bin-2.11.0-1  imagemagick-  intel-gmmlib-22.3.14-1 
              intel-media-driver-23.4.2-1  iptables-nft-1:1.8.10-1  kactivitymanagerd-5.27.10-1  kde-cli-tools-5.27.10-1 
              kde-gtk-config-5.27.10-1  kdecoration-5.27.10-1  khotkeys-5.27.10-1  kidentitymanagement-23.08.3-2 
              kinfocenter-5.27.10-1  kmenuedit-5.27.10-1  kmime-23.08.3-2  kontactinterface-23.08.3-2 
              kpimtextedit-23.08.3-2  kpipewire-5.27.10-1  kscreen-5.27.10-1  kscreenlocker-5.27.10-1 
              ksystemstats-5.27.10-1  ktextaddons-1.5.2-4  kwallet-pam-5.27.10-1  kwin-5.27.10-1  lapack-3.12.0-2 
              layer-shell-qt-5.27.10-1  lcms2-2.16-1  lib32-gettext-0.22.4-1  lib32-libdecor-0.2.1-1 
              lib32-libpipewire-1:1.0.0-1  lib32-libtiff-4.6.0-2  lib32-libxml2-2.12.2-1  lib32-nss-3.95-1 
              lib32-nvidia-utils-545.29.06-1  lib32-opencl-nvidia-545.29.06-1  lib32-pipewire-1:1.0.0-1 
              lib32-pipewire-jack-1:1.0.0-1  lib32-readline-8.2.007-1  lib32-util-linux-2.39.3-1  libadwaita-1:1.4.2-1 
              libakonadi-23.08.3-2  libavif-1.0.3-1  libcap-2.69-3  libcmis-0.6.2-1  libde265-1.0.14-1  libdecor-0.2.1-1 
              libheif-1.17.5-2  libibus-1.5.29-2  libindi-2.0.5-1  libksba-1.6.5-1  libkscreen-5.27.10-1 
              libksysguard-5.27.10-1  liblangtag-0.6.7-1  libmirage-3.2.7-1  libnl-3.9.0-1  libpamac-aur-11.6.2-2 
              libpipewire-1:1.0.0-2  libpulse-16.1-7  libqaccessibilityclient-qt5-0.6.0-1  libqalculate-4.9.0-1 
              libreoffice-still-7.5.8-2  libtiff-4.6.0-2  liburing-2.5-1  libvirt-1:9.10.0-1  libvirt-glib-5.0.0-1 
              libvirt-python-1:9.10.0-1  libwacom-2.9.0-2  libwbclient-4.19.3-1  libwireplumber-0.4.17-1  libxisf-0.2.10-1 
              libxml2-2.12.2-1  libxnvctrl-545.29.06-1  lilv-0.24.22-1  linux-firmware-20231110.74158e7a-1 
              linux-firmware-whence-20231110.74158e7a-1  linux-lts-6.1.65-1  linux-lts-headers-6.1.65-1 
              linux-zen-6.6.4.zen1-1  linux-zen-headers-6.6.4.zen1-1  lsof-4.99.0-1  mariadb-11.2.2-1 
              mariadb-clients-11.2.2-1  mariadb-libs-11.2.2-1  mhwd-db-garuda-2:1.1.6-1 
              microsoft-edge-dev-bin-121.0.2220.3-1  milou-5.27.10-1  mlt-7.22.0-1  mujs-1.3.4-1  multipath-tools-0.9.7-4 
              noto-fonts-1:23.12.1-1  noto-fonts-emoji-1:2.042-1  nss-3.95-1  nvidia-dkms-545.29.06-1 
              nvidia-settings-545.29.06-1  nvidia-utils-545.29.06-1  onevpl-2023.4.0-1  opencl-nvidia-545.29.06-1 
              opera-105.0.4970.34-1  opera-ffmpeg-codecs-119.0.6045.199-1  oxygen-sounds-5.27.10-1  pamac-aur-11.6.0-4 
              patool-2.0.0-2  pcsclite-2.0.1-1  perl-5.38.1-1  pipewire-1:1.0.0-2  pipewire-alsa-1:1.0.0-2 
              pipewire-audio-1:1.0.0-2  pipewire-jack-1:1.0.0-2  pipewire-pulse-1:1.0.0-2  pipewire-v4l2-1:1.0.0-2 
              pipewire-x11-bell-1:1.0.0-2  pipewire-zeroconf-1:1.0.0-2  pkgconf-2.1.0-2  plasma-desktop-5.27.10-1 
              plasma-integration-5.27.10-1  plasma-nm-5.27.10-1  plasma-pa-5.27.10-1  plasma-workspace-5.27.10-1 
              polkit-kde-agent-5.27.10-1  poppler-23.12.0-1  poppler-glib-23.12.0-1  poppler-qt5-23.12.0-1 
              powerdevil-5.27.10-1  protobuf-25.1-1  proton-ge-custom-2:GE.Proton8.25-1 
              protontricks-git-1.10.5.r13.g26952ae-1  pugixml-1.14-1  python-3.11.6-1  python-attrs-23.1.0-1 
              python-certifi-2023.11.17-1  python-cryptography-41.0.7-1  python-fastjsonschema-2.19.0-1 
              python-fonttools-4.46.0-1  python-grpcio-1.59.3-1  python-numpy-1.26.2-1  python-platformdirs-4.1.0-1 
              python-protobuf-25.1-1  python-pydantic-2.5.2-1  python-pydantic-core-1:2.14.5-1  python-setuptools-1:68.2.1-1 
              python-trove-classifiers-2023.11.29-1  python-urllib3-1.26.18-1  qbittorrent-4.6.2-2  qgpgme-qt5-1.23.2-1 
              qt5-base-5.15.11+kde+r147-1  qt6-base-6.6.1-1  qt6-charts-6.6.1-1  qt6-declarative-6.6.1-1 
              qt6-multimedia-6.6.1-1  qt6-multimedia-ffmpeg-6.6.1-1  qt6-positioning-6.6.1-1  qt6-serialport-6.6.1-1 
              qt6-svg-6.6.1-1  qt6-translations-6.6.1-1  qt6-webchannel-6.6.1-1  qt6-webengine-6.6.1-1  readline-8.2.007-1 
              rtl-sdr-1:2.0.1-3  samba-4.19.3-1  sddm-kcm-5.27.10-1  shaderc-2023.7-2  smbclient-4.19.3-1  snapper-0.10.7-1 
              sord-0.16.16-1  spirv-tools-2023.5-1  spotify-1:  sqlite-3.44.2-2  sratom-0.6.16-1 
              systemsettings-5.27.10-1  ttf-firacode-nerd-3.1.1-1  ufw-extras-1.0.0-1  ugrep-4.3.5-1  util-linux-2.39.3-1 
              util-linux-libs-2.39.3-1  v4l-utils-1.26.0-1  verdict-1.4.2-1  vim-9.0.2143-1  vim-runtime-9.0.2143-1 
              webkit2gtk-2.42.3-1  webkit2gtk-4.1-2.42.3-1  wine-8.21-2  winetricks-20230212-2  wireplumber-0.4.17-1 
              xapian-core-1:1.4.24-1  xapp-2.8.1-1  xdg-desktop-portal-1.18.2-1  xdg-desktop-portal-kde-5.27.10-1 
              xdg-utils-1.2.0r25+g0f49cf5-1  yay-12.2.0-1  zix-0.4.2-2  zsh-theme-powerlevel10k-git-r4212.47b0187a-1 

Total Download Size:    417.32 MiB 
Total Installed Size:  9181.72 MiB 
Net Upgrade Size:       887.50 MiB

Hi there, welcome to the forum.
The text you describe is not Plymouth, which is a graphical splash screen in the early booting stages (before login) and is no more configured in your system (splash does not appear in your boot parameters). You can remove that text at all using Garuda Boot Options and removing quiet there.
I see you have also the linux-lts kernel installed.
Do you have the same problems if you boot with it?

1 Like

Just a little popup (i have actually no time for helping):
His display server (x11) does not load the module Xwayland.
He has the same problem as this user:

Hey TurboTux, I have xfce so no wayland is used. Not sure if these are the same problems.

@brynsky` that was just a hint. You have completely different hardware and different DE’s/DM’s.
Similarities are error description, installation date, update date, topic date and X11 with missing xwayland module. This doesn’t have to be related, so it was just a small hint :slight_smile:

1 Like

I only have one displayport montior; I do have a icc color profile put in for it don’t know if that matters. I got the idea it was something like that that’s why I held back the nvidia drivers to see if it still did it. Like I said I also tried to hold back the kernel from updating and that didn’t help for me LTS kernel doen’t fix it either. If I install that Xwayland would it help or is there some way I need to tell it I only have one monitor? I can try to disable the text if you think it would help with the monitor not waking from sleep the pc does but not the monitor.

Please REBOOT/Restart

1 Like

After making a list of the updates, I rebooted my device. That’s when it messes up on the screen not waking from sleep and the text size changing back and forth on boot; or is it something else your asking me to do after I reboot?

please refer to :


and there is more , I’m sure you will find a solution if you search in the forum

I decided to reinstall thanks for trying to help everyone

1 Like